math/py-graphillion: Update to 0.99

- Update PORTVERSION and distinfo checksum (0.99)
- Switch to CHEESESHOP (now includes license file)
- Add LICENSE_FILE
- Remove unecessary setup.py patch, zip_safe override no longer needed

Changes:

  https://github.com/takemaru/graphillion/compare/v0.98...v0.99
This commit is contained in:
Kubilay Kocak 2016-03-03 10:54:53 +00:00
parent 196e67a9e6
commit b634f9269b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=410030
3 changed files with 8 additions and 16 deletions

View File

@ -2,24 +2,24 @@
# $FreeBSD$
PORTNAME= graphillion
PORTVERSION= 0.98
DISTVERSIONPREFIX= v
PORTVERSION= 0.99
CATEGORIES= math python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME:S/g/G/}-${PORTVERSION}
MAINTAINER= koobs@FreeBSD.org
COMMENT= Fast, lightweight graphset operation library in Python
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
USES= python
USE_GITHUB= yes
USE_PYTHON= distutils autoplist
GH_ACCOUNT= takemaru
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/_graphillion.so
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/_graphillion.so
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test

View File

@ -1,2 +1,2 @@
SHA256 (takemaru-graphillion-v0.98_GH0.tar.gz) = f9e7995352d7da510f47f3c322753486b1b2482aaf673359d906b0c32e0fcfb4
SIZE (takemaru-graphillion-v0.98_GH0.tar.gz) = 1588861
SHA256 (Graphillion-0.99.tar.gz) = e635f8c12a94abd4fe13bd99e33a326a661ac7d13198b6fbb11060c117b19ab0
SIZE (Graphillion-0.99.tar.gz) = 1041596

View File

@ -1,8 +0,0 @@
--- ./setup.py.orig 2013-06-21 19:44:04.348822813 +1000
+++ ./setup.py 2013-06-21 19:44:14.872371187 +1000
@@ -51,4 +51,5 @@
),
],
test_suite='graphillion.test',
+ zip_safe=False,
)