Update to 0.2

PR:		ports/14541
Submitted by:	Ade Lovett<ade@lovett.com>
This commit is contained in:
Yukihiro Nakai 1999-10-27 10:26:20 +00:00
parent 18d1bf8323
commit b5f93939d8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=22687
4 changed files with 24 additions and 35 deletions

View File

@ -1,12 +1,12 @@
# New ports collection makefile for: gdk-pixbuf
# Version required: 0.2
# Version required: 0.3
# Date created: 5th October 1999
# Whom: Ade Lovett <ade@lovett.com>
#
# $FreeBSD$
#
DISTNAME= gdk-pixbuf-0.2
DISTNAME= gdk-pixbuf-0.3
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gdk-pixbuf
@ -16,12 +16,14 @@ MAINTAINER= ade@lovett.com
LIB_DEPENDS= gnome.3:${PORTSDIR}/x11/gnomelibs
GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/giflib" \
GLIB_CONFIG="${GLIB_CONFIG}" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (gdk-pixbuf-0.2.tar.gz) = d8d17d81a42494b9467e4ed292b65b49
MD5 (gdk-pixbuf-0.3.tar.gz) = e4f6c284723e77439700aaa6cbb854fc

View File

@ -1,17 +1,6 @@
--- configure.orig Tue Sep 28 13:50:52 1999
+++ configure Tue Oct 5 16:16:32 1999
@@ -2702,8 +2702,8 @@
echo "configure:2703: checking whether to build gmodulized gdk-pixbuf" >&5
oLIBS="$LIBS"
oCFLAGS="$CFLAGS"
-LIBS="$LIBS `glib-config --libs gmodule`"
-CFLAGS="$CFLAGS `glib-config --cflags gmodule`"
+LIBS="$LIBS `$GLIB_CONFIG --libs gmodule`"
+CFLAGS="$CFLAGS `$GLIB_CONFIG --cflags gmodule`"
if test "$cross_compiling" = yes; then
{ echo "configure: error: can not run test program while cross compiling" 1>&2; exit 1; }
else
@@ -2752,8 +2752,8 @@
--- configure.orig Wed Oct 20 17:15:24 1999
+++ configure Fri Oct 22 10:26:25 1999
@@ -3028,8 +3028,8 @@
#define USE_GMODULE 1
EOF
@ -22,23 +11,22 @@
echo "$ac_t""yes" 1>&6
@@ -3696,8 +3696,8 @@
fi
@@ -3561,8 +3561,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-lgif echo "configure: warning: *** Native GIF support will not be built" 1>&2;
- gifok=no $LIBS"
+LIBS="-lgif $GTK_LIBS $LIBS"
cat > conftest.$ac_ext <<EOF
#line 3568 "configure"
#include "confdefs.h"
--- Makefile.in.orig Wed Oct 20 17:34:44 1999
+++ Makefile.in Fri Oct 22 10:22:14 1999
@@ -94,7 +94,7 @@
VERSION = @VERSION@
GDK_PIXBUF_LIBDIR='-L${libdir}'
-GDK_PIXBUF_INCLUDEDIR="-I${includedir} `gnome-config --cflags glib libart` `glib-config --cflags gmodule`"
-GDK_PIXBUF_LIBS="$LIBS `gnome-config --libs glib libart` `glib-config --libs gmodule` -lgdk_pixbuf"
+GDK_PIXBUF_INCLUDEDIR="-I${includedir} `gnome-config --cflags glib libart` `$GLIB_CONFIG --cflags gmodule`"
+GDK_PIXBUF_LIBS="$LIBS `gnome-config --libs glib libart` `$GLIB_CONFIG --libs gmodule` -lgdk_pixbuf"
--- Makefile.in.orig Tue Sep 28 13:54:53 1999
+++ Makefile.in Tue Oct 5 16:23:16 1999
@@ -101,7 +101,7 @@
ZVT_LIBS = @ZVT_LIBS@
SUBDIRS = macros src
SUBDIRS = src
-confexecdir = $(libdir)
+confexecdir = $(sysconfdir)
confexec_DATA = gdk_pixbufConf.sh

View File

@ -1,5 +1,4 @@
etc/gdk_pixbufConf.sh
include/gdk-pixbuf/gdk-pixbuf-io.h
include/gdk-pixbuf/gdk-pixbuf.h
lib/gdk-pixbuf/loaders/libpixbuf-gif.so
lib/gdk-pixbuf/loaders/libpixbuf-jpeg.so
@ -8,7 +7,7 @@ lib/gdk-pixbuf/loaders/libpixbuf-tiff.so
lib/gdk-pixbuf/loaders/libpixbuf-xpm.so
lib/libgdk_pixbuf.a
lib/libgdk_pixbuf.so
lib/libgdk_pixbuf.so.0
lib/libgdk_pixbuf.so.1
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
@dirrm include/gdk-pixbuf