net-im/jabberd: remove dependency on autoconf-archive
This commit is contained in:
parent
d201617835
commit
b5e37fea97
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=482837
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= jabberd
|
||||
PORTVERSION= 2.6.1
|
||||
PORTREVISION= 5
|
||||
PORTREVISION= 6
|
||||
CATEGORIES= net-im
|
||||
MASTER_SITES= https://github.com/jabberd2/jabberd2/releases/download/${PORTNAME}-${DISTVERSION}/ \
|
||||
LOCAL/matthew/${PORTNAME}
|
||||
@ -17,8 +17,6 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
|
||||
libgsasl.so:security/gsasl \
|
||||
libidn.so:dns/libidn \
|
||||
libudns.so:dns/udns
|
||||
BUILD_DEPENDS= autoconf-archive>=0:devel/autoconf-archive
|
||||
|
||||
USES= autoreconf compiler:c11 iconv libtool perl5 ssl tar:xz
|
||||
|
||||
OPTIONS_DEFINE= MYSQL PGSQL LDAP BDB SQLITE PAM PIPE ANON FS DEBUG REQUIRES \
|
||||
|
@ -1,6 +1,17 @@
|
||||
--- configure.ac.orig 2017-07-01 15:27:52 UTC
|
||||
+++ configure.ac
|
||||
@@ -406,9 +406,9 @@ if test "x-$want_ssl" != "x-no" ; then
|
||||
@@ -74,10 +74,6 @@ if test "x-$want_mio_debug" = "x-yes" ; then
|
||||
AC_DEFINE(MIO_DEBUG,1,[Define to 1 if you want to enable managed IO debug output.])
|
||||
fi
|
||||
|
||||
-# Colorized build output
|
||||
-AX_CHECK_COMPILE_FLAG([-fdiagnostics-color], [CFLAGS="${CFLAGS} -fdiagnostics-color"],
|
||||
- [AX_CHECK_COMPILE_FLAG([-fcolor-diagnostics], [CFLAGS="${CFLAGS} -fcolor-diagnostics"])])
|
||||
-
|
||||
# Two-step header checking. First check for headers which don't
|
||||
# require any other headers.
|
||||
AC_HEADER_DIRENT
|
||||
@@ -406,9 +402,9 @@ if test "x-$want_ssl" != "x-no" ; then
|
||||
fi
|
||||
AC_CHECK_HEADERS(openssl/crypto.h)
|
||||
if test "x-$ac_cv_header_openssl_crypto_h" = "x-yes" ; then
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- storage/authreg_mysql.c.orig 2018-10-22 23:49:34 UTC
|
||||
--- storage/authreg_mysql.c.orig 2016-05-22 15:52:07 UTC
|
||||
+++ storage/authreg_mysql.c
|
||||
@@ -489,6 +489,8 @@ DLLEXPORT int ar_init(authreg_t ar) {
|
||||
@@ -487,6 +487,8 @@ DLLEXPORT int ar_init(authreg_t ar) {
|
||||
MYSQL *conn;
|
||||
mysqlcontext_t mysqlcontext;
|
||||
int fail = 0;
|
||||
@ -9,7 +9,7 @@
|
||||
|
||||
/* configure the database context with field names and SQL statements */
|
||||
mysqlcontext = (mysqlcontext_t) malloc( sizeof( struct mysqlcontext_st ) );
|
||||
@@ -620,6 +622,7 @@ DLLEXPORT int ar_init(authreg_t ar) {
|
||||
@@ -618,6 +620,7 @@ DLLEXPORT int ar_init(authreg_t ar) {
|
||||
|
||||
mysql_options(conn, MYSQL_READ_DEFAULT_GROUP, "jabberd");
|
||||
mysql_options(conn, MYSQL_SET_CHARSET_NAME, "utf8");
|
||||
@ -17,7 +17,7 @@
|
||||
|
||||
/* connect with CLIENT_INTERACTIVE to get a (possibly) higher timeout value than default */
|
||||
if(mysql_real_connect(conn, host, user, pass, dbname, atoi(port), NULL, CLIENT_INTERACTIVE) == NULL) {
|
||||
@@ -628,9 +631,6 @@ DLLEXPORT int ar_init(authreg_t ar) {
|
||||
@@ -626,9 +629,6 @@ DLLEXPORT int ar_init(authreg_t ar) {
|
||||
}
|
||||
|
||||
mysql_query(conn, "SET NAMES 'utf8'");
|
||||
|
Loading…
Reference in New Issue
Block a user