Fix java.c Now we can invoke gij by typing java.

This commit is contained in:
Maho Nakata 2006-07-29 12:35:48 +00:00
parent 4b67be2fc9
commit b5d5619657
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=169040
2 changed files with 13 additions and 0 deletions

View File

@ -7,6 +7,7 @@
PORTNAME= java-gcj-compat
PORTVERSION= 1.0.56 # intentionally not upgrading
PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= ftp://sources.redhat.com/pub/rhug/
@ -31,6 +32,7 @@ CONFIGURE_ARGS+="-with-origin-name=gcj41" "--with-gcc-suffix=41" \
pre-configure:
@${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e "s|%%GCCSUFFIX%%|${GCJVER}|" ${WRKSRC}/java.c
post-install:
@${LN} -sf ${PREFIX}/lib/jvm/java-1.4.2-gcj41-1.4.2.0 ${PREFIX}/lib/jvm/java-gcj

View File

@ -0,0 +1,11 @@
--- java.c~ Sat Jul 29 21:29:35 2006
+++ java.c Sat Jul 29 21:29:52 2006
@@ -103,7 +103,7 @@
free (newpath);
- error_code = execv (GCJ_BIN_DIR "/gij", set_java_ext_dir (argc, argv));
+ error_code = execv (GCJ_BIN_DIR "/gij%%GCCSUFFIX%%", set_java_ext_dir (argc, argv));
fprintf (stderr, "error spawning gij\n");