New port: konwert
Konwert is a package for conversion between various character encodings. By encodings author imply not only different charsets like Windows-1252, KOI8-R or UTF-8 but also the different representations of characters like TeX escaping, quoted-printable and even RFC 1345 mnemonics. The autodetect of the encodings is also implemented. There are also filter filterm which allow to make separate input and output conversions of the encodings for the given command. It can help e.g. when our terminal is unable to display non-ASCII characters or to enter them from the keyboard. PR: 50614 Submitted by: Alex Semenyaka <alexs@snark.ratmir.ru>
This commit is contained in:
parent
0c80fc48a0
commit
b58e0621f4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=79294
@ -17,6 +17,7 @@
|
||||
SUBDIR += iconv-extra
|
||||
SUBDIR += iconv-rfc1345
|
||||
SUBDIR += ish
|
||||
SUBDIR += konwert
|
||||
SUBDIR += libiconv
|
||||
SUBDIR += libutf-8
|
||||
SUBDIR += mimelib
|
||||
|
42
converters/konwert/Makefile
Normal file
42
converters/konwert/Makefile
Normal file
@ -0,0 +1,42 @@
|
||||
# New ports collection makefile for: konwert
|
||||
# Date created: Apr 19 2003
|
||||
# Whom: Alex Semenyaka <alex@rinet.ru>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= konwert
|
||||
PORTVERSION= 1.8
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= converters
|
||||
MASTER_SITES= ${MASTER_SITE_DEBIAN}
|
||||
MASTER_SITE_SUBDIR= pool/main/${DISTNAME:C/${DISTNAME:C/.//}//}/${PORTNAME}
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
|
||||
|
||||
PATCH_SITES= ${MASTER_SITES}
|
||||
PATCH_SITE_SUBDIR= ${MASTER_SITE_SUBDIR}
|
||||
PATCHFILES= ${PORTNAME}_${PORTVERSION}-${PORTREVISION}.diff.gz
|
||||
|
||||
MAINTAINER= alexs@snark.rinet.ru
|
||||
COMMENT= Modular converter between charsets and filter
|
||||
|
||||
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2
|
||||
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
PATCH_WRKSRC= ${WRKDIR}
|
||||
|
||||
USE_REINPLACE= yes
|
||||
REINPLACE_ARGS= -i ""
|
||||
USE_PERL5= yes
|
||||
USE_GMAKE= yes
|
||||
|
||||
MAN1= konwert.1 trs.1 filterm.1
|
||||
MANLANG= "" pl
|
||||
MANCOMPRESSED= maybe
|
||||
|
||||
post-patch:
|
||||
@${GREP} -Rl '#\!/bin/bash' ${WRKSRC}/* 2>/dev/null | ${XARGS} \
|
||||
${REINPLACE_CMD} -e 's|^#\!/bin/bash|#\!${LOCALBASE}/bin/bash|'
|
||||
|
||||
.include <bsd.port.mk>
|
2
converters/konwert/distinfo
Normal file
2
converters/konwert/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
MD5 (konwert_1.8.orig.tar.gz) = 838e73ec911ebf25816135cbfd0f7a04
|
||||
MD5 (konwert_1.8-5.diff.gz) = d21594e55d60261de00e798bfa01687c
|
54
converters/konwert/files/patch-Makefile
Normal file
54
converters/konwert/files/patch-Makefile
Normal file
@ -0,0 +1,54 @@
|
||||
--- konwert-1.8/Makefile.old Thu Jul 30 20:43:04 1998
|
||||
+++ konwert-1.8/Makefile Sat Apr 5 02:33:30 2003
|
||||
@@ -14,3 +14,3 @@
|
||||
|
||||
-prefix = /usr/local
|
||||
+prefix = ${PREFIX}
|
||||
exec_prefix = $(prefix)
|
||||
@@ -48,3 +48,3 @@
|
||||
|
||||
-mydocdir = $(prefix)/doc/konwert-$(version)
|
||||
+mydocdir = $(prefix)/share/konwert/doc
|
||||
srcdocdir = doc
|
||||
@@ -257,3 +257,3 @@
|
||||
{ \
|
||||
- echo '#!/bin/bash -'; \
|
||||
+ echo '#!/usr/local/bin/bash -'; \
|
||||
echo; \
|
||||
@@ -274,3 +274,3 @@
|
||||
{ \
|
||||
- echo '#!/bin/bash -'; \
|
||||
+ echo '#!/usr/local/bin/bash -'; \
|
||||
echo; \
|
||||
@@ -294,3 +294,3 @@
|
||||
{ \
|
||||
- echo '#!/bin/bash -'; \
|
||||
+ echo '#!/usr/local/bin/bash -'; \
|
||||
echo; \
|
||||
@@ -337,13 +337,12 @@
|
||||
$(INSTALL) -m755 -s $(installbindir)/filterm $(bindir)
|
||||
- cp -dRf $(installfiltersdir)/* $(filtersdir)
|
||||
+ cp -Rf $(installfiltersdir)/* $(filtersdir)
|
||||
$(perl) $(srcdeveldir)/mkaliases $(srcdeveldir)/aliases \
|
||||
$(installfiltersdir) $(filtersdir)
|
||||
- cp -dRf $(installauxdir)/* $(auxdir)
|
||||
+ cp -Rf $(installauxdir)/* $(auxdir)
|
||||
$(perl) $(srcdeveldir)/mkaliases $(srcdeveldir)/aliases \
|
||||
$(installauxdir)/charsets $(auxdir)/charsets
|
||||
- cp -dRf $(installlibauxdir)/* $(libauxdir)
|
||||
- cp -dRf $(installdeveldir)/* $(develdir)
|
||||
- cp -dRf $(installdocdir)/* $(mydocdir)
|
||||
- cp -dRf $(installmandir)/* $(mandir)
|
||||
- if [ -z "$(nofixmanconfig)" ]; then $(srcauxdir)/fixmanconfig; fi
|
||||
+ cp -Rf $(installlibauxdir)/* $(libauxdir)
|
||||
+ cp -Rf $(installdeveldir)/* $(develdir)
|
||||
+ cp -Rf $(installdocdir)/* $(mydocdir)
|
||||
+ cp -Rf $(installmandir)/* $(mandir)
|
||||
|
||||
@@ -352,3 +351,5 @@
|
||||
uninstall:
|
||||
- rm -f $(bindir)/{trs,konwert,filterm}
|
||||
+ rm -f $(bindir)/trs
|
||||
+ rm -f $(bindir)/konwert
|
||||
+ rm -f $(bindir)/filterm
|
||||
rm -rf $(mylibdir) $(mysharedir) $(mydocdir)
|
12
converters/konwert/pkg-descr
Normal file
12
converters/konwert/pkg-descr
Normal file
@ -0,0 +1,12 @@
|
||||
Konwert is a package for conversion between various character encodings.
|
||||
|
||||
By encodings author imply not only different charsets like Windows-1252,
|
||||
KOI8-R or UTF-8 but also the different representations of characters like
|
||||
TeX escaping, quoted-printable and even RFC 1345 mnemonics.
|
||||
|
||||
There are also filter filterm which allow to make separate input and output
|
||||
conversions of the encodings for the given command. It can help e.g. when
|
||||
our terminal is unable to display non-ASCII characters or to enter them
|
||||
from the keyboard.
|
||||
|
||||
Maintains: Alex Semenyaka <alexs@snark.rinet.ru>
|
1001
converters/konwert/pkg-plist
Normal file
1001
converters/konwert/pkg-plist
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user