Move spidermonkey17's headers out of LOCALBASE and in there own subdir. [1]
This fixes build issues with other spidermonkey using ports when SM 1.7 is installed, due to SM 1.7's headers being found first. [2] Update SM 1.7 users to take this change into account. PR: 219761 [1], 214724 [2], 202246 [2] Approved by: maintainer timeout (nearly 2 months)
This commit is contained in:
parent
edcd495d20
commit
b56e9c435e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=446936
@ -19,6 +19,7 @@ TEST_DEPENDS= p5-Log-Log4perl>=0:devel/p5-Log-Log4perl
|
||||
|
||||
USE_PERL5= configure
|
||||
USES= perl5
|
||||
CFLAGS+= -I${LOCALBASE}/include/js-1.7/
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|libjs.a|libjs.so|' ${WRKSRC}/Makefile.PL
|
||||
|
@ -1,14 +1,17 @@
|
||||
--- Makefile.PL.orig 2010-11-17 13:51:38.000000000 +0100
|
||||
+++ Makefile.PL 2010-11-17 13:59:54.000000000 +0100
|
||||
@@ -71,11 +71,6 @@
|
||||
$include_dir =~ s/$c_header$//;
|
||||
push @JS_INCL_DIRS, $include_dir;
|
||||
}
|
||||
- foreach my $headerfile(glob "$include_path/*/$c_header") {
|
||||
- my $include_dir = $headerfile;
|
||||
--- Makefile.PL.orig 2011-10-23 12:27:21.000000000 +0200
|
||||
+++ Makefile.PL 2017-06-03 21:50:44.801687000 +0200
|
||||
@@ -68,13 +68,8 @@
|
||||
next if ! -f $libfile;
|
||||
my $include_path = $possible_install_paths{$install_path};
|
||||
foreach my $c_header(@c_header_files) {
|
||||
- if (-f "$include_path/$c_header") {
|
||||
+ if (-f "$include_path/js-1.7/$c_header") {
|
||||
my $include_dir = "$include_path/$c_header";
|
||||
- $include_dir =~ s/$c_header$//;
|
||||
- push @JS_INCL_DIRS, $include_dir;
|
||||
- }
|
||||
}
|
||||
if (scalar(@JS_INCL_DIRS) == scalar(@c_header_files)) {
|
||||
$JS_LIB_DIR = $libfile;
|
||||
- foreach my $headerfile(glob "$include_path/*/$c_header") {
|
||||
- my $include_dir = $headerfile;
|
||||
$include_dir =~ s/$c_header$//;
|
||||
push @JS_INCL_DIRS, $include_dir;
|
||||
}
|
||||
|
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= spidermonkey17
|
||||
DISTVERSION= 1.7.0
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= MOZILLA/js
|
||||
DISTNAME= js-${DISTVERSION}
|
||||
@ -40,7 +40,7 @@ JSH= jsapi.h jsarena.h jsarray.h jsatom.h jsautocfg.h jsbool.h \
|
||||
jsstr.h jstypes.h jsxdrapi.h jsxml.h \
|
||||
js.msg jsproto.tbl
|
||||
|
||||
PLIST_FILES= bin/js lib/libjs.so lib/libjs.so.1 ${JSH:S,^,include/,}
|
||||
PLIST_FILES= bin/js lib/libjs.so lib/libjs.so.1 ${JSH:S,^,include/js-1.7/,}
|
||||
WRKSRC= ${WRKDIR}/${SRC_DIR}
|
||||
EXTRACT_AFTER_ARGS= --exclude js/jsd
|
||||
|
||||
@ -63,6 +63,8 @@ do-install:
|
||||
${STAGEDIR}${PREFIX}/lib
|
||||
${LN} -sf libjs.so ${STAGEDIR}${PREFIX}/lib/libjs.so.1
|
||||
${CP} ${WRKSRC}/${OPSYS}`${UNAME} -r`_DBG.OBJ/jsautocfg.h ${WRKSRC}
|
||||
@${INSTALL_DATA} ${JSH:S,^,${WRKSRC}/,} ${STAGEDIR}${PREFIX}/include/
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/include/js-1.7
|
||||
@${INSTALL_DATA} ${JSH:S,^,${WRKSRC}/,} \
|
||||
${STAGEDIR}${PREFIX}/include/js-1.7/
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -66,7 +66,7 @@ MYSQL_CONFIGURE_ENABLE= mysql
|
||||
MYSQL_CONFIGURE_ON= --with-mysql-cfg="${LOCALBASE}/bin/mysql_config"
|
||||
|
||||
JS_CONFIGURE_ENABLE= libjs
|
||||
JS_CONFIGURE_ON= --with-js-h="${LOCALBASE}/include" \
|
||||
JS_CONFIGURE_ON= --with-js-h="${LOCALBASE}/include/js-1.7" \
|
||||
--with-js-libs="${LOCALBASE}/lib"
|
||||
JS_LIB_DEPENDS= libjs.so:lang/spidermonkey17
|
||||
|
||||
|
@ -94,7 +94,8 @@ XBELNARKS_CONFIGURE_OFF=--disable-xbel
|
||||
SPIDERMONKEY_BUILD_DEPENDS= ${LOCALBASE}/lib/libjs.so:lang/spidermonkey17
|
||||
SPIDERMONKEY_RUN_DEPENDS= js:lang/spidermonkey17
|
||||
SPIDERMONKEY_LIB_DEPENDS= libnspr4.so:devel/nspr
|
||||
SPIDERMONKEY_CFLAGS= -I${LOCALBASE}/include/nspr
|
||||
SPIDERMONKEY_CFLAGS= -I${LOCALBASE}/include/nspr \
|
||||
-I${LOCALBASE}/include/js-1.7
|
||||
SPIDERMONKEY_LDFLAGS= -lnspr4 -pthread -lpthread -lm
|
||||
SPIDERMONKEY_CONFIGURE_ON= --enable-sm-scripting --with-spidermonkey
|
||||
SPIDERMONKEY_CONFIGURE_OFF= --disable-sm-scripting --without-spidermonkey
|
||||
|
Loading…
Reference in New Issue
Block a user