- Fix incorrect accept(2) usage

- SIZE'ify and remove unneeded distfile from distinfo [1]
- Pet portlint [2]
- Bump PORTREVISION

PR:		ports/64088
Submitted by:	maintainer, trevor [1], krion [2]
This commit is contained in:
Kirill Ponomarev 2004-03-12 09:17:12 +00:00
parent 3bd1ad1a98
commit b53318104b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=103744
4 changed files with 14 additions and 7 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= ehnt
PORTVERSION= 0.3
PORTREVISION= 3
PORTREVISION= 4
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}

View File

@ -1,2 +1,2 @@
MD5 (ehnt-0.3.tar.gz) = 1477137f5207561cafb421864351562d
MD5 (ehnt_data-0.3.tar.gz) = b861e0fb0092c45c71b9048e9a4b1679
SIZE (ehnt-0.3.tar.gz) = 25795

View File

@ -2,7 +2,7 @@
$FreeBSD$
--- ehntserv.c.orig Thu Oct 4 22:18:29 2001
+++ ehntserv.c Thu Nov 14 22:18:40 2002
+++ ehntserv.c Fri May 30 14:16:22 2003
@@ -33,8 +33,8 @@
#define MAXCLIENTS 256
#define MAXPACKET 8192
@ -120,11 +120,18 @@ $FreeBSD$
for (i=0; i<MAXCLIENTS; i++) {
if (l_clients[i] > 0) {
if (FD_ISSET(l_clients[i],&write_fds)) {
@@ -220,9 +230,9 @@
@@ -215,14 +225,14 @@
if (FD_ISSET(l_fd,&read_fds)) { /*we have a new TCP client*/
int l_connfd,new_index=-1;
socklen_t l_addrlen;
- struct sockaddr * l_cliaddr;
+ struct sockaddr l_cliaddr;
/* printf("incoming connection on tcp 4444\n");*/
l_addrlen=sizeof(l_cliaddr);
if ( (l_connfd = accept(l_fd,(struct sockaddr *) l_cliaddr, &l_addrlen)) < 0)
- if ( (l_connfd = accept(l_fd,(struct sockaddr *) l_cliaddr, &l_addrlen)) < 0)
- { log_error("accept error"); exit(0); }
+ if ( (l_connfd = accept(l_fd, &l_cliaddr, &l_addrlen)) < 0)
+ { log_error("accept error"); exit(1); }
- SetTCPOpts(l_connfd);

View File

@ -1,7 +1,7 @@
bin/ehnt
etc/rc.d/ehntserv.sh.sample
sbin/ehntserv
%%PORTDOCS%%share/doc/ehnt/README
%%PORTDOCS%%%%DOCSDIR%%/README
share/ehnt/asnc.txt
@dirrm share/ehnt
%%PORTDOCS%%@dirrm share/doc/ehnt
%%PORTDOCS%%@dirrm %%DOCSDIR%%