Update to version 2.2.11.

PR:		10374
Submitted by:	Pedro F. Giffuni <pfgiffuni@bachue.usc.unal.edu.co>
This commit is contained in:
Steve Price 1999-03-15 01:27:27 +00:00
parent 3c30c9578b
commit b530ac6901
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=17192
5 changed files with 46 additions and 49 deletions

View File

@ -1,27 +1,32 @@
# New ports collection makefile for: FreeWAIS_sf-2.1.2
# Version required: 2.1.1
# New ports collection makefile for: FreeWAIS-sf
# Version required: 2.2.11
# Date created: 19 November 1996
# Whom: Pedro Giffuni
#
# $Id: Makefile,v 1.6 1998/11/28 05:39:01 asami Exp $
# $Id: Makefile,v 1.7 1998/12/09 20:47:38 billf Exp $
#
DISTNAME= freeWAIS-sf-2.1.2
PKGNAME= freewais-sf-2.1.2
DISTNAME= freeWAIS-sf-2.2.11
PKGNAME= freewais-sf-2.2.11
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.wsct.wsc.com/pub/freeWAIS-sf/freeWAIS-sf-2.1/ \
ftp://ftp.u-aizu.ac.jp/pub/net/wais/ \
ftp://ftp.bio.indiana.edu/util/wais/
MASTER_SITES= ftp://ls6-www.cs.uni-dortmund.de/pub/src/freeWAIS-sf/ \
ftp://ftp.leo.org/pub/comp/general/infosys/wais/freeWAIS/freeWAIS-sf-2.2/ \
ftp://ftp.germany.eu.net/pub/infosystems/wais/Unido-LS6/freeWAIS-sf-2.2/
MAINTAINER= giffunip@asme.org
MAINTAINER= ports@FreeBSD.org
USE_XLIB= yes
GNU_CONFIGURE= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT=Configure
CONFIGURE_ARGS= < ${FILESDIR}/configure.ans
INSTALL_TARGET= install install.man
MAN1= catalog.1 dictionary.1 inverted_file.1 makedb.1 mkfmt.1 waisindex.1 \
waisq.1 waissearch.1 xwais.1 xwaisq.1
MAN3= ftw.3 scandir.3
pre-install:
${MKDIR} ${PREFIX}/lib/freeWAIS-sf
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/SF

View File

@ -1 +1 @@
MD5 (freeWAIS-sf-2.1.2.tar.gz) = 2013cf21af0a19b5f981a13b7532257d
MD5 (freeWAIS-sf-2.2.11.tar.gz) = 83976c5f92444e5ffbbadbd01787b016

View File

@ -1,18 +1,19 @@
--- configure~ Mon Jul 8 22:36:12 1996
+++ configure Mon Feb 17 16:22:27 1997
@@ -2575,6 +2575,7 @@
#line 2576 "configure"
#include "confdefs.h"
+#include <sys/types.h>
#ifdef HAVE_SYS_DIR_H
#include <sys/dir.h>
#endif
@@ -2616,6 +2617,7 @@
#line 2617 "configure"
#include "confdefs.h"
+#include <sys/types.h>
#ifdef HAVE_SYS_DIR_H
#include <sys/dir.h>
#endif
*** Configure.orig Tue Mar 2 11:28:08 1999
--- Configure Tue Mar 2 11:36:05 1999
***************
*** 829,835 ****
*)
if test ! -t 0; then
echo "Say 'sh Configure', not 'sh <Configure'"
! exit 1
fi
;;
esac
--- 829,835 ----
*)
if test ! -t 0; then
echo "Say 'sh Configure', not 'sh <Configure'"
! # exit 1
fi
;;
esac

View File

@ -1,11 +0,0 @@
--- ir/Makefile.in.orig Tue Jul 30 00:42:14 1996
+++ ir/Makefile.in Mon Feb 17 16:33:11 1997
@@ -196,7 +196,7 @@
libwais.a: $(PROTOCOL_OBJS) $(INV_OBJS) $(SIG_OBJS) $(LOCAL_OBJS) $(CLIENT_OBJS)
$(RM) $@
- $(AR) $@ $(PROTOCOL_OBJS) $(INV_OBJS) $(SIG_OBJS) $(LOCAL_OBJS) $(CLIENT_OBJS) ../ctype/ctype.o
+ $(AR) $@ $(PROTOCOL_OBJS) $(INV_OBJS) $(SIG_OBJS) $(LOCAL_OBJS) $(CLIENT_OBJS)
$(RANLIB) $@
install.lib:: libwais.a libinv.a libsig.a libclient.a $(LIBLOCAL)

View File

@ -4,9 +4,10 @@ bin/dictionary
bin/getaddrs
bin/inverted_file
bin/makedb
bin/stringtoany
bin/mkfmt
bin/server_stats
bin/stats.awk
bin/swais
bin/trunc
bin/wais-gif-display
bin/wais-html-display
bin/wais-jfif-display
@ -15,15 +16,16 @@ bin/wais-pict-display
bin/wais-ppm-display
bin/wais-tiff-display
bin/waisindex
bin/waisping
bin/waisq
bin/waisretrieve
bin/waissearch
bin/waisserver
bin/ws
bin/xwais
bin/xwaisq
lib/XwaisHELP
lib/XwaisqHELP
lib/app-defaults/Xwais
lib/emacs/lisp/wais.el
lib/freeWAIS-sf/emacs/lisp/wais.el
lib/freeWAIS-sf/libwais.a
share/doc/SF/fwsf.ps
@dirrm lib/freeWAIS-sf/emacs/lisp
@dirrm lib/freeWAIS-sf/emacs
@dirrm lib/freeWAIS-sf
@dirrm share/doc/SF