Upgrade to v1.10.

Release notes at <https://github.com/FabriceColin/pinot/releases/tag/1.10>.
This commit is contained in:
Thierry Thomas 2020-02-12 06:42:51 +00:00
parent 083f09be07
commit b4a7815960
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=525897
6 changed files with 6 additions and 172 deletions

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pinot
PORTVERSION= 1.09
PORTREVISION= 22
PORTVERSION= 1.10
CATEGORIES= deskutils
MAINTAINER= thierry@FreeBSD.org
@ -24,7 +23,7 @@ LIB_DEPENDS= libxapian.so:databases/xapian-core \
libnotify.so:devel/libnotify \
libexif.so:graphics/libexif \
libexiv2.so:graphics/exiv2 \
libgmime-2.4.so:mail/gmime24 \
libgmime-2.6.so:mail/gmime26 \
libtag.so:audio/taglib \
libcurl.so:ftp/curl
RUN_DEPENDS= update-mime-database:misc/shared-mime-info \
@ -38,7 +37,6 @@ RUN_DEPENDS= update-mime-database:misc/shared-mime-info \
USE_GITHUB= yes
GH_ACCOUNT= FabriceColin
GH_TAGNAME= c14d6d5
USES= compiler:c++11-lang autoreconf gettext gnome libarchive \
libtool pkgconfig python shebangfix sqlite:3 ssl xorg
@ -69,7 +67,7 @@ INSTALLS_ICONS= yes
DOCS= AUTHORS ChangeLog ChangeLog-dijon INSTALL NEWS README TODO
LM2FIX= textcat_conf.txt textcat3_conf.txt textcat31_conf.txt textcat32_conf.txt
SHR2FIX= Core/pinot-search.1 README
SHR2FIX= Core/pinot-search.1
UL2FIX= Utils/xdgmime/xdgmime.c
post-extract:
@ -90,8 +88,6 @@ pre-configure:
${UL2FIX:S|^|${WRKSRC}/|}
${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|' \
${SHR2FIX:S|^|${WRKSRC}/|}
${REINPLACE_CMD} -e 's|Icon=pinot.png|Icon=pinot|g' \
${WRKSRC}/*.desktop
post-install:
${TOUCH} ${STAGEDIR}${DATADIR}/stopwords/.empty_file

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1473961314
SHA256 (FabriceColin-pinot-1.09-c14d6d5_GH0.tar.gz) = 24faced5089ebe9df143a7ad4a87b9beaf639533e2c113b6de3ed0f6cdce8394
SIZE (FabriceColin-pinot-1.09-c14d6d5_GH0.tar.gz) = 786374
TIMESTAMP = 1581456790
SHA256 (FabriceColin-pinot-1.10_GH0.tar.gz) = 3eb273b1b9ea2b146add790478acf58924d11650e21ca860bd5c79a797585f77
SIZE (FabriceColin-pinot-1.10_GH0.tar.gz) = 808404

View File

@ -1,36 +0,0 @@
--- Core/Makefile.am.orig 2016-06-20 18:07:02 UTC
+++ Core/Makefile.am
@@ -64,7 +64,7 @@ pinot_index_LDADD = \
pinot_index_SOURCES = pinot-index.cpp
-pinot_index_DEPENDENCIES = libCore.la
+pinot_index_DEPENDENCIES = libCore.la libThread.la
pinot_search_LDFLAGS = \
-export-dynamic
@@ -82,7 +82,7 @@ pinot_search_LDADD = \
pinot_search_SOURCES = \
pinot-search.cpp
-pinot_search_DEPENDENCIES = libCore.la
+pinot_search_DEPENDENCIES = libCore.la libThread.la
pinot_dbus_daemon_LDFLAGS = \
-export-dynamic
@@ -105,7 +105,7 @@ pinot_dbus_daemon_SOURCES = \
ServerThreads.cpp \
pinot-dbus-daemon.cpp
-pinot_dbus_daemon_DEPENDENCIES = libCore.la
+pinot_dbus_daemon_DEPENDENCIES = libCore.la libThread.la
pinot_daemon_LDFLAGS = \
-export-dynamic
@@ -128,5 +128,5 @@ pinot_daemon_SOURCES = \
ServerThreads.cpp \
pinot-dbus-daemon.cpp
-pinot_daemon_DEPENDENCIES = libCore.la
+pinot_daemon_DEPENDENCIES = libCore.la libThread.la

View File

@ -1,13 +0,0 @@
Fix build with exiv2-0.27
--- Tokenize/filters/Exiv2ImageFilter.cc.orig 2019-03-09 07:44:20 UTC
+++ Tokenize/filters/Exiv2ImageFilter.cc
@@ -25,7 +25,7 @@
#include <exiv2/image.hpp>
#include <exiv2/exif.hpp>
#include <exiv2/iptc.hpp>
-#include <exiv2/xmp.hpp>
+#include <exiv2/exiv2.hpp>
#include "config.h"
#include "Exiv2ImageFilter.h"

View File

@ -1,11 +0,0 @@
--- Tokenize/filters/GMimeMboxFilter.cc.orig 2017-04-03 09:38:48 UTC
+++ Tokenize/filters/GMimeMboxFilter.cc
@@ -301,7 +301,7 @@ bool GMimeMboxFilter::skip_to_document(const string &i
}
// ipath's format is "o=offset&l=part_levels"
- if (sscanf(ipath.c_str(), "o="GMIME_OFFSET_MODIFIER"&l=[", &m_messageStart) != 1)
+ if (sscanf(ipath.c_str(), "o=" GMIME_OFFSET_MODIFIER "&l=[", &m_messageStart) != 1)
{
return false;
}

View File

@ -1,102 +0,0 @@
Description: Catch up with current glib and OpenSSL
Author: FabriceColin <fabrice.colin@gmail.com>
Bug-Debian: https://bugs.debian.org/828503
Forwarded: yes
Last-Update: 2018-06-14
diff --git Collect/DownloaderInterface.cpp Collect/DownloaderInterface.cpp
index 10f4f66..f084f50 100644
--- Collect/DownloaderInterface.cpp
+++ Collect/DownloaderInterface.cpp
@@ -1,5 +1,5 @@
/*
- * Copyright 2005-2008 Fabrice Colin
+ * Copyright 2005-2017 Fabrice Colin
*
* This program is free software; you can redistribute it and/or modify
* it under the terms of the GNU General Public License as published by
@@ -33,7 +33,8 @@ using namespace std;
#ifdef USE_SSL
// OpenSSL multi-thread support, required by Curl
-static pthread_mutex_t locksTable[CRYPTO_NUM_LOCKS];
+static unsigned int g_lockArrayCount = 0;
+static pthread_mutex_t *g_pLockArray = NULL;
// OpenSSL locking functiom
static void lockingCallback(int mode, int n, const char *file, int line)
@@ -42,7 +43,7 @@ static void lockingCallback(int mode, int n, const char *file, int line)
if (mode & CRYPTO_LOCK)
{
- status = pthread_mutex_lock(&(locksTable[n]));
+ status = pthread_mutex_lock(&(g_pLockArray[n]));
#ifdef DEBUG
if (status != 0)
{
@@ -52,7 +53,7 @@ static void lockingCallback(int mode, int n, const char *file, int line)
}
else
{
- status = pthread_mutex_unlock(&(locksTable[n]));
+ status = pthread_mutex_unlock(&(g_pLockArray[n]));
#ifdef DEBUG
if (status != 0)
{
@@ -82,9 +83,15 @@ void DownloaderInterface::initialize(void)
pthread_mutexattr_settype(&mutexAttr, PTHREAD_MUTEX_ERRORCHECK);
// Initialize the OpenSSL mutexes
- for (unsigned int lockNum = 0; lockNum < CRYPTO_NUM_LOCKS; ++lockNum)
+#ifdef CRYPTO_num_locks
+ g_lockArrayCount = CRYPTO_num_locks();
+#else
+ g_lockArrayCount = CRYPTO_NUM_LOCKS;
+#endif
+ g_pLockArray = (pthread_mutex_t *)OPENSSL_malloc(g_lockArrayCount * sizeof(pthread_mutex_t));
+ for (unsigned int lockNum = 0; lockNum < g_lockArrayCount; ++lockNum)
{
- pthread_mutex_init(&(locksTable[lockNum]), &mutexAttr);
+ pthread_mutex_init(&(g_pLockArray[lockNum]), &mutexAttr);
}
// Set the callbacks
CRYPTO_set_locking_callback(lockingCallback);
@@ -103,10 +110,13 @@ void DownloaderInterface::shutdown(void)
CRYPTO_set_locking_callback(NULL);
// Free the mutexes
- for (unsigned int lockNum = 0; lockNum < CRYPTO_NUM_LOCKS; ++lockNum)
+ for (unsigned int lockNum = 0; lockNum < g_lockArrayCount; ++lockNum)
{
- pthread_mutex_destroy(&(locksTable[lockNum]));
+ pthread_mutex_destroy(&(g_pLockArray[lockNum]));
}
+ OPENSSL_free(g_pLockArray);
+ g_pLockArray = NULL;
+ g_lockArrayCount = 0;
#endif
}
diff --git Utils/MIMEScanner.cpp Utils/MIMEScanner.cpp
index e02215c..50ceb3d 100644
--- Utils/MIMEScanner.cpp
+++ Utils/MIMEScanner.cpp
@@ -1,5 +1,5 @@
/*
- * Copyright 2005-2012 Fabrice Colin
+ * Copyright 2005-2017 Fabrice Colin
*
* This program is free software; you can redistribute it and/or modify
* it under the terms of the GNU General Public License as published by
@@ -456,9 +456,10 @@ MIMEScanner::~MIMEScanner()
bool MIMEScanner::initialize(const string &userPrefix, const string &systemPrefix)
{
#ifdef USE_GIO
+#if !GLIB_CHECK_VERSION(2,35,0)
// Initialize the GType system
g_type_init();
-
+#endif
return true;
#else
list<string> desktopFilesPaths;