Revert r516273 and unbreak

Reported by:	pkg-fallout
This commit is contained in:
Antoine Brodin 2019-11-02 12:15:48 +00:00
parent 0a375277a2
commit b42c213cac
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=516306
5 changed files with 2 additions and 62 deletions

View File

@ -29,7 +29,8 @@ PORTDOCS= AUTHORS ChangeLog NEWS README TODO
OPTIONS_DEFINE= DOCS
post-patch:
# @${REINPLACE_CMD} -e '/^PKG_/d' ${WRKSRC}/configure.ac
@${REINPLACE_CMD} -e '/^PKG_/d' ${WRKSRC}/configure.ac
@${REINPLACE_CMD} -e 's|sys/capability.h|sys/capsicum.h|' ${WRKSRC}/src/platform-headers.h ${WRKSRC}/src/platform/freebsd/platform-freebsd.h
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}

View File

@ -1,11 +0,0 @@
--- configure.ac.orig 2019-08-02 20:40:49 UTC
+++ configure.ac
@@ -58,7 +58,7 @@ AC_CHECK_HEADERS([numa.h])
# FreeBSD 9+ with appropriately configured kernel
# (enabled by default in FreeBSD 10)
AC_SEARCH_LIBS([cap_getmode], [c])
-AC_CHECK_HEADERS([sys/capability.h])
+AC_CHECK_HEADERS([sys/capsicum.h])
AC_SEARCH_LIBS([cap_init], [cap],
[HAVE_LIBCAP=yes],

View File

@ -1,20 +0,0 @@
--- src/platform-headers.h.orig 2019-08-02 20:40:49 UTC
+++ src/platform-headers.h
@@ -98,7 +98,7 @@ typedef struct statfs procenv_mnt_type;
#endif
#if defined (HAVE_SYS_CAPABILITY_H)
-#include <sys/capability.h>
+#include <sys/capsicum.h>
#endif
#if defined (__GLIBC__)
@@ -263,7 +263,7 @@ typedef struct statfs procenv_mnt_type;
#include <link.h>
#if defined (HAVE_SYS_CAPABILITY_H)
-#include <sys/capability.h>
+#include <sys/capsicum.h>
#endif
#define PROCENV_CPU_TYPE int

View File

@ -1,13 +0,0 @@
--- src/platform/freebsd/platform-freebsd.h.orig 2019-08-02 20:40:49 UTC
+++ src/platform/freebsd/platform-freebsd.h
@@ -22,8 +22,8 @@
#include "platform.h"
#include "util.h"
-#if defined (HAVE_SYS_CAPABILITY_H)
-#include <sys/capability.h>
+#if defined (HAVE_SYS_CAPSICUM_H)
+#include <sys/capsicum.h>
#if __FreeBSD__ == 9

View File

@ -1,17 +0,0 @@
--- src/tests/show_compiler_details.orig 2019-08-02 20:40:49 UTC
+++ src/tests/show_compiler_details
@@ -9,8 +9,12 @@ CPP=${CPP:-cpp}
LD=${LD:-ld}
# handle strange environments
-command -v gcpp >/dev/null 2>&1 && CPP=gcpp
-command -v gcc >/dev/null 2>&1 && CC=gcc
+if ! command -v $CPP; then
+ command -v gcpp && CPP=gcpp
+fi >/dev/null 2>&1
+if ! command -v $CC; then
+ command -v gcc && CC=gcc
+fi >/dev/null 2>&1
echo "XXX:--------------------------------------------------"
echo "XXX: $0: preprocessor ('$CPP') version"