- Update to version 2.0.12

- Approved by maintainer

PR:		56180
Submitted by:	Dan Larsson <ports@tyfon.net>
This commit is contained in:
Kirill Ponomarev 2003-10-05 19:59:13 +00:00
parent 1f13b5f761
commit b41e4b82b7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=90325
10 changed files with 95 additions and 55 deletions

View File

@ -6,15 +6,14 @@
#
PORTNAME= noip
PORTVERSION= 1.6
PORTVERSION= 2.0.12
CATEGORIES= dns
MASTER_SITES= http://www.no-ip.com/client/linux/
DISTNAME= noip_updater_v${PORTVERSION}
MAINTAINER= esoha@attbi.com
COMMENT= No-IP.com's dynamic DNS update client
ALL_TARGET= noip
ALL_TARGET= noip2
post-build:
${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/noip.sh > ${WRKSRC}/noip.sh
@ -24,21 +23,18 @@ pre-install:
${PKGINSTALL} ${PKGNAME} PRE-INSTALL
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/noip ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/noip2 ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/noip.sh ${PREFIX}/etc/rc.d
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
${INSTALL_MAN} ${WRKSRC}/README.FIRST ${PREFIX}/share/doc/${PORTNAME}
${INSTALL_MAN} ${WRKSRC}/COPYING ${PREFIX}/share/doc/${PORTNAME}
${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
${INSTALL_MAN} ${WRKSRC}/no-ip.conf.sample ${PREFIX}/share/examples/${PORTNAME}
${INSTALL_SCRIPT} ${WRKSRC}/no-ip.sh ${PREFIX}/share/examples/${PORTNAME}
.endif
@${SED} "s|%%PREFIX%%|${PREFIX}|g" ${PKGMESSAGE} | ${SED} "s|%%WRKSRC%%|${WRKSRC}|g"
conf:
(cd ${PREFIX}/etc && ${PREFIX}/share/examples/noip/no-ip.sh)
${CHOWN} noip:noip ${PREFIX}/etc/no-ip.conf
${CHMOD} 0600 ${PREFIX}/etc/no-ip.conf
(cd ${PREFIX}/etc && ${PREFIX}/bin/noip2 -C)
${CHOWN} noip:noip ${PREFIX}/etc/no-ip2.conf
${CHMOD} 0600 ${PREFIX}/etc/no-ip2.conf
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (noip_updater_v1.6.tar.gz) = 6503e2e7d8ea35c304744a318b400a09
MD5 (noip-2.0.12.tar.gz) = 72053672a5125d39b861a130aa4532f1

View File

@ -2,14 +2,14 @@
case "$1" in
start)
if [ -x %%PREFIX%%/bin/noip -a -f %%PREFIX%%/etc/no-ip.conf ]; then
if [ -x %%PREFIX%%/bin/noip2 -a -f %%PREFIX%%/etc/no-ip2.conf ]; then
echo -n ' noip';
su -m noip -c '%%PREFIX%%/bin/noip' 2> /dev/null > /dev/null
su -m noip -c '%%PREFIX%%/bin/noip2' 2> /dev/null > /dev/null
fi
;;
stop)
echo -n ' noip';
killall noip
killall noip2
;;
*)
echo "Usage: `basename $0` {start|stop}" >&2

View File

@ -0,0 +1,35 @@
--- Makefile.orig Thu May 8 23:13:28 2003
+++ Makefile Fri Aug 29 10:22:57 2003
@@ -1,16 +1,16 @@
TGT=noip2
-CC=gcc
+MYCC=${CC}
-PREFIX=/usr/local
-CONFDIR=${PREFIX}/etc
-BINDIR=${PREFIX}/bin
+MYPREFIX=${PREFIX}
+CONFDIR=${MYPREFIX}/etc
+BINDIR=${MYPREFIX}/bin
# these defines are for Linux
-LIBS=
-ARCH=linux
+#LIBS=
+#ARCH=linux
# for BSD systems that have getifaddr(), uncomment the next line
-#ARCH=bsd_with_getifaddrs
+ARCH=bsd_with_getifaddrs
# for early BSD systems without getifaddrs(), uncomment the next line
#ARCH=bsd
@@ -21,7 +21,7 @@
# ARCH=sun
${TGT}: Makefile ${TGT}.c
- ${CC} -Wall -g -O2 -D${ARCH} -DPREFIX=\"${PREFIX}\" ${TGT}.c -o ${TGT} ${LIBS}
+ ${MYCC} ${CFLAGS} -D${ARCH} -DPREFIX=\"${MYPREFIX}\" ${TGT}.c -o ${TGT} ${LIBS}
install: ${TGT}
if [ ! -d ${BINDIR} ]; then mkdir -p ${BINDIR};fi

View File

@ -1,16 +0,0 @@
--- no-ip.sh.orig Wed Oct 10 16:35:12 2001
+++ no-ip.sh Fri Mar 29 01:55:11 2002
@@ -1,3 +1,4 @@
+#!/bin/sh
#
# configuration file builder script for no-ip
#
@@ -89,7 +90,7 @@
#
if [ "$NAT" = "N" ]
then
- devs=`tail +3 /proc/net/dev | awk -F: '{print $1}' | tr -d ' '|tr '\n' ' '`
+ devs=`ifconfig -l inet`
DEV=foo
while [ "$DEV" = "foo" ]
do

View File

@ -1,12 +0,0 @@
--- noip.c.bak Sat Mar 30 17:59:58 2002
+++ noip.c Sat Mar 30 17:59:15 2002
@@ -452,7 +452,8 @@
else
getip(IPaddress);
#ifdef DEBUG
- ErrMsg("! LIA = %s, IP = %s",Last_IP_Addr, IPaddress);
+ if (debug)
+ ErrMsg("! LIA = %s, IP = %s",Last_IP_Addr, IPaddress);
#endif
if ((*IPaddress != 0) &&
(strcmp(IPaddress, Last_IP_Addr) != 0)) {

View File

@ -0,0 +1,46 @@
--- noip2.c.orig Sat May 24 00:55:14 2003
+++ noip2.c Fri Aug 29 10:50:06 2003
@@ -141,7 +141,7 @@
#define VERSION "2.0.12"
#define NOIP_NAME "dynupdate.no-ip.com"
-#define USER_AGENT "User-Agent: Linux DUC "VERSION
+#define USER_AGENT "User-Agent: FreeBSD DUC "VERSION
#define SETTING_SCRIPT "settings.php?"
#define USTRNG "username="
#define PWDSTRNG "&pass="
@@ -246,7 +246,7 @@
#define CMSG21 "Please select the Internet interface from this list.\n"
#define CMSG22 "By typing the number associated with it."
#define CMSG23 "Too many network devices. Limit is %d"
-#define CMSG24 "\nAuto configuration for Linux client of no-ip.com.\n"
+#define CMSG24 "\nAuto configuration for FreeBSD client of no-ip.com.\n"
#define CMSG25 "Can't create config file (%s)"
#define CMSG25a "Re-run noip, adding '-c configfilename' as a parameter."
#define CMSG26 "Can't rename config file (%s)"
@@ -438,7 +438,7 @@
fprintf(stderr, "[ -d][ -D pid]");
#endif
fprintf(stderr, "[ -i addr][ -S][ -M][ -h]");
- fprintf(stderr, "\n\nVersion Linux-%s\n", VERSION);
+ fprintf(stderr, "\n\nVersion FreeBSD-%s\n", VERSION);
fprintf(stderr, "Options: -C create configuration data\n");
fprintf(stderr, " -F force NAT off\n");
fprintf(stderr, " -Y select all hosts/groups\n");
@@ -1884,12 +1884,10 @@
for (ifa = ifap; ifa; ifa = ifa->ifa_next) {
if (ifa->ifa_addr->sa_family == AF_LINK) {
struct if_data *ifd = (struct if_data *) ifa->ifa_data;
- if (ifd->ifi_type == IFT_PFLOG
- || ifd->ifi_type == IFT_PFSYNC
- || ifd->ifi_type == IFT_ENC
- || ifd->ifi_type == IFT_BRIDGE
- || ifd->ifi_type == IFT_OTHER
- || ifd->ifi_type == IFT_GIF)
+ if (ifd->ifi_type == IFT_OTHER
+ || ifd->ifi_type == IFT_GIF
+ || ifd->ifi_type == IFT_LOOP
+ || ifd->ifi_type == IFT_FAITH)
continue;
q = dq; // add new name into list
p = ifa->ifa_name;

View File

@ -21,7 +21,7 @@ fi
if ! ${PW} usershow "${USER}" 2>/dev/null 1>&2; then
if ${PW} useradd ${USER} -g ${GROUP} -h - \
-s "/sbin/nologin" -d "/nonexistent" \
-c "noip_updater pseudo-user"; \
-c "noip pseudo-user"; \
then
${ECHO} "Added user \"${USER}\"."
else

View File

@ -1,14 +1,8 @@
##################################################################
You need to generate the noip config file 'no-ip.conf' in
%%PREFIX%%/etc/no-ip.conf. To do this automatically, run:
You need to generate the noip config file 'no-ip2.conf' in
%%PREFIX%%/etc/no-ip2.conf. To do this automatically, run:
make conf
To do it manually, copy
%%PREFIX%%/share/examples/noip/no-ip.conf.sample to
%%PREFIX%%/etc/no-ip.conf and edit it or use
%%PREFIX%%/share/examples/noip/no-ip.sh to make no-ip.conf. Then
chown to noip:noip and chmod to 0600.
You need to register with www.no-ip.com to use this port.
##################################################################

View File

@ -1,8 +1,5 @@
bin/noip
bin/noip2
etc/rc.d/noip.sh
%%PORTDOCS%%share/doc/noip/README.FIRST
%%PORTDOCS%%share/doc/noip/COPYING
%%PORTDOCS%%share/examples/noip/no-ip.conf.sample
%%PORTDOCS%%share/examples/noip/no-ip.sh
%%PORTDOCS%%@dirrm share/doc/noip
%%PORTDOCS%%@dirrm share/examples/noip