Update to 2.8.9dev.8.
* Remove "--enable-addrlist-page" from EXPERIMENTAL_OPTS_CONFIGURE_ON. It has been enabled by default since 2.8.8dev.9. * Remove files/patch-src-GridText.c. It has been merged officially since 2.8.8dev.9. * Correct the CPE information. * Make Makefile to have the same style as japanese/lynx. PR: 206571 Submitted by: WATANABE Kazuhiro <CQG00620@nifty.ne.jp> (maintainer)
This commit is contained in:
parent
90d293bd4f
commit
b3a281dec2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=410063
@ -3,24 +3,23 @@
|
||||
|
||||
PORTNAME= lynx
|
||||
DISTVERSION= ${VERSION}.${MINOR_VERSION:S/.//}
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= japanese www ipv6
|
||||
MASTER_SITES= http://invisible-mirror.net/archives/lynx/tarballs/
|
||||
DISTNAME= ${PORTNAME}${VERSION}${MINOR_VERSION}
|
||||
PKGNAMESUFFIX= -current
|
||||
|
||||
MAINTAINER= CQG00620@nifty.ne.jp
|
||||
COMMENT= Terminal WWW client with multi-byte modification (development version)
|
||||
COMMENT= Console WWW client (browser) with multi-byte encoding support (development release)
|
||||
|
||||
VERSION= 2.8.8
|
||||
MINOR_VERSION= dev.3
|
||||
LICENSE= GPLv2
|
||||
|
||||
CONFLICTS= lynx-2.* ja-lynx-2.8.7.*
|
||||
VERSION= 2.8.9
|
||||
MINOR_VERSION= dev.8
|
||||
|
||||
CONFLICTS= lynx-2.* ja-lynx-2.8.8.*
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}${VERSION:S/./-/g}
|
||||
USES= cpe ncurses shebangfix tar:bzip2
|
||||
SHEBANG_FILES= samples/mailto-form.pl
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+=--with-screen=ncurses --with-zlib --libdir="${L_LIB}" \
|
||||
--enable-nsl-fork --enable-ipv6 \
|
||||
@ -29,32 +28,34 @@ CONFIGURE_ARGS+=--with-screen=ncurses --with-zlib --libdir="${L_LIB}" \
|
||||
MAKE_ARGS= helpdir=${L_HELP} docdir=${DOCSDIR}
|
||||
MAKEFILE= makefile
|
||||
INSTALL_TARGET= install-full
|
||||
CPE_VERSION= ${PORTVERSION:R}
|
||||
CPE_UPDATE= ${PORTVERSION:E:S/p/pre./:S/d/dev./}
|
||||
|
||||
L_LIB= ${PREFIX}/etc
|
||||
L_HELP= ${PREFIX}/share/lynx_help
|
||||
|
||||
OPTIONS_DEFINE= COLOR_STYLE DEFAULT_COLORS DOCS EXPERIMENTAL_OPTS JAPANESE_UTF8
|
||||
OPTIONS_DEFAULT=EXPERIMENTAL_OPTS JAPANESE_UTF8
|
||||
OPTIONS_DEFINE= COLOR_STYLE DEFAULT_COLORS DOCS JAPANESE_UTF8 EXPERIMENTAL_OPTS
|
||||
OPTIONS_DEFAULT=JAPANESE_UTF8 EXPERIMENTAL_OPTS
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
COLOR_STYLE_DESC= Color style (ncurses/ncurses)
|
||||
COLOR_STYLE_DESC= Optional color style support
|
||||
COLOR_STYLE_CONFIGURE_ENABLE= color-style
|
||||
|
||||
DEFAULT_COLORS_DESC= Default colors (ncurses/slang)
|
||||
DEFAULT_COLORS_DESC= Default-color background support (ncurses)
|
||||
DEFAULT_COLORS_CONFIGURE_ENABLE=default-colors
|
||||
|
||||
EXPERIMENTAL_OPTS_DESC= Experimental options
|
||||
EXPERIMENTAL_OPTS_CONFIGURE_ON= --enable-addrlist-page \
|
||||
--enable-charset-choice
|
||||
EXPERIMENTAL_OPTS_DESC= Use experimental options
|
||||
EXPERIMENTAL_OPTS_CONFIGURE_ON= --enable-charset-choice --enable-nested-tables
|
||||
|
||||
JAPANESE_UTF8_DESC= Experimental Japanese UTF-8 logic
|
||||
JAPANESE_UTF8_CONFIGURE_ON= ${ICONV_CONFIGURE_ARG} \
|
||||
--enable-japanese-utf8
|
||||
JAPANESE_UTF8_CONFIGURE_OFF= --disable-japanese-utf8
|
||||
JAPANESE_UTF8_DESC= Experimental Japanese UTF-8 logic support
|
||||
JAPANESE_UTF8_CONFIGURE_ON= ${ICONV_CONFIGURE_ARG}
|
||||
JAPANESE_UTF8_CONFIGURE_ENABLE= japanese-utf8
|
||||
JAPANESE_UTF8_USES= iconv
|
||||
|
||||
# Change "cd foo && $(MAKE_RECUR)" into "$(MAKE_RECUR) -C foo" to unbreak
|
||||
# parallel builds
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|-lssl -lcrypto|-L${OPENSSLLIB} &|g' \
|
||||
${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -E 's|cd (.+) && (\$$\(MAKE_RECUR\))|\2 -C \1|' \
|
||||
${WRKSRC}/${MAKEFILE}.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (lynx2.8.8dev.3.tar.bz2) = 9f9f114f9732d90c8b7627e1a96a49bf335212cd89d8f559be9c3abd4bd305dd
|
||||
SIZE (lynx2.8.8dev.3.tar.bz2) = 2450931
|
||||
SHA256 (lynx2.8.9dev.8.tar.bz2) = c6223b885378d77cbc7cf7137273f1e9c142ec846d4d78477d319d10c4316d31
|
||||
SIZE (lynx2.8.9dev.8.tar.bz2) = 2657804
|
||||
|
@ -1,15 +1,6 @@
|
||||
--- makefile.in.orig 2014-05-18 17:40:49.321601176 +0200
|
||||
+++ makefile.in 2014-05-18 17:42:33.446626842 +0200
|
||||
@@ -320,7 +320,7 @@
|
||||
fi'
|
||||
$(SHELL) -c 'for name in COPYING COPYHEADER; do \
|
||||
cd $(HELPDIR) && rm -f $$name ;\
|
||||
- cd $(HELPDIR) && ( $(LN_S) $(DOCDIR)/$$name . || cp $(DOCDIR)/$$name . );\
|
||||
+ cd $(HELPDIR) && ( $(LN_S) $(docdir)/$$name . || cp $(DOCDIR)/$$name . );\
|
||||
done'
|
||||
-$(SHELL) -c 'case `id|sed -e "s/(.*//"` in uid=0) chown -R root $(DOCDIR);; esac'
|
||||
|
||||
@@ -399,8 +399,8 @@
|
||||
--- makefile.in.orig 2014-03-10 06:43:10.000000000 +0900
|
||||
+++ makefile.in 2015-11-28 14:46:42.000000000 +0900
|
||||
@@ -421,8 +421,8 @@
|
||||
$(SHELL) $(scripts_dir)/cfg_path.sh lynx_doc $(helpdir) | \
|
||||
sed -e '/^HELPFILE:file/s!$$!$(COMPRESS_EXT)!' \
|
||||
-e '/^HELPFILE:file/s!$(COMPRESS_EXT)$(COMPRESS_EXT)$$!$(COMPRESS_EXT)!' \
|
||||
@ -20,7 +11,7 @@
|
||||
-rm -f $(SYSCONFDIR)/lynx.tmp
|
||||
|
||||
LYHelp.h : help_files.sed $(srcdir)/LYHelp.hin
|
||||
@@ -423,10 +423,9 @@
|
||||
@@ -445,10 +445,9 @@
|
||||
$(SHELL) -c 'SHELL=$(SHELL) $(SHELL) $(scripts_dir)/cfg_defs.sh $(srcdir)'
|
||||
|
||||
install-cfg : $(SYSCONFDIR)
|
||||
|
@ -1,31 +0,0 @@
|
||||
--- src/GridText.c.orig 2010-04-26 08:44:30.000000000 +0900
|
||||
+++ src/GridText.c 2010-05-24 18:15:47.000000000 +0900
|
||||
@@ -11128,9 +11128,28 @@
|
||||
if (check_form_specialchars(val_used) != 0) {
|
||||
/* We should translate back. */
|
||||
StrAllocCopy(copied_val_used, val_used);
|
||||
+ if (HTCJK == JAPANESE) {
|
||||
+ if ((0 <= target_cs) &&
|
||||
+ (strcmp(LYCharSet_UC[target_cs].MIMEname, "euc-jp") == 0)) {
|
||||
+ TO_EUC(val_used, copied_val_used);
|
||||
+ success = YES;
|
||||
+ }
|
||||
+ else if ((0 <= target_cs) &&
|
||||
+ (strcmp(LYCharSet_UC[target_cs].MIMEname, "shift_jis") == 0)) {
|
||||
+ TO_SJIS(val_used, copied_val_used);
|
||||
+ success = YES;
|
||||
+ }
|
||||
+ else {
|
||||
success = LYUCTranslateBackFormData(&copied_val_used,
|
||||
form_ptr->value_cs,
|
||||
target_cs, PlainText);
|
||||
+ }
|
||||
+ }
|
||||
+ else {
|
||||
+ success = LYUCTranslateBackFormData(&copied_val_used,
|
||||
+ form_ptr->value_cs,
|
||||
+ target_cs, PlainText);
|
||||
+ }
|
||||
CTRACE((tfp, "field \"%s\" %d %s -> %d %s %s\n",
|
||||
NonNull(form_ptr->name),
|
||||
form_ptr->value_cs,
|
@ -34,7 +34,6 @@ man/man1/lynx.1.gz
|
||||
%%PORTDOCS%%%%DOCSDIR%%/docs/TCPWARE.announce
|
||||
%%PORTDOCS%%%%DOCSDIR%%/docs/VMSWAIS.announce
|
||||
%%PORTDOCS%%%%DOCSDIR%%/docs/djgpp.key
|
||||
%%PORTDOCS%%%%DOCSDIR%%/docs/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/docs/pdcurses.key
|
||||
%%PORTDOCS%%%%DOCSDIR%%/docs/slang.key
|
||||
%%PORTDOCS%%%%DOCSDIR%%/docs/win-386.announce
|
||||
@ -42,7 +41,6 @@ man/man1/lynx.1.gz
|
||||
%%PORTDOCS%%%%DOCSDIR%%/samples/bright-blue.lss
|
||||
%%PORTDOCS%%%%DOCSDIR%%/samples/cernrules.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/samples/home.htm
|
||||
%%PORTDOCS%%%%DOCSDIR%%/samples/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/samples/installdirs.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/samples/jumps.htm
|
||||
%%PORTDOCS%%%%DOCSDIR%%/samples/jumpsUnix.html
|
||||
@ -62,36 +60,41 @@ man/man1/lynx.1.gz
|
||||
%%PORTDOCS%%%%DOCSDIR%%/samples/mild-colors.lss
|
||||
%%PORTDOCS%%%%DOCSDIR%%/samples/mime.types
|
||||
%%PORTDOCS%%%%DOCSDIR%%/samples/oldlynx
|
||||
%%PORTDOCS%%%%DOCSDIR%%/samples/oldlynx.bat
|
||||
%%PORTDOCS%%%%DOCSDIR%%/samples/opaque.lss
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/ALT88592.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/ISO_LATIN1_test.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/README.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/TestComment.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/X
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/bad-html.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/c1.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/circle.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/cp-1252.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/cp-1252a.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/image.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/iso-8859-1.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/iso-8859-1a.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/iso-8859-2.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/iso-8859-2a.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/koi8-r.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/nobody
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/quickbrown.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/raw8bit.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/sgml.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/spaces.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/special_urls.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/square.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/tabtest.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/tags.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/test-styles.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/triangle.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/unicode.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/test/utf-8-demo.html
|
||||
%%PORTDOCS%%share/lynx_help/COPYHEADER
|
||||
%%PORTDOCS%%share/lynx_help/COPYING
|
||||
share/lynx_help/Lynx_users_guide.html
|
||||
share/lynx_help/about_lynx.html
|
||||
share/lynx_help/index.html
|
||||
share/lynx_help/keystrokes/alt_edit_help.html
|
||||
share/lynx_help/keystrokes/bashlike_edit_help.html
|
||||
share/lynx_help/keystrokes/bookmark_help.html
|
||||
@ -102,7 +105,6 @@ share/lynx_help/keystrokes/environments.html
|
||||
share/lynx_help/keystrokes/follow_help.html
|
||||
share/lynx_help/keystrokes/gopher_types_help.html
|
||||
share/lynx_help/keystrokes/history_help.html
|
||||
share/lynx_help/keystrokes/index.html
|
||||
share/lynx_help/keystrokes/keystroke_help.html
|
||||
share/lynx_help/keystrokes/movement_help.html
|
||||
share/lynx_help/keystrokes/option_help.html
|
||||
|
Loading…
Reference in New Issue
Block a user