- Support CC/CFLAGS properly
- Add WWW: line PR: ports/89015 Submitted by: Ports Fury
This commit is contained in:
parent
269eb41f69
commit
b38e144b6a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=148344
@ -7,38 +7,35 @@
|
||||
|
||||
PORTNAME= jpeg2ps
|
||||
PORTVERSION= 1.9
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= graphics converters
|
||||
MASTER_SITES= http://www.pdflib.com/products/more/jpeg2ps/
|
||||
PKGNAMESUFFIX= -${PAPERSIZE}
|
||||
|
||||
MAINTAINER= ports@freebsd.org
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Converter for JPEG compressed images to PostScript Level 2
|
||||
|
||||
MAKE_ARGS+= CFLAGS="-c ${CFLAGS}" LD="${CC}"
|
||||
|
||||
MAN1= jpeg2ps.1
|
||||
PLIST_FILES= bin/jpeg2ps
|
||||
|
||||
PAPERSIZE?= letter
|
||||
|
||||
INSTALL_TARGET=
|
||||
|
||||
MAN1= jpeg2ps.1
|
||||
|
||||
PLIST_FILES= bin/jpeg2ps %%DOCSDIR%%/jpeg2ps.txt
|
||||
PLIST_DIRS= %%DOCSDIR%%
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PAPERSIZE} == a4
|
||||
post-patch:
|
||||
${CP} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.input
|
||||
${SED} "s%CCFLAGS=-O -c%CCFLAGS=-O -c -DA4%" ${WRKSRC}/Makefile.input > ${WRKSRC}/Makefile
|
||||
${RM} -f ${WRKSRC}/Makefile.input
|
||||
.if !defined(NOPORTDOCS)
|
||||
PORTDOCS= jpeg2ps.txt
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
.if ${PAPERSIZE} == a4
|
||||
CFLAGS+= -DA4
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/jpeg2ps ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/jpeg2ps.1 ${MANPREFIX}/man/man1
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/jpeg2ps.txt ${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/jpeg2ps.1 ${MANPREFIX}/man/man1
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,3 @@
|
||||
MD5 (jpeg2ps-1.9.tar.gz) = e654f6a584435e6717b6c2659c07db28
|
||||
SHA256 (jpeg2ps-1.9.tar.gz) = e09919ff55bb1fd26299adfe92e5ea0e7daaa3bfa0277a0483cac9764eac25a2
|
||||
SIZE (jpeg2ps-1.9.tar.gz) = 67105
|
||||
|
@ -1,12 +0,0 @@
|
||||
--- Makefile.orig Mon Feb 4 03:39:21 2002
|
||||
+++ Makefile Sun Oct 19 02:44:27 2003
|
||||
@@ -14,7 +14,8 @@
|
||||
# The following was reported to work for emx/gcc 0.9c fix04 under OS/2:
|
||||
# make -f Makefile "CFLAGS=-c -DA4 -DDOS -O2" "LDFLAGS=-Zexe -s"
|
||||
|
||||
-CFLAGS=-c -DA4
|
||||
+CFLAGS?=-O -pipe
|
||||
+CFLAGS+=-c
|
||||
LD=cc
|
||||
LDFLAGS=
|
||||
OBJ=o
|
@ -8,3 +8,5 @@ file. Decompression is done by the PostScript interpreter (only PostScript
|
||||
Level 2 and 3 interpreters support JPEG compression and decompression).
|
||||
If you have a slow communication channel and a fast printer, sending
|
||||
compressed image data is a big win.
|
||||
|
||||
WWW: http://www.pdflib.com/products/more/jpeg2ps.html
|
||||
|
Loading…
Reference in New Issue
Block a user