Update to 2.5.5 (no major changes from 2.5.4).

Major changes to the port infrastructure:
 - Replace WWWDOCROOT and WEBFRONTURL options with WEBFRONTDIR
   (defaults to www/ganglia).
 - Install files under ${PREFIX}/${WEBFRONTDIR}.
 - Since the files are no longer installed in the document root,
   add a pkg-message with a suggest addition to Apache's
   httpd.conf.
 - Use USE_PHP and WANT_PHP_MOD.
 - Add a note about installing PHP with GD support at done in
   mail/nocc.
 - Remove conf.php only if it is identical to conf.php.sample as
   done in mail/nocc.
 - Sizify.
 - Don't install the empty addons directory since packages won't
   contain it.

PR:		ports/62802
Submitted by:	Brooks Davis <brooks@FreeBSD.org> (maintainer)
This commit is contained in:
Mark Linimon 2004-02-18 06:34:16 +00:00
parent 13b02ed1b3
commit b367f5c3e7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=101304
6 changed files with 63 additions and 24 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= ganglia-webfrontend
PORTVERSION= 2.5.4
PORTVERSION= 2.5.5
CATEGORIES= sysutils net parallel www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ganglia
@ -14,26 +14,41 @@ MASTER_SITE_SUBDIR= ganglia
MAINTAINER= brooks@FreeBSD.org
COMMENT= "Ganglia cluster monitor, web frontend"
RUN_DEPENDS= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4 \
${LOCALBASE}/sbin/gmetad:${PORTSDIR}/sysutils/ganglia-monitor-core
RUN_DEPENDS+= ${LOCALBASE}/sbin/gmetad:${PORTSDIR}/sysutils/ganglia-monitor-core
PKGMESSAGE= ${WRKDIR}/pkg-message
PLIST_SUB+= WEBFRONTDIR="${WEBFRONTDIR}"
NO_BUILD= yes
USE_REINPLACE= yes
USE_PHP= yes
WANT_PHP_MOD= yes
# The Ganglia Web Frontend port supports a number of options that may be
# tweaked at buildtime. Perform a "make options" to see more
# information on these variables.
WWWDOCROOT?= www/data
WEBFRONTURL?= ganglia
WEBFRONTDIR?= www/ganglia
WWWOWN?= www
WWWGRP?= www
# Set custom variables:
#
WEBFRONTDIR= ${WWWDOCROOT}/${WEBFRONTURL}
PKGOPTS= ${FILESDIR}/pkg-opts
EXCEPTFILES= AUTHORS ChangeLog COPYING webfrontend.spec
EXCEPTFILES= AUTHORS ChangeLog COPYING addons webfrontend.spec
pre-everything::
@${ECHO} ""
@${ECHO} "You have to configure PHP with GD support to allow "
@${ECHO} "the Ganglia Webfrontend draw some standard graphs.
@${ECHO} ""
@${ECHO} "If you have already compiled PHP without GD,"
@${ECHO} "press CTRL+C now and rebuild it before installing"
@${ECHO} "the Ganglia Webfrontend."
@${ECHO} ""
pre-patch:
@${SED} -e 's|%%PREFIX%%|${PREFIX}|g' \
-e 's|%%WEBFRONTDIR%%|${WEBFRONTDIR}|g' \
${.CURDIR}/pkg-message > ${PKGMESSAGE}
options:
@ ${ECHO_MSG} "===> Build options for ${PKGNAME}:"
@ -60,9 +75,12 @@ do-install:
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${WEBFRONTDIR}
${INSTALL} -c -o ${WWWOWN} -g ${WWWGRP} \
${WRKSRC}/conf.php ${PREFIX}/${WEBFRONTDIR}/conf.php.sample
if [ ! -f ${PREFIX}/${WEBFRONTDIR}/conf.php ]; then \
@if [ ! -f ${PREFIX}/${WEBFRONTDIR}/conf.php ]; then \
${INSTALL} -c -o ${WWWOWN} -g ${WWWGRP} \
${WRKSRC}/conf.php ${PREFIX}/${WEBFRONTDIR} ;\
fi
post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -1 +1,2 @@
MD5 (ganglia-webfrontend-2.5.4.tar.gz) = 952b32c343c797f07688f354170d7c59
MD5 (ganglia-webfrontend-2.5.5.tar.gz) = 26d32439a49a1b16754138fc5ff72033
SIZE (ganglia-webfrontend-2.5.5.tar.gz) = 98076

View File

@ -1,8 +1,17 @@
$FreeBSD$
--- conf.php.orig Mon Aug 11 15:56:15 2003
+++ conf.php Tue Oct 28 11:59:38 2003
--- conf.php.orig Mon Nov 10 10:54:16 2003
+++ conf.php Thu Feb 12 18:40:24 2004
@@ -5,7 +5,7 @@
#
$majorversion = 2;
$minorversion = 5;
-$microversion = 4;
+$microversion = 5;
#
# The name of the directory in "./templates" which contains the
# templates that you want to use. Templates are like a skin for the
@@ -22,12 +22,12 @@
#$gmetad_root = "/usr/local/gmetad";

View File

@ -1,12 +1,6 @@
* WWWDOCROOT [www/data]
The DocumentRoot of your webserver under ${PREFIX}
* WEBFRONTURL [ganglia]
The base URL of the Ganglia Web Frontend on your webserver.
The Ganglia Web Frontend will be installed under
${PREFIX}/${WWWDOCROOT}/${WEBFRONTURL} and will be visible as
http://<;hostname>/${WEBFRONTURL}
* WEBFRONTDIR [www/ganglia]
The Ganglia Web Frontend will be installed under
${PREFIX}/${WEBFRONTDIR}.
* WWWOWN [www]
The user ID under which your webserver executes

View File

@ -0,0 +1,18 @@
****************************************************************
The Ganglia Web Frontend has been installed in the directory
%%PREFIX%%/%%WEBFRONTDIR%%.
You must add appropriate configuration directives to your
apache configuration file (%%PREFIX%%/etc/apache/httpd.conf).
A typical configuration would be:
Alias /ganglia/ "%%PREFIX%%/%%WEBFRONTDIR%%/"
<Directory "%%PREFIX%%/%%WEBFRONTDIR%%">
Options Indexes FollowSymlinks MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>
****************************************************************

View File

@ -12,7 +12,6 @@
%%WEBFRONTDIR%%/header.php
%%WEBFRONTDIR%%/host_view.php
%%WEBFRONTDIR%%/index.php
%%WEBFRONTDIR%%/info.php
%%WEBFRONTDIR%%/meta_view.php
%%WEBFRONTDIR%%/node_legend.html
%%WEBFRONTDIR%%/physical_view.php
@ -55,12 +54,12 @@
%%WEBFRONTDIR%%/templates/default/physical_view.tpl
%%WEBFRONTDIR%%/templates/default/show_node.tpl
%%WEBFRONTDIR%%/templates/default/grid_tree.tpl
@unexec if cmp -s %D/%%WEBFRONTDIR%%/conf.php %D/%%WEBFRONTDIR%%/conf.php.sample; then rm -f %D/%%WEBFRONTDIR%%/conf.php; fi
%%WEBFRONTDIR%%/conf.php.sample
%%WEBFRONTDIR%%/conf.php
@dirrm %%WEBFRONTDIR%%/addons
@exec [ -f %B/conf.php ] || cp %B/%f %B/conf.php
@dirrm %%WEBFRONTDIR%%/templates/Rocks/images
@dirrm %%WEBFRONTDIR%%/templates/Rocks
@dirrm %%WEBFRONTDIR%%/templates/default/images
@dirrm %%WEBFRONTDIR%%/templates/default
@dirrm %%WEBFRONTDIR%%/templates
@dirrm %%WEBFRONTDIR%%
@unexec rmdir %D/%%WEBFRONTDIR%% 2>/dev/null || (echo "Configuration information saved. If you will *NOT* use this package anymore," && echo "please remove %D/%%WEBFRONTDIR%% and its contents manually.")