www/mod_scgi: update to 2.0
While here, update maintainer email PR: 240542 Submitted by: Walter Schwarzenfeld <w.schwarzenfeld@utanet.at> (maintainer)
This commit is contained in:
parent
bca39e79c5
commit
b32585289a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=512011
@ -2,28 +2,23 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= mod_scgi
|
||||
PORTVERSION= 1.15
|
||||
PORTVERSION= 2.0
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://python.ca/scgi/releases/
|
||||
DISTNAME= scgi-${PORTVERSION:S/.a/a/}
|
||||
|
||||
MAINTAINER= w.schwarzenfeld@aon.at
|
||||
MAINTAINER= w.schwarzenfeld@utanet.at
|
||||
COMMENT= Apache module that implements the client side of the SCGI protocol
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKDIR}/${DISTNAME}/LICENSE.txt
|
||||
|
||||
USES= apache:2.4
|
||||
|
||||
SCGI_DIR= apache2
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/${SCGI_DIR}
|
||||
|
||||
USES= apache:2.2+
|
||||
AP_FAST_BUILD= yes
|
||||
AP_GENPLIST= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${APACHE_VERSION} == 2.4
|
||||
EXTRA_PATCHES= ${FILESDIR}/apache24-compat-mod__scgi.c
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (scgi-1.15.tar.gz) = e6cd197b089cca6478e9995ed076975756c30ebb903aabce912f404ee75a6d6f
|
||||
SIZE (scgi-1.15.tar.gz) = 32984
|
||||
TIMESTAMP = 1568303948
|
||||
SHA256 (scgi-2.0.tar.gz) = fc59ec13cb989d14216e78426a2f84bd3d46f712a35bca0f4806cd3c38050a72
|
||||
SIZE (scgi-2.0.tar.gz) = 32726
|
||||
|
@ -1,49 +0,0 @@
|
||||
--- mod_scgi.c.orig 2009-11-21 23:02:06 UTC
|
||||
+++ mod_scgi.c
|
||||
@@ -135,16 +135,16 @@ static int scgi_map_location(request_rec
|
||||
return DECLINED;
|
||||
}
|
||||
|
||||
-static void log_err(const char *file, int line, request_rec *r,
|
||||
+static void log_err(const char *file, int line, int index, request_rec *r,
|
||||
apr_status_t status, const char *msg)
|
||||
{
|
||||
- ap_log_rerror(file, line, APLOG_ERR, status, r, "scgi: %s", msg);
|
||||
+ ap_log_rerror(file, line, index, APLOG_ERR, status, r, "scgi: %s", msg);
|
||||
}
|
||||
|
||||
-static void log_debug(const char *file, int line, request_rec *r, const
|
||||
+static void log_debug(const char *file, int line, int index, request_rec *r, const
|
||||
char *msg)
|
||||
{
|
||||
- ap_log_rerror(file, line, APLOG_DEBUG, APR_SUCCESS, r, msg);
|
||||
+ ap_log_rerror(file, line, index, APLOG_DEBUG, APR_SUCCESS, r, "%s", msg);
|
||||
}
|
||||
|
||||
static char *http2env(apr_pool_t *p, const char *name)
|
||||
@@ -312,7 +312,7 @@ send_headers(request_rec *r, struct sock
|
||||
int i;
|
||||
apr_status_t rv = 0;
|
||||
apr_port_t port = 0;
|
||||
- GET_PORT(port, r->connection->remote_addr);
|
||||
+ GET_PORT(port, r->useragent_addr);
|
||||
|
||||
log_debug(APLOG_MARK,r, "sending headers");
|
||||
t = apr_table_make(r->pool, 40);
|
||||
@@ -324,14 +324,14 @@ send_headers(request_rec *r, struct sock
|
||||
buf = "0";
|
||||
add_header(t, "CONTENT_LENGTH", buf);
|
||||
add_header(t, "SCGI", SCGI_PROTOCOL_VERSION);
|
||||
- add_header(t, "SERVER_SOFTWARE", ap_get_server_version());
|
||||
+ add_header(t, "SERVER_SOFTWARE", ap_get_server_banner());
|
||||
add_header(t, "SERVER_PROTOCOL", r->protocol);
|
||||
add_header(t, "SERVER_NAME", ap_get_server_name(r));
|
||||
add_header(t, "SERVER_ADMIN", r->server->server_admin);
|
||||
add_header(t, "SERVER_ADDR", r->connection->local_ip);
|
||||
add_header(t, "SERVER_PORT", apr_psprintf(r->pool, "%u",
|
||||
ap_get_server_port(r)));
|
||||
- add_header(t, "REMOTE_ADDR", r->connection->remote_ip);
|
||||
+ add_header(t, "REMOTE_ADDR", r->useragent_ip);
|
||||
add_header(t, "REMOTE_PORT", apr_psprintf(r->pool, "%d", port));
|
||||
add_header(t, "REMOTE_USER", r->user);
|
||||
add_header(t, "REQUEST_METHOD", r->method);
|
Loading…
Reference in New Issue
Block a user