science/py-gpaw: Update 21.6.0 -> 22.1.0

This commit is contained in:
Yuri Victorovich 2022-01-13 02:25:05 -08:00
parent 3c32a4025e
commit b31f2fdb7c
3 changed files with 22 additions and 5 deletions

View File

@ -1,6 +1,5 @@
PORTNAME= gpaw
DISTVERSION= 21.6.0
PORTREVISION= 1
DISTVERSION= 22.1.0
CATEGORIES= science python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -24,6 +23,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ase>0:science/py-ase@${PY_FLAVOR} \
USES= gettext-runtime localbase python:3.7+ shebangfix
USE_PYTHON= distutils concurrent autoplist
SHEBANG_FILES= tools/*
LDFLAGS= -lmpi # otherwise: ImportError: /usr/local/lib/python3.8/site-packages/_gpaw.cpython-38.so: Undefined symbol "MPI_Comm_rank"
@ -34,4 +34,10 @@ post-patch:
post-install:
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/_gpaw*.so
do-test: install
@${ECHO} "== Performing a test calculation on one CPU =="
@gpaw test
@${ECHO} "== Performing a test calculation on 8 CPUs =="
@gpaw -P 8 test
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1628472882
SHA256 (gpaw-21.6.0.tar.gz) = 5bb805bf514a7b04e3fdfce6f7864d150032badc5cd2805c57513af982d7a9cc
SIZE (gpaw-21.6.0.tar.gz) = 1534942
TIMESTAMP = 1642067411
SHA256 (gpaw-22.1.0.tar.gz) = 2d2509e9e4b23205f5576ddfd1b0e9d9ac8cea1cf80ae1216af29513bd3cc42a
SIZE (gpaw-22.1.0.tar.gz) = 1625694

View File

@ -0,0 +1,11 @@
--- setup.py.orig 2022-01-12 10:11:02 UTC
+++ setup.py
@@ -113,7 +113,7 @@ if compiler is not None:
from sysconfig import get_config_vars
# If CC is set then the following hack will not work
- assert not os.environ.get('CC'), 'Please unset CC'
+ #assert not os.environ.get('CC'), 'Please unset CC'
vars = get_config_vars()
for key in ['CC', 'LDSHARED']: