Move japanese/uim port to textproc category after repocopy.

PR:		ports/89725
Submitted by:	nobutaka
This commit is contained in:
MANTANI Nobutaka 2005-11-30 16:32:14 +00:00
parent ce5d6d1767
commit b2f9d34f45
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=150063
17 changed files with 5 additions and 339 deletions

1
MOVED
View File

@ -1984,3 +1984,4 @@ x11/xscoop|x11-toolkits/xscoop|2005-11-24|Port readded in proper category
misc/compat22||2005-11-25|Forbidden, unfetchable, unneeded
net/doc|dns/doc|2005-11-25|Moved to a better category
www/firefox-devel|www/firefox|2005-11-29|Firefox 1.5 is now stable
japanese/uim|textproc/uim|2005-11-30|new category

View File

@ -380,7 +380,6 @@
SUBDIR += today
SUBDIR += truetypefonts
SUBDIR += typist
SUBDIR += uim
SUBDIR += vera-fpw
SUBDIR += vflib
SUBDIR += vftool

View File

@ -17,7 +17,7 @@ MAINTAINER= s_yanagita@ybb.ne.jp
COMMENT= SCIM IMEngine module using UIM input method library
BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim
LIB_DEPENDS= uim.0:${PORTSDIR}/japanese/uim
LIB_DEPENDS= uim.0:${PORTSDIR}/textproc/uim
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_GNOME= lthack

View File

@ -1,85 +0,0 @@
# New ports collection makefile for: uim
# Date created: 31 August 2003
# Whom: MANTANI Nobutaka <nobutaka@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= uim
PORTVERSION= 0.4.9.1
PORTREVISION= 1
CATEGORIES= japanese x11
MASTER_SITES= http://uim.freedesktop.org/releases/
MAINTAINER= nobutaka@FreeBSD.org
COMMENT= Input method library
LIB_DEPENDS= anthy.1:${PORTSDIR}/japanese/anthy \
m17n.1:${PORTSDIR}/devel/m17n-lib
USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_PERL5_BUILD=yes
INSTALLS_SHLIB= yes
WANT_GNOME= yes
USE_GNOME= lthack gnometarget glib20
USE_GMAKE= yes
USE_ICONV= yes
USE_AUTOTOOLS= libtool:13:inc
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
DOCSDIR_JA= ${PREFIX}/share/doc/ja/uim
PLIST_SUB+= DOCSDIR_JA="${DOCSDIR_JA:S,^${PREFIX}/,,}"
MAN1= uim-xim.1
.include <bsd.port.pre.mk>
.if ${ARCH} == ia64
BROKEN= "Segfault during build on ia64"
.endif
.if ${HAVE_GNOME:Mgtk20}
USE_GNOME+= gtk20
PLIST_SUB+= GTK=""
.else
PLIST_SUB+= GTK="@comment "
.endif
.if ${HAVE_GNOME:Mgnomepanel}
USE_GNOME+= gnomepanel
PLIST_SUB+= GNOME=""
.else
PLIST_SUB+= GNOME="@comment "
.endif
.if exists(${X11BASE}/bin/scim) || defined(WITH_SCIM)
USE_GCC= 3.4
LIB_DEPENDS= scim-1.0.9:${PORTSDIR}/textproc/scim
CONFIGURE_ARGS+=--with-scim
PLIST_SUB+= SCIM=""
.else
PLIST_SUB+= SCIM="@comment "
.endif
.if exists(${LOCALBASE}/sbin/cannaserver) || defined(WITH_CANNA)
LIB_DEPENDS= canna.1:${PORTSDIR}/japanese/Canna
CONFIGURE_ARGS+=--with-canna
PLIST_SUB+= CANNA=""
.else
PLIST_SUB+= CANNA="@comment "
.endif
post-patch:
${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},' ${WRKSRC}/scm/skk-custom.scm
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${DOCSDIR_JA}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.ja ${DOCSDIR_JA}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
${CAT} ${PKGMESSAGE}
.endif
.include <bsd.port.post.mk>

View File

@ -1,2 +0,0 @@
MD5 (uim-0.4.9.1.tar.gz) = 0e2625cc926917d7864c4d0c341c535a
SIZE (uim-0.4.9.1.tar.gz) = 1602849

View File

@ -1,11 +0,0 @@
--- Makefile.in.orig Wed Apr 7 13:38:51 2004
+++ Makefile.in Wed Apr 7 23:23:22 2004
@@ -201,7 +201,7 @@
DISTCLEANFILES = uim.pc intltool-extract intltool-merge intltool-update
-pkgconfigdir = $(libdir)/pkgconfig
+pkgconfigdir = $(prefix)/libdata/pkgconfig
pkgconfig_DATA = uim.pc
noinst_PROGRAMS = $(gtk_entry) uim-agent

View File

@ -1,21 +0,0 @@
--- configure.orig Sun Aug 1 22:33:54 2004
+++ configure Sun Aug 1 22:34:13 2004
@@ -19203,18 +19203,6 @@
echo "$as_me: error: perl 5.x required for intltool" >&2;}
{ (exit 1); exit 1; }; }
fi
-if test "x" != "xno-xml"; then
- echo "$as_me:$LINENO: checking for XML::Parser" >&5
-echo $ECHO_N "checking for XML::Parser... $ECHO_C" >&6
- if `$INTLTOOL_PERL -e "require XML::Parser" 2>/dev/null`; then
- echo "$as_me:$LINENO: result: ok" >&5
-echo "${ECHO_T}ok" >&6
- else
- { { echo "$as_me:$LINENO: error: XML::Parser perl module is required for intltool" >&5
-echo "$as_me: error: XML::Parser perl module is required for intltool" >&2;}
- { (exit 1); exit 1; }; }
- fi
-fi
# Remove file type tags (using []) from po/POTFILES.

View File

@ -1,27 +0,0 @@
--- gtk/Makefile.in.orig Wed Mar 2 02:29:13 2005
+++ gtk/Makefile.in Wed Mar 2 02:37:44 2005
@@ -308,15 +308,15 @@
cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe)
moduleLTLIBRARIES_INSTALL = $(INSTALL)
install-moduleLTLIBRARIES: $(module_LTLIBRARIES)
- @$(NORMAL_INSTALL)
- $(mkinstalldirs) $(DESTDIR)$(moduledir)
- @list='$(module_LTLIBRARIES)'; for p in $$list; do \
- if test -f $$p; then \
- f="`echo $$p | sed -e 's|^.*/||'`"; \
- echo " $(LIBTOOL) --mode=install $(moduleLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) $$p $(DESTDIR)$(moduledir)/$$f"; \
- $(LIBTOOL) --mode=install $(moduleLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) $$p $(DESTDIR)$(moduledir)/$$f; \
- else :; fi; \
- done
+@GTK2_TRUE@ @$(NORMAL_INSTALL)
+@GTK2_TRUE@ $(mkinstalldirs) $(DESTDIR)$(moduledir)
+@GTK2_TRUE@ @list='$(module_LTLIBRARIES)'; for p in $$list; do \
+@GTK2_TRUE@ if test -f $$p; then \
+@GTK2_TRUE@ f="`echo $$p | sed -e 's|^.*/||'`"; \
+@GTK2_TRUE@ echo " $(LIBTOOL) --mode=install $(moduleLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) $$p $(DESTDIR)$(moduledir)/$$f"; \
+@GTK2_TRUE@ $(LIBTOOL) --mode=install $(moduleLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) $$p $(DESTDIR)$(moduledir)/$$f; \
+@GTK2_TRUE@ else :; fi; \
+@GTK2_TRUE@ done
uninstall-moduleLTLIBRARIES:
@$(NORMAL_UNINSTALL)

View File

@ -1,11 +0,0 @@
--- helper/Makefile.in.orig Wed Apr 7 05:45:42 2004
+++ helper/Makefile.in Wed Apr 7 22:21:03 2004
@@ -203,7 +203,7 @@
@APPLET_TRUE@uim_helper_applet_SOURCES = helper-applet.c helper-toolbar-common-gtk.c
-@APPLET_TRUE@serverdir = $(libdir)/bonobo/servers
+@APPLET_TRUE@serverdir = $(prefix)/libdata/bonobo/servers
@APPLET_TRUE@server_DATA = GNOME_UimApplet.server
@APPLET_TRUE@server_in_files = $(server_DATA:=.in)
@APPLET_TRUE@server_in_in_files = $(server_in_files:=.in)

View File

@ -1,12 +0,0 @@
--- scm/skk-custom.scm.orig Tue Jun 14 05:46:11 2005
+++ scm/skk-custom.scm Mon Jun 27 02:29:34 2005
@@ -338,8 +338,7 @@
(lambda ()
skk-use-skkserv?))
-(define-custom 'skk-dic-file-name (string-append (sys-datadir)
- "/skk/SKK-JISYO.L")
+(define-custom 'skk-dic-file-name "%%LOCALBASE%%/share/skk/SKK-JISYO.L"
'(skk-dict)
'(pathname)
(_ "Dictionary file")

View File

@ -1,11 +0,0 @@
--- uim/scim.cpp.orig Wed Sep 21 00:27:36 2005
+++ uim/scim.cpp Wed Sep 21 00:29:33 2005
@@ -175,7 +175,7 @@
return uim_scm_f();
}
- config = config_module->create_config("scim");
+ config = config_module->create_config();
if ( config.null() )
{
fprintf(stderr, "create_config failed\n");

View File

@ -1,11 +0,0 @@
uim aims for multilingual input method library.
It works as an XIM server or an input module of GTK+ 2.x.
And currently it supports following input methods.
Chinese: Pinyin
Japanese: Anthy, Prime, SKK, T-code, TUT-code
Korean: Hangul, Romaja
Vietnamese: VIQR
Other: IPA
WWW: http://freedesktop.org/Software/uim

View File

@ -1,17 +0,0 @@
UIM configuration changed after uim-0.4.4.
# Before 0.4.4:
GTK_IM_MODULE=uim-anthy; export GTK_IM_MODULE
XMODIFIERS=@im=uim-anthy; export XMODIFIERS
# After 0.4.4:
GTK_IM_MODULE=uim; export GTK_IM_MODULE
XMODIFIERS=@im=uim; export XMODIFIERS
And specify your favorite input method to your ~/.uim
(define default-im-name 'anthy)
SEE ALSO:
in English:
http://freedesktop.org/pipermail/uim/2004-October/000659.html
in Japanese:
http://lists.sourceforge.jp/mailman/archives/anthy-dev/2004-October/001135.html

View File

@ -1,127 +0,0 @@
bin/uim-fep
bin/uim-fep-tick
bin/uim-helper-server
bin/uim-module-manager
bin/uim-sh
%%GTK%%bin/uim-candwin-gtk
%%GTK%%bin/uim-helper-candwin-gtk
%%GTK%%bin/uim-helper-toolbar-gtk
%%GTK%%bin/uim-helper-toolbar-gtk-systray
%%GTK%%bin/uim-im-switcher-gtk
%%GTK%%bin/uim-input-pad-ja
%%GTK%%bin/uim-pref-gtk
%%GTK%%bin/uim-toolbar-gtk
%%GTK%%bin/uim-toolbar-gtk-systray
bin/uim-xim
include/uim/plugin.h
include/uim/uim-compat-scm.h
include/uim/uim-custom.h
include/uim/uim-helper.h
include/uim/uim-im-switcher.h
include/uim/uim-scm.h
include/uim/uim-util.h
include/uim/uim.h
%%GNOME%%libdata/bonobo/servers/GNOME_UimApplet.server
%%GTK%%lib/gtk-2.0/2.4.0/immodules/im-uim.so
lib/libuim-custom.a
lib/libuim-custom.so
lib/libuim-custom.so.0
lib/libuim.a
lib/libuim.so
lib/libuim.so.0
lib/uim/plugin/libuim-anthy.so
%%CANNA%%lib/uim/plugin/libuim-canna.so
lib/uim/plugin/libuim-custom-enabler.so
lib/uim/plugin/libuim-m17nlib.so
%%SCIM%%lib/uim/plugin/libuim-scim.so
lib/uim/plugin/libuim-skk.so
libdata/pkgconfig/uim.pc
%%GNOME%%libexec/uim-helper-applet
%%GNOME%%libexec/uim-toolbar-applet
%%PORTDOCS%%%%DOCSDIR_JA%%/README.ja
%%PORTDOCS%%%%DOCSDIR%%/README
share/applications/uim.desktop
share/locale/fr/LC_MESSAGES/uim.mo
share/locale/ja/LC_MESSAGES/uim.mo
share/uim/PY.scm
share/uim/action.scm
share/uim/anthy-custom.scm
share/uim/anthy-key-custom.scm
share/uim/anthy.scm
share/uim/canna-custom.scm
share/uim/canna-key-custom.scm
share/uim/canna.scm
share/uim/custom-rt.scm
share/uim/custom.scm
share/uim/default.scm
share/uim/direct.scm
share/uim/generic-custom.scm
share/uim/generic-key-custom.scm
share/uim/generic.scm
share/uim/hangul.scm
share/uim/hangul2.scm
share/uim/hangul3.scm
share/uim/i18n.scm
share/uim/im-custom.scm
share/uim/im.scm
share/uim/init.scm
share/uim/installed-modules.scm
share/uim/ipa-x-sampa.scm
share/uim/japanese-azik.scm
share/uim/japanese-kana.scm
share/uim/japanese.scm
share/uim/key.scm
share/uim/latin.scm
share/uim/lazy-load.scm
share/uim/load-action.scm
share/uim/loader.scm
share/uim/m17nlib.scm
share/uim/manage-modules.scm
share/uim/pinyin-big5.scm
share/uim/pixmaps/configure-qt.png
share/uim/pixmaps/switcher-icon.png
share/uim/pixmaps/uim-icon.png
share/uim/plugin.scm
share/uim/prime-custom.scm
share/uim/prime-key-custom.scm
share/uim/prime.scm
share/uim/pyload.scm
share/uim/pyunihan.scm
share/uim/rk.scm
share/uim/romaja.scm
share/uim/scim.scm
share/uim/skk-custom.scm
share/uim/skk-dialog.scm
share/uim/skk-editor.scm
share/uim/skk-key-custom.scm
share/uim/skk.scm
share/uim/spellcheck-custom.scm
share/uim/spellcheck.scm
share/uim/tables/japanese-azik.table
share/uim/tables/japanese-kana.table
share/uim/tables/japanese-roma.table
share/uim/tables/japanese-tcode.table
share/uim/tables/japanese-tutcode.table
share/uim/tables/korean-hangul2.table
share/uim/tables/korean-hangul3.table
share/uim/tcode.scm
share/uim/tutcode-key-custom.scm
share/uim/tutcode.scm
share/uim/uim-db.scm
share/uim/uim-module-manager.scm
share/uim/uim-sh.scm
share/uim/ustr.scm
share/uim/util.scm
share/uim/viqr.scm
share/uim/zaurus.scm
@dirrm include/uim
@dirrm lib/uim/plugin
@dirrm lib/uim
@unexec rmdir %D/share/applications 2>/dev/null || true
%%PORTDOCS%%@dirrm %%DOCSDIR_JA%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm share/uim/tables
@dirrm share/uim/pixmaps
@dirrm share/uim
%%GTK%%@exec gtk-query-immodules-2.0 > %D/etc/gtk-2.0/gtk.immodules
%%GTK%%@unexec gtk-query-immodules-2.0 > %D/etc/gtk-2.0/gtk.immodules

View File

@ -745,6 +745,7 @@
SUBDIR += txt2man
SUBDIR += txt2tags
SUBDIR += ua-ispell
SUBDIR += uim
SUBDIR += uni2ascii
SUBDIR += unroff
SUBDIR += unrtf

View File

@ -8,7 +8,7 @@
PORTNAME= uim
PORTVERSION= 0.4.9.1
PORTREVISION= 1
CATEGORIES= japanese x11
CATEGORIES= textproc
MASTER_SITES= http://uim.freedesktop.org/releases/
MAINTAINER= nobutaka@FreeBSD.org

View File

@ -39,7 +39,7 @@ LIB_DEPENDS+= fribidi.0:${PORTSDIR}/converters/fribidi
.if defined(WITH_UIM)
CONFIGURE_ARGS+= --enable-uim
MAKE_ENV= LIBS_LOCAL=-L${LOCALBASE}/lib
LIB_DEPENDS+= uim.0:${PORTSDIR}/japanese/uim
LIB_DEPENDS+= uim.0:${PORTSDIR}/textproc/uim
PLIST_SUB+= UIM=""
.else
PLIST_SUB+= UIM="@comment "