databases/mariadb101-server: Security update to 10.1.33

- Fix build on aarch64 [1]
 - Remove ${name}_limits for 11-STABLE [2]

PR:             227628 [1], 227434 [2], 228148 [3]
Submitted by:   Naram Qashat <cyberbotx cyberbotx com> [1]
Submitted by:   0mp [2]
Reported by:    Miroslav Lachman <000 fbsd quip cz> [3]
MFH:            2018Q2
Security:       57aec168-453e-11e8-8777-b499baebfeaf
This commit is contained in:
Bernard Spil 2018-05-11 09:37:49 +00:00
parent 17740079ae
commit b2c1075b5b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=469620
5 changed files with 55 additions and 23 deletions

View File

@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME?= mariadb
PORTVERSION= 10.1.32
PORTREVISION?= 2
PORTVERSION= 10.1.33
PORTREVISION?= 0
CATEGORIES= databases ipv6
MASTER_SITES= http://ftp.osuosl.org/pub/${SITESDIR}/ \
http://mirrors.supportex.net/${SITESDIR}/ \
@ -22,7 +22,6 @@ LICENSE_NAME_PerconaFT= PerconaFT patents license
LICENSE_FILE_PerconaFT= ${WRKSRC}/storage/tokudb/PerconaFT/PATENTS
LICENSE_PERMS_PerconaFT= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BROKEN_aarch64= Fails to link: missing sbrk
BROKEN_SSL= openssl-devel
BROKEN_SSL_REASON_openssl-devel= incomplete definition of type 'struct dh_st'
@ -184,11 +183,10 @@ post-install-MROONGA-on:
.include <bsd.port.options.mk>
.if ${OPSYS} != FreeBSD || ${OSVERSION} < 1101514 || \
${OSVERSION} >= 1200000 && ${OSVERSION} < 1200057
SUB_LIST+= LEGACY_LIMITS="" MODERN_LIMITS="@comment "
.else
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200057
SUB_LIST+= LEGACY_LIMITS="@comment " MODERN_LIMITS=""
.else
SUB_LIST+= LEGACY_LIMITS="" MODERN_LIMITS="@comment "
.endif
.include <bsd.port.pre.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1522324355
SHA256 (mariadb-10.1.32.tar.gz) = 0e2aae6a6a190d07c8e36e87dd43377057fa82651ca3c583462563f3e9369096
SIZE (mariadb-10.1.32.tar.gz) = 68001321
TIMESTAMP = 1525903240
SHA256 (mariadb-10.1.33.tar.gz) = 94312c519f2c0c25e1964c64e22aff0036fb22dfb2685638f43a6b2211395d2d
SIZE (mariadb-10.1.33.tar.gz) = 65292094

View File

@ -0,0 +1,46 @@
--- mysys/stacktrace.c.orig 2018-03-26 14:18:03 UTC
+++ mysys/stacktrace.c
@@ -34,19 +34,19 @@
#include <execinfo.h>
#endif
+#ifdef __linux__
#define PTR_SANE(p) ((p) && (char*)(p) >= heap_start && (char*)(p) <= heap_end)
-
static char *heap_start;
-
-#ifdef HAVE_BSS_START
extern char *__bss_start;
-#endif
+#else
+#define PTR_SANE(p) (p)
+#endif /* __linux */
void my_init_stacktrace()
{
-#ifdef HAVE_BSS_START
+#ifdef __linux__
heap_start = (char*) &__bss_start;
-#endif
+#endif /* __linux__ */
}
#ifdef __linux__
@@ -149,15 +149,15 @@ static int safe_print_str(const char *ad
int my_safe_print_str(const char* val, int max_len)
{
+#ifdef __linux__
char *heap_end;
-#ifdef __linux__
// Try and make use of /proc filesystem to safely print memory contents.
if (!safe_print_str(val, max_len))
return 0;
-#endif
heap_end= (char*) sbrk(0);
+#endif
if (!PTR_SANE(val))
{

View File

@ -1,12 +0,0 @@
--- sql-common/client.c.orig 2018-01-24 00:36:45.520273000 +0100
+++ sql-common/client.c 2018-01-24 00:37:57.536367000 +0100
@@ -1821,7 +1821,8 @@
*/
#ifdef HAVE_X509_check_host
- ret_validation= X509_check_host(server_cert, server_hostname, 0, 0, 0) != 1;
+ ret_validation= X509_check_host(server_cert, server_hostname,
+ strlen(server_hostname), 0, 0) != 1;
#else
subject= X509_get_subject_name(server_cert);
cn_loc= X509_NAME_get_index_by_NID(subject, NID_commonName, -1);

View File

@ -72,8 +72,8 @@ include/mysql/private/my_md5.h
include/mysql/private/my_nosys.h
include/mysql/private/my_rdtsc.h
include/mysql/private/my_rnd.h
include/mysql/private/my_service_manager.h
include/mysql/private/my_stacktrace.h
include/mysql/private/my_systemd.h
include/mysql/private/my_time.h
include/mysql/private/my_tree.h
include/mysql/private/my_uctype.h