Add new port of libvorbis, a library for handling Vorbis-encoded
Ogg streams. PR: 22097 Submitted by: Theo van Klaveren <t.vanklaveren@student.utwente.nl>
This commit is contained in:
parent
ed5b75356a
commit
b2aa1c9be4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=34669
@ -81,6 +81,7 @@
|
||||
SUBDIR += libogg
|
||||
SUBDIR += libshout
|
||||
SUBDIR += libsidplay
|
||||
SUBDIR += libvorbis
|
||||
SUBDIR += libworkman
|
||||
SUBDIR += linux-realplayer
|
||||
SUBDIR += lopster
|
||||
|
34
audio/libvorbis/Makefile
Normal file
34
audio/libvorbis/Makefile
Normal file
@ -0,0 +1,34 @@
|
||||
# New ports collection makefile for: libvorbis
|
||||
# Date created: 18 October 2000
|
||||
# Whom: t.vanklaveren@student.utwente.nl
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libvorbis
|
||||
PORTVERSION= 20001018
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://home.student.utwente.nl/t.vanklaveren/distfiles/
|
||||
DISTNAME= vorbis-${PORTVERSION}
|
||||
|
||||
MAINTAINER= t.vanklaveren@student.utwente.nl
|
||||
|
||||
LIB_DEPENDS= ogg.0:${PORTSDIR}/audio/libogg
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LIBTOOL= yes
|
||||
WRKSRC= ${WRKDIR}/vorbis
|
||||
|
||||
ACLOCAL?= ${LOCALBASE}/bin/aclocal
|
||||
AUTOHEADER?= ${LOCALBASE}/bin/autoheader
|
||||
CFLAGS+= -I${LOCALBASE}/include
|
||||
CONFIGURE_ARGS+= --with-ogg=${LOCALBASE}
|
||||
|
||||
post-patch:
|
||||
cd ${WRKSRC} && ${ACLOCAL}
|
||||
cd ${WRKSRC} && ${AUTOHEADER}
|
||||
cd ${WRKSRC} && ${AUTOMAKE} --add-missing
|
||||
cd ${WRKSRC} && ${AUTOCONF}
|
||||
|
||||
.include <bsd.port.mk>
|
1
audio/libvorbis/distinfo
Normal file
1
audio/libvorbis/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (vorbis-20001018.tar.gz) = e2a134ed638617ffcd702a69590fd868
|
11
audio/libvorbis/files/patch-aa
Normal file
11
audio/libvorbis/files/patch-aa
Normal file
@ -0,0 +1,11 @@
|
||||
--- doc/Makefile.am.orig Wed Oct 18 23:23:41 2000
|
||||
+++ doc/Makefile.am Wed Oct 18 23:23:51 2000
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
AUTOMAKE_OPTIONS = foreign
|
||||
|
||||
-docdir = $(prefix)/doc/$(PACKAGE)-$(VERSION)
|
||||
+docdir = $(prefix)/share/doc/$(PACKAGE)-$(VERSION)
|
||||
|
||||
doc_DATA = v-comment.html vorbisword2.png white-ogg.png programming.html\
|
||||
vorbis.html wait.png white-xifish.png
|
1
audio/libvorbis/pkg-comment
Normal file
1
audio/libvorbis/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
MP3-comparable audio compression codec library
|
17
audio/libvorbis/pkg-descr
Normal file
17
audio/libvorbis/pkg-descr
Normal file
@ -0,0 +1,17 @@
|
||||
Vorbis is a general-purpose audio and music encoding format contemporary to
|
||||
MPEG-4's AAC and TwinVQ, the next generation beyond MPEG audio layer 3. Unlike
|
||||
the MPEG sponsored formats (and other proprietary formats such as RealAudio G2
|
||||
and Windows' flavor of the month), the Vorbis CODEC specification belongs to
|
||||
the public domain. All the technical details are published and documented, and
|
||||
any software entity may make full use of the format without royalty or patent
|
||||
concerns.
|
||||
|
||||
This package contains libvorbis, an LGPLed software implementation of the
|
||||
Vorbis specification by the Xiphophorus company (http://www.xiph.org/), and
|
||||
vorbisfile, an LGPLed convenience library built on Vorbis designed to simplify
|
||||
common uses.
|
||||
|
||||
WWW: http://www.vorbis.com
|
||||
|
||||
- Theo van Klaveren
|
||||
t.vanklaveren@student.utwente.nl
|
96
audio/libvorbis/pkg-plist
Normal file
96
audio/libvorbis/pkg-plist
Normal file
@ -0,0 +1,96 @@
|
||||
include/vorbis/backends.h
|
||||
include/vorbis/codebook.h
|
||||
include/vorbis/codec.h
|
||||
include/vorbis/mode_A.h
|
||||
include/vorbis/mode_B.h
|
||||
include/vorbis/mode_C.h
|
||||
include/vorbis/mode_D.h
|
||||
include/vorbis/mode_E.h
|
||||
include/vorbis/modes.h
|
||||
include/vorbis/vorbisfile.h
|
||||
include/vorbis/book/lsp12_0.vqh
|
||||
include/vorbis/book/lsp30_0.vqh
|
||||
include/vorbis/book/res0_1024a_128_1.vqh
|
||||
include/vorbis/book/res0_1024a_128_2.vqh
|
||||
include/vorbis/book/res0_1024a_128_3.vqh
|
||||
include/vorbis/book/res0_1024a_128_4.vqh
|
||||
include/vorbis/book/res0_1024a_128_5.vqh
|
||||
include/vorbis/book/res0_1024a_128_6.vqh
|
||||
include/vorbis/book/res0_1024a_128_7.vqh
|
||||
include/vorbis/book/res0_1024a_128_8.vqh
|
||||
include/vorbis/book/res0_1024a_128_9.vqh
|
||||
include/vorbis/book/res0_1024a_160_1.vqh
|
||||
include/vorbis/book/res0_1024a_160_2.vqh
|
||||
include/vorbis/book/res0_1024a_160_3.vqh
|
||||
include/vorbis/book/res0_1024a_160_4.vqh
|
||||
include/vorbis/book/res0_1024a_160_5.vqh
|
||||
include/vorbis/book/res0_1024a_160_6.vqh
|
||||
include/vorbis/book/res0_1024a_160_7.vqh
|
||||
include/vorbis/book/res0_1024a_160_8.vqh
|
||||
include/vorbis/book/res0_1024a_160_9.vqh
|
||||
include/vorbis/book/res0_1024a_192_1.vqh
|
||||
include/vorbis/book/res0_1024a_192_2.vqh
|
||||
include/vorbis/book/res0_1024a_192_3.vqh
|
||||
include/vorbis/book/res0_1024a_192_4.vqh
|
||||
include/vorbis/book/res0_1024a_192_5.vqh
|
||||
include/vorbis/book/res0_1024a_256_1.vqh
|
||||
include/vorbis/book/res0_1024a_256_2.vqh
|
||||
include/vorbis/book/res0_1024a_256_3.vqh
|
||||
include/vorbis/book/res0_1024a_256_4.vqh
|
||||
include/vorbis/book/res0_1024a_256_5.vqh
|
||||
include/vorbis/book/res0_1024a_350_1.vqh
|
||||
include/vorbis/book/res0_1024a_350_2.vqh
|
||||
include/vorbis/book/res0_1024a_350_3.vqh
|
||||
include/vorbis/book/res0_1024a_350_4.vqh
|
||||
include/vorbis/book/res0_1024a_350_5.vqh
|
||||
include/vorbis/book/res0_128a_128_1.vqh
|
||||
include/vorbis/book/res0_128a_128_2.vqh
|
||||
include/vorbis/book/res0_128a_128_3.vqh
|
||||
include/vorbis/book/res0_128a_128_4.vqh
|
||||
include/vorbis/book/res0_128a_128_5.vqh
|
||||
include/vorbis/book/res0_128a_160_1.vqh
|
||||
include/vorbis/book/res0_128a_160_2.vqh
|
||||
include/vorbis/book/res0_128a_160_3.vqh
|
||||
include/vorbis/book/res0_128a_160_4.vqh
|
||||
include/vorbis/book/res0_128a_160_5.vqh
|
||||
include/vorbis/book/res0_128a_192_1.vqh
|
||||
include/vorbis/book/res0_128a_192_2.vqh
|
||||
include/vorbis/book/res0_128a_192_3.vqh
|
||||
include/vorbis/book/res0_128a_192_4.vqh
|
||||
include/vorbis/book/res0_128a_192_5.vqh
|
||||
include/vorbis/book/res0_128a_256_1.vqh
|
||||
include/vorbis/book/res0_128a_256_2.vqh
|
||||
include/vorbis/book/res0_128a_256_3.vqh
|
||||
include/vorbis/book/res0_128a_256_4.vqh
|
||||
include/vorbis/book/res0_128a_256_5.vqh
|
||||
include/vorbis/book/res0_128a_350_1.vqh
|
||||
include/vorbis/book/res0_128a_350_2.vqh
|
||||
include/vorbis/book/res0_128a_350_3.vqh
|
||||
include/vorbis/book/res0_128a_350_4.vqh
|
||||
include/vorbis/book/res0_128a_350_5.vqh
|
||||
include/vorbis/book/resaux0_1024a_128.vqh
|
||||
include/vorbis/book/resaux0_1024a_160.vqh
|
||||
include/vorbis/book/resaux0_1024a_192.vqh
|
||||
include/vorbis/book/resaux0_1024a_256.vqh
|
||||
include/vorbis/book/resaux0_1024a_350.vqh
|
||||
include/vorbis/book/resaux0_128a_128.vqh
|
||||
include/vorbis/book/resaux0_128a_160.vqh
|
||||
include/vorbis/book/resaux0_128a_192.vqh
|
||||
include/vorbis/book/resaux0_128a_256.vqh
|
||||
include/vorbis/book/resaux0_128a_350.vqh
|
||||
lib/libvorbis.a
|
||||
lib/libvorbis.so
|
||||
lib/libvorbis.so.0
|
||||
lib/libvorbisfile.a
|
||||
lib/libvorbisfile.so
|
||||
lib/libvorbisfile.so.0
|
||||
share/doc/libvorbis-1.0.0/programming.html
|
||||
share/doc/libvorbis-1.0.0/v-comment.html
|
||||
share/doc/libvorbis-1.0.0/vorbis.html
|
||||
share/doc/libvorbis-1.0.0/vorbisword2.png
|
||||
share/doc/libvorbis-1.0.0/wait.png
|
||||
share/doc/libvorbis-1.0.0/white-ogg.png
|
||||
share/doc/libvorbis-1.0.0/white-xifish.png
|
||||
@dirrm include/vorbis/book
|
||||
@dirrm include/vorbis
|
||||
@dirrm share/doc/libvorbis-1.0.0
|
Loading…
Reference in New Issue
Block a user