Add pmars-sdl: Port of pMARS using the Simple Directmedia Library.

PR:		ports/84351
Submitted by:	Alejandro Pulver (alejandro at varnet.biz)
This commit is contained in:
Dejan Lesjak 2005-07-31 02:31:38 +00:00
parent 4ae1da5b8f
commit b233cd98cd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=140515
5 changed files with 95 additions and 0 deletions

View File

@ -393,6 +393,7 @@
SUBDIR += pinball
SUBDIR += pipenightdreams
SUBDIR += pmars
SUBDIR += pmars-sdl
SUBDIR += polypuzzle
SUBDIR += powermanga
SUBDIR += powerpak

58
games/pmars-sdl/Makefile Normal file
View File

@ -0,0 +1,58 @@
# New ports collection makefile for: pmars-sdl
# Date created: 30 Jul 2005
# Whom: Alejandro Pulver <alejandro@varnet.biz>
#
# $FreeBSD$
#
PORTNAME= pmars
PORTVERSION= 0.9.2
CATEGORIES= games
MASTER_SITES= http://www.cs.helsinki.fi/u/jpihlaja/cw/pmars-sdl/
PKGNAMESUFFIX= -sdl
DISTNAME= ${PORTNAME}-${PORTVERSION}-5
MAINTAINER= alejandro@varnet.biz
COMMENT= Port of pMARS using the Simple Directmedia Library
USE_GCC= 3.1+
USE_SDL= sdl
WRKSRC= ${WRKDIR}/${DISTNAME}/src
OPTIONS= ICWS94 "Enable ICWS'94 support" on \
OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
PERMUTATE "Enable the -P switch" on \
SMALLMEM "Use 16-bit addresses (smaller)" off
MAKE_ARGS+= CFLAGS+="${CFLAGS}" \
CFLAGS+="-fno-builtin" \
CFLAGS+="`${SDL_CONFIG} --cflags`" \
LIB+="`${SDL_CONFIG} --libs`" \
CFLAGS+="-DSDLGRAPHX"
PLIST_FILES= bin/${PORTNAME}${PKGNAMESUFFIX}
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} \
${PREFIX}/bin/${PORTNAME}${PKGNAMESUFFIX}
.include <bsd.port.pre.mk>
.if defined(WITH_ICWS94)
MAKE_ARGS+= CFLAGS+="-DEXT94"
.endif
.if defined(WITH_OPTIMIZED_CFLAGS)
MAKE_ARGS+= CFLAGS+="-O3 -fomit-frame-pointer"
.endif
.if defined(WITH_PERMUTATE)
MAKE_ARGS+= CFLAGS+="-DPERMUTATE"
.endif
.if defined(WITH_SMALLMEM)
MAKE_ARGS+= CFLAGS+="-DSMALLMEM"
.endif
.include <bsd.port.post.mk>

2
games/pmars-sdl/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (pmars-0.9.2-5.tar.gz) = 4733185c5eb6a4554a54d91331e6501d
SIZE (pmars-0.9.2-5.tar.gz) = 200966

View File

@ -0,0 +1,17 @@
--- Makefile.orig Thu May 1 10:09:46 2003
+++ Makefile Mon Jul 18 09:49:02 2005
@@ -1,5 +1,4 @@
# generic UNIX makefile
-CC = gcc # req. for linux
#CC = cc # if you don't have gcc
# Configuration options:
#
@@ -18,8 +17,6 @@
# (8) -DSDLGRAPHX 1 SDL graphics (generic)
#DBG = -g -W -Wall -pg
-CFLAGS = -O4 -fomit-frame-pointer $(DBG) -DSERVER -DEXT94 -DPERMUTATE $(INC)
-LFLAGS = -x
# LIB = -lcurses -ltermlib # enable this one for curses display
# LIB = -lvgagl -lvga # enable this one for Linux/SVGA
# LIB = -L/usr/X11R6/lib -lX11 # enable this one for X11

17
games/pmars-sdl/pkg-descr Normal file
View File

@ -0,0 +1,17 @@
Port of pMARS using the Simple Directmedia Library. Currently the port is in
beta testing stage testing and bug reports/feature requests are more than
welcome. The latest release is version 0.9.2-5.
Features/fixes:
* Environment sensitive. Now looks for macro files in the directory specified
by the environment variable PMARSHOME if they are not found in the current
directory.
* Both Win32 and X11 supported.
* Command line history using Shift-Up and Shift-Down keys.
* Rewrote text display and screen update routines for faster text panels (for
slow computers like mine.)
* BIG core cells for those tiny cores. (Choose a display mode larger than 2,
e.g. -v 134.)
WWW: http://www.cs.helsinki.fi/u/jpihlaja/cw/pmars-sdl/