Add a port for `pgdriver', the OpenACS projects supported AOLserver
to PostgreSQL interface.
This commit is contained in:
parent
5ff72b2dc1
commit
b229f25fba
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=39640
@ -185,6 +185,7 @@
|
||||
SUBDIR += p5-libapreq
|
||||
SUBDIR += p5-libwww
|
||||
SUBDIR += peacock
|
||||
SUBDIR += pgdriver
|
||||
SUBDIR += plugger
|
||||
SUBDIR += pruby
|
||||
SUBDIR += publicfile
|
||||
|
21
www/pgdriver/Makefile
Normal file
21
www/pgdriver/Makefile
Normal file
@ -0,0 +1,21 @@
|
||||
# New ports collection makefile for: pgdriver
|
||||
# Date created: 12 March 2001
|
||||
# Whom: jkoshy
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= pgdriver
|
||||
PORTVERSION= 1.1
|
||||
CATEGORIES= www databases
|
||||
MASTER_SITES= http://openacs.org/sdm/download-package/2/20/
|
||||
|
||||
MAINTAINER= jkoshy@freebsd.org
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/aolserver/bin/nsd:${PORTSDIR}/www/aolserver \
|
||||
${LOCALBASE}/pgsql/bin/postmaster:${PORTSDIR}/databases/postgresql7
|
||||
RUN_DEPENDS= ${BUILD_DEPENDS}
|
||||
|
||||
MAKEFILE= makefile
|
||||
|
||||
.include <bsd.port.mk>
|
1
www/pgdriver/distinfo
Normal file
1
www/pgdriver/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (pgdriver-1.1.tar.gz) = c7fb77755fe12f51929b8370b35141fc
|
31
www/pgdriver/files/patch-aa
Normal file
31
www/pgdriver/files/patch-aa
Normal file
@ -0,0 +1,31 @@
|
||||
--- makefile-- Thu Mar 1 12:44:27 2001
|
||||
+++ makefile Thu Mar 1 12:46:38 2001
|
||||
@@ -33,15 +33,15 @@
|
||||
# package installed AOLserver and PostgreSQL
|
||||
|
||||
# Location of the PostgreSQL libraries
|
||||
-#PGLIB=/usr/local/pgsql/lib
|
||||
+PGLIB=/usr/local/pgsql/lib
|
||||
|
||||
# Location of the PostgreSQL includes
|
||||
-#PGINC=/usr/local/pgsql/include
|
||||
+PGINC=/usr/local/pgsql/include
|
||||
|
||||
# Location of the AOLserver files (normally the ~nsadmin directory):
|
||||
#NSHOME=/opt/aolserver
|
||||
# Alternate location for AOLserver
|
||||
-#NSHOME=/usr/local/AOLserver
|
||||
+NSHOME=/usr/local/aolserver
|
||||
|
||||
CC=gcc
|
||||
COPTS=-Wall -fpic -shared -I/usr/local/pgsql/include -I/home/nsadmin/include -I-/usr/include
|
||||
@@ -82,8 +82,8 @@
|
||||
# FreeBSD 3
|
||||
# The make install target isn't what you want---just copy postgres.so to
|
||||
# /usr/local/libexec/aolserver
|
||||
-#COPTS=-g -Wall -fpic -pthread -D_THREAD_SAFE -I/usr/local/include/aolserver -I/usr/local/pgsql/include
|
||||
-#LDFLAGS=-pthread -Wl,-E
|
||||
+COPTS=-g -Wall -fpic -pthread -D_THREAD_SAFE -I${NSHOME}/include -I${PGINC}
|
||||
+LDFLAGS=-pthread -Wl,-E
|
||||
|
||||
# You should not need to edit anything below this line.
|
11
www/pgdriver/files/patch-ab
Normal file
11
www/pgdriver/files/patch-ab
Normal file
@ -0,0 +1,11 @@
|
||||
--- postgres.c-- Fri Jun 30 01:42:10 2000
|
||||
+++ postgres.c Thu Mar 1 14:41:54 2001
|
||||
@@ -1139,7 +1139,7 @@
|
||||
char* filename)
|
||||
{
|
||||
int fd, i, j, segment, readlen;
|
||||
- char in_buf[6000], out_buf[8000], query[100];
|
||||
+ char in_buf[6001], out_buf[8001], query[8100];
|
||||
char *segment_pos;
|
||||
|
||||
fd = open (filename, O_RDONLY);
|
1
www/pgdriver/pkg-comment
Normal file
1
www/pgdriver/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A driver for AOLserver to PostgreSQL connectivity
|
3
www/pgdriver/pkg-descr
Normal file
3
www/pgdriver/pkg-descr
Normal file
@ -0,0 +1,3 @@
|
||||
A driver for AOLserver to PostgreSQL connectivity.
|
||||
|
||||
This is the supported driver for the OpenACS project.
|
1
www/pgdriver/pkg-plist
Normal file
1
www/pgdriver/pkg-plist
Normal file
@ -0,0 +1 @@
|
||||
aolserver/bin/postgres.so
|
Loading…
Reference in New Issue
Block a user