PR: ports/11468
Submitted by: Keith Jang <jtjang@gcn.net.tw> Update xcin to xcin-2.5.1 after repo copied. Old xcin will be dropped out after few months. xcin is a Chinese INput application in X, well support in both Traditional Chinese(Big5) and Simplified Chinese(GB) charsets. New version of xcin support standard XIM too. You can activate one xcin-XIM server, meanwhile, use different locale configuration to input Big5/GB words at the different sessions. This port is current version of xcin, code rewritten by Tung-Han Hsieh <thhsieh@linux.org.tw>. WWW: http://xcin.linux.org.tw/ Porting to FreeBSD by Yung-Jen Hung <winard@ms11.url.com.tw> & Keith Jang <jtjang@gcn.net.tw>.
This commit is contained in:
parent
d7af4f1da5
commit
b215d940f4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=21369
@ -1,26 +1,69 @@
|
||||
# New ports collection makefile for: xcin
|
||||
# Version required: xcin-2.3.03
|
||||
# Date created: Nov 28 ,1997
|
||||
# Whom: Yen-Shuo Su <yssu@CCCA.NCTU.edu.tw>
|
||||
# New ports collection makefile for: xcin25
|
||||
# Version required: xcin-2.5.1
|
||||
# Date created: 25 June 1999
|
||||
# Whom: Keith Jang <jtjang@gcn.net.tw>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
DISTNAME= xcin-2.3.03
|
||||
PKGNAME= zh-xcin-2.3.03
|
||||
CATEGORIES= chinese
|
||||
MASTER_SITES= ftp://xcin.linux.org.tw/pub/xcin/xcin/ \
|
||||
ftp://ftp.ncu.edu.tw/OS/Linux/Chinese/xcin/xcin/ \
|
||||
ftp://linux.cis.nctu.edu.tw/packages/chinese/X/xcin/xcin/
|
||||
DISTNAME= xcin-2.5.1
|
||||
PKGNAME= zh-xcin-2.5.1
|
||||
CATEGORIES= chinese x11
|
||||
MASTER_SITES= ftp://xcin.linux.org.tw/pub/xcin/xcin/
|
||||
|
||||
MAINTAINER= yssu@CCCA.NCTU.edu.tw
|
||||
MAINTAINER= jtjang@gcn.net.tw
|
||||
|
||||
RUN_DEPENDS= ${X11BASE}/lib/X11/fonts/local/kc15f.pcf.gz:${PORTSDIR}/chinese/kcfonts
|
||||
LIB_DEPENDS= tabe.0:${PORTSDIR}/chinese/libtabe \
|
||||
intl.1:${PORTSDIR}/devel/gettext
|
||||
BUILD_DEPENDS= ${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db
|
||||
RUN_DEPENDS= ${PREFIX}/lib/X11/locale/zh_TW.Big5/XLC_LOCALE:${PORTSDIR}/x11/XFree86
|
||||
|
||||
WRKSRC= ${WRKDIR}/xcin-2.5
|
||||
USE_X_PREFIX= yes
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --prefix="${X11BASE}" --os=FreeBSD --no-menu
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --prefix=${PREFIX} \
|
||||
--with-xcin-dir=${PREFIX}/lib/X11/xcin25 \
|
||||
--with-dbinc=${LOCALBASE}/include/db2 \
|
||||
--with-dblib=${LOCALBASE}/lib \
|
||||
--with-tabeinc=${LOCALBASE}/include/tabe \
|
||||
--with-tabelib=${LOCALBASE}/lib \
|
||||
--with-intlinc=${LOCALBASE}/include \
|
||||
--with-intllib=${LOCALBASE}/lib
|
||||
|
||||
MAN1= xcin.1 cin2tab.1
|
||||
post-install:
|
||||
${STRIP} ${PREFIX}/bin/xcin2.5
|
||||
${STRIP} ${PREFIX}/lib/X11/xcin25/bin/cin2tab
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/lib/X11/xcin25/doc
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/Bugs ${PREFIX}/lib/X11/xcin25/doc
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/COPYING ${PREFIX}/lib/X11/xcin25/doc
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/CREDITS ${PREFIX}/lib/X11/xcin25/doc
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/Changes ${PREFIX}/lib/X11/xcin25/doc
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/Cin ${PREFIX}/lib/X11/xcin25/doc
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/CopyRight ${PREFIX}/lib/X11/xcin25/doc
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/FAQ ${PREFIX}/lib/X11/xcin25/doc
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/README ${PREFIX}/lib/X11/xcin25/doc
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/SETUP ${PREFIX}/lib/X11/xcin25/doc
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/Todo ${PREFIX}/lib/X11/xcin25/doc
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/Usage ${PREFIX}/lib/X11/xcin25/doc
|
||||
${MKDIR} ${PREFIX}/lib/X11/xcin25/doc/internal
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/internal/IMdkit \
|
||||
${PREFIX}/lib/X11/xcin25/doc/internal
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/internal/gen_inp \
|
||||
${PREFIX}/lib/X11/xcin25/doc/internal
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/internal/module \
|
||||
${PREFIX}/lib/X11/xcin25/doc/internal
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/internal/structer \
|
||||
${PREFIX}/lib/X11/xcin25/doc/internal
|
||||
${MKDIR} ${PREFIX}/lib/X11/xcin25/doc/modules
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/modules/bimsphone \
|
||||
${PREFIX}/lib/X11/xcin25/doc/modules
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/modules/gen_inp \
|
||||
${PREFIX}/lib/X11/xcin25/doc/modules
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/modules/im_comm \
|
||||
${PREFIX}/lib/X11/xcin25/doc/modules
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/modules/zh_hex \
|
||||
${PREFIX}/lib/X11/xcin25/doc/modules
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1 +1 @@
|
||||
MD5 (xcin-2.3.03.tar.gz) = b6b4715a1fddac8377005d6ac12b248a
|
||||
MD5 (xcin-2.5.1.tar.gz) = 35f9b95585e1322da73362802dad7efa
|
||||
|
@ -1,62 +1,13 @@
|
||||
--- script/config.status.orig Fri Dec 11 09:36:32 1998
|
||||
+++ script/config.status Sun Jan 17 14:42:51 1999
|
||||
@@ -14,8 +14,8 @@
|
||||
PATH_XCIN_DIR=/usr/local/lib/xcin
|
||||
PATH_XCIN_MAN=/usr/local/man
|
||||
--- src/util/cin2tab/Makefile.in.orig Sun Aug 15 00:03:26 1999
|
||||
+++ src/util/cin2tab/Makefile.in Sun Aug 15 00:13:01 1999
|
||||
@@ -58,7 +58,8 @@
|
||||
distclean: clean
|
||||
rm -f Makefile .depend
|
||||
install: $(BIN)
|
||||
- if [ -f $(xcin_binp)/$(BIN) ]; then mv $(xcin_binp)/$(BIN) $(xcin_binp)/$(BIN).old; fi
|
||||
- $(INSTALL_PROGRAM) $(BIN) $(xcin_binp)
|
||||
+ if [ ! -d $(xcin_libp)/bin ]; then mkdir -p $(xcin_libp)/bin; fi
|
||||
+ if [ -f $(xcin_libp)/bin/$(BIN) ]; then mv $(xcin_libp)/bin/$(BIN) $(xcin_libp)/bin/$(BIN).old; fi
|
||||
+ $(INSTALL_PROGRAM) $(BIN) $(xcin_libp)/bin
|
||||
|
||||
-OPT_XCIN_CFONT=-twmoe-kai-medium-r-normal--24-240-75-75-c-240-big5-1
|
||||
-OPT_XCIN_EFONT=12x24
|
||||
+OPT_XCIN_CFONT=kc15f
|
||||
+OPT_XCIN_EFONT=kc8x15
|
||||
OPT_UTIL_CIN2TAB=yes
|
||||
OPT_UTIL_TSINTOOLS=yes
|
||||
OPT_INPTAB_SRC=yes
|
||||
--- script/configure.makefile.orig Fri Dec 11 09:18:08 1998
|
||||
+++ script/configure.makefile Sun Jan 17 14:34:16 1999
|
||||
@@ -78,7 +78,7 @@
|
||||
: # AIX
|
||||
else
|
||||
INSTALL="$dir/install -c"
|
||||
- INSTALL_PROGRAM='$(INSTALL)'
|
||||
+ INSTALL_PROGRAM='$(INSTALL) -s'
|
||||
INSTALL_DATA='$(INSTALL) -m 644'
|
||||
INSTALL_DIR='$(INSTALL) -d'
|
||||
break
|
||||
--- script/configure.menu.orig Fri Dec 11 09:49:43 1998
|
||||
+++ script/configure.menu Sun Jan 17 14:40:11 1999
|
||||
@@ -266,7 +266,7 @@
|
||||
{
|
||||
PATH_XCIN_PREFIX=$1
|
||||
PATH_XCIN_BIN=$PATH_XCIN_PREFIX/bin
|
||||
- PATH_XCIN_DIR=$PATH_XCIN_PREFIX/lib/xcin
|
||||
+ PATH_XCIN_DIR=$PATH_XCIN_PREFIX/lib/X11/xcin
|
||||
PATH_XCIN_MAN=$PATH_XCIN_PREFIX/man
|
||||
}
|
||||
|
||||
--- src/Makefile.in.orig Wed Dec 9 22:26:36 1998
|
||||
+++ src/Makefile.in Sun Jan 17 14:34:16 1999
|
||||
@@ -149,7 +149,7 @@
|
||||
|
||||
install_xcin: xcin $(KBMS) $(INPUT0) tsintab
|
||||
if [ ! -d $(PATH_XCIN_BIN) ]; then $(INSTALL_DIR) $(PATH_XCIN_BIN); fi
|
||||
- $(INSTALL) xcin $(PATH_XCIN_BIN)
|
||||
+ $(INSTALL_PROGRAM) xcin $(PATH_XCIN_BIN)
|
||||
echo $(PATH_XCIN_BIN)/xcin >> filelist
|
||||
|
||||
if [ ! -d $(PATH_XCIN_DIR) ]; then $(INSTALL_DIR) $(PATH_XCIN_DIR); fi
|
||||
@@ -159,13 +159,13 @@
|
||||
|
||||
install_cin2tab: cin2tab
|
||||
if [ ! -d $(PATH_XCIN_DIR) ]; then $(INSTALL_DIR) $(PATH_XCIN_DIR); fi
|
||||
- $(INSTALL) cin2tab $(PATH_XCIN_DIR)
|
||||
+ $(INSTALL_PROGRAM) cin2tab $(PATH_XCIN_DIR)
|
||||
echo $(PATH_XCIN_DIR)/cin2tab >> filelist
|
||||
|
||||
install_tsintools: tsintools
|
||||
if [ ! -d $(PATH_XCIN_DIR) ]; then $(INSTALL_DIR) $(PATH_XCIN_DIR); fi
|
||||
for f in $(TSINTOOLS); do\
|
||||
- $(INSTALL) $$f $(PATH_XCIN_DIR); echo $(PATH_XCIN_DIR)/$$f >> filelist;\
|
||||
+ $(INSTALL_PROGRAM) $$f $(PATH_XCIN_DIR); echo $(PATH_XCIN_DIR)/$$f >> filelist;\
|
||||
done
|
||||
|
||||
install_tsintabsrc:
|
||||
include .depend
|
||||
|
@ -1,29 +1,8 @@
|
||||
--- src/xi.c.orig Wed Dec 9 22:43:13 1998
|
||||
+++ src/xi.c Thu Jul 22 12:34:14 1999
|
||||
@@ -1056,19 +1056,25 @@
|
||||
|
||||
void switch_active_client( InmdState *state, Window cli_win )
|
||||
{
|
||||
+ int refresh = 1;
|
||||
last_win = cli_win;
|
||||
|
||||
if ( ignore_cli_stat )
|
||||
ignore_cli_stat = 0;
|
||||
else
|
||||
if ( state->_CurInMethod )
|
||||
- memcpy( &inmdstate, state, sizeof( inmdstate ) );
|
||||
+ if(memcmp(&inmdstate, state, sizeof( inmdstate)))
|
||||
+ memcpy( &inmdstate, state, sizeof( inmdstate ) );
|
||||
+ else
|
||||
+ refresh = 0;
|
||||
|
||||
if ( hide_xcin && ( EngChi || HalfFull ) )
|
||||
Show_Xcin();
|
||||
else if ( hide_xcin && !EngChi && !HalfFull )
|
||||
XUnmapWindow( display, main_win );
|
||||
|
||||
+ if(!refresh)
|
||||
+ return;
|
||||
gotoxy( 0, MROW - 1 );
|
||||
|
||||
ClrShowArea( 0 );
|
||||
--- src/lib/Makefile.in.orig Sun Aug 15 00:23:04 1999
|
||||
+++ src/lib/Makefile.in Sun Aug 15 00:23:24 1999
|
||||
@@ -30,3 +30,5 @@
|
||||
rm -f Makefile
|
||||
for d in $(SUBSYS); do ( cd $$d; $(MAKE) distclean ); done
|
||||
( cd IMdkit; $(MAKE) clean )
|
||||
+
|
||||
+install:
|
||||
|
11
chinese/xcin25/files/patch-ad
Normal file
11
chinese/xcin25/files/patch-ad
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/Makefile.in.orig Sun Aug 15 00:34:38 1999
|
||||
+++ src/Makefile.in Sun Aug 15 00:35:31 1999
|
||||
@@ -45,7 +45,7 @@
|
||||
LIB = -lm ${x_libraries} ${extra_lib} ${locale_lib} ${dl_lib} ${intl_lib} \
|
||||
${xcinlib} -lXimd -lim_comm -lxcintool -lsiod
|
||||
|
||||
-BIN = xcin
|
||||
+BIN = xcin2.5
|
||||
SRC = xcin_main.c module.c gui.c xim.c xim_IC.c fkey.c
|
||||
OBJ = xcin_main.o module.o gui.o xim.o xim_IC.o fkey.o
|
||||
SUBSYS = lib Cinput
|
13
chinese/xcin25/files/patch-ae
Normal file
13
chinese/xcin25/files/patch-ae
Normal file
@ -0,0 +1,13 @@
|
||||
--- src/xcinrc.in.orig Fri Sep 3 01:17:52 1999
|
||||
+++ src/xcinrc.in Fri Sep 3 01:18:29 1999
|
||||
@@ -86,8 +86,8 @@
|
||||
(define bimsphone
|
||||
'((SETKEY 6)
|
||||
(MODULE "bimsphone")
|
||||
- (TSI_FNAME "tsi.db")
|
||||
- (YIN_FNAME "yin.db")
|
||||
+ (TSI_FNAME "/usr/local/share/tabe/tsiyin/tsi.db")
|
||||
+ (YIN_FNAME "/usr/local/share/tabe/tsiyin/yin.db")
|
||||
(KEYMAP 0))) ; 0: 零壹, 1: 倚天, 2: 許氏
|
||||
|
||||
(define cj
|
@ -1 +1 @@
|
||||
A chinese input utility in X
|
||||
A Chinese input method server under X.
|
||||
|
@ -1,14 +1,12 @@
|
||||
Thanks to Mr. Edward Der-Hua Liu and others who developed the xcin
|
||||
system. With the wonderful program, we can do a lot of operations with
|
||||
Chinese under the X Window System in the UN*X world. As time goes on,
|
||||
more and more people use it, and more and more comments appear. The
|
||||
package hs been upgraded with time but it seems that the install process
|
||||
is not convenient and self-consistent. These confuse a lot of people,
|
||||
especially for new users in the UN*X world. We often see the `Big FAQs'
|
||||
about xcin such as `how can I install the Chinese fonts' or `the cj2cin
|
||||
command not found' or `the crxvt terminal is too big!!' or something
|
||||
appears in the newsgroup again and again. In fact, such problems are
|
||||
easy to remedy. Because I really like this program and feel that I may
|
||||
do something to improve this package, I try my best to re-write the
|
||||
Makefiles and auto-configuration programs of this package to try to
|
||||
solve these troubles. This comes the `xcin-2.3' project.
|
||||
xcin is a Chinese INput application in X, well support in both Traditional
|
||||
Chinese(Big5) and Simplified Chinese(GB) charsets. New version of xcin support
|
||||
standard XIM too. You can activate one xcin-XIM server, meanwhile, use
|
||||
different locale configuration to input Big5/GB words at the different
|
||||
sessions. This port is current version of xcin, code rewritten by
|
||||
Tung-Han Hsieh <thhsieh@linux.org.tw>.
|
||||
|
||||
WWW: http://xcin.linux.org.tw/
|
||||
|
||||
Porting to FreeBSD by Yung-Jen Hung <winard@ms11.url.com.tw>
|
||||
& Keith Jang <jtjang@gcn.net.tw>.
|
||||
|
||||
|
@ -1,42 +1,56 @@
|
||||
bin/xcin
|
||||
lib/X11/xcin/cin2tab
|
||||
lib/X11/xcin/cj.cin
|
||||
lib/X11/xcin/cj.tab
|
||||
lib/X11/xcin/cj.tab.rev
|
||||
lib/X11/xcin/et.kbm
|
||||
lib/X11/xcin/et26.kbm
|
||||
lib/X11/xcin/hsu.kbm
|
||||
lib/X11/xcin/lphrase
|
||||
lib/X11/xcin/pho.sel1st
|
||||
lib/X11/xcin/pho.tab
|
||||
lib/X11/xcin/phone.cin
|
||||
lib/X11/xcin/phone.tab
|
||||
lib/X11/xcin/phone.tab.rev
|
||||
lib/X11/xcin/phs_out
|
||||
lib/X11/xcin/pin2tsin
|
||||
lib/X11/xcin/pinyin.cin
|
||||
lib/X11/xcin/pinyin.tab
|
||||
lib/X11/xcin/pinyin.tab.rev
|
||||
lib/X11/xcin/sample.phs.out
|
||||
lib/X11/xcin/tsa2d
|
||||
lib/X11/xcin/tsa2rel
|
||||
lib/X11/xcin/tsd2a
|
||||
lib/X11/xcin/tsin
|
||||
lib/X11/xcin/tsin.idx
|
||||
lib/X11/xcin/tsin.rel
|
||||
lib/X11/xcin/tsin.rel.src
|
||||
lib/X11/xcin/tsin.src
|
||||
lib/X11/xcin/tsin_pin.map
|
||||
lib/X11/xcin/voca.box
|
||||
lib/X11/xcin/zmdbosh.cin
|
||||
lib/X11/xcin/zmdbosh.tab
|
||||
lib/X11/xcin/zmdbosh.tab.rev
|
||||
lib/X11/xcin/zo.kbm
|
||||
lib/X11/xcin/docs/Boshiamy.HOWTO
|
||||
lib/X11/xcin/docs/README.xcin
|
||||
lib/X11/xcin/docs/XCIN.client.doc
|
||||
lib/X11/xcin/docs/Xfonts.HOWTO
|
||||
lib/X11/xcin/docs/cin2tab.HOWTO
|
||||
lib/X11/xcin/docs/xcin.HOWTO
|
||||
@dirrm lib/X11/xcin/docs
|
||||
@dirrm lib/X11/xcin
|
||||
bin/xcin2.5
|
||||
etc/xcinrc
|
||||
lib/X11/xcin25/bimsphone.so
|
||||
lib/X11/xcin25/gen_inp.so
|
||||
lib/X11/xcin25/zh_hex.so
|
||||
lib/X11/xcin25/bin/cin2tab
|
||||
lib/X11/xcin25/doc/Bugs
|
||||
lib/X11/xcin25/doc/COPYING
|
||||
lib/X11/xcin25/doc/CREDITS
|
||||
lib/X11/xcin25/doc/Changes
|
||||
lib/X11/xcin25/doc/Cin
|
||||
lib/X11/xcin25/doc/CopyRight
|
||||
lib/X11/xcin25/doc/FAQ
|
||||
lib/X11/xcin25/doc/README
|
||||
lib/X11/xcin25/doc/SETUP
|
||||
lib/X11/xcin25/doc/Todo
|
||||
lib/X11/xcin25/doc/Usage
|
||||
lib/X11/xcin25/doc/internal/IMdkit
|
||||
lib/X11/xcin25/doc/internal/gen_inp
|
||||
lib/X11/xcin25/doc/internal/module
|
||||
lib/X11/xcin25/doc/internal/structer
|
||||
lib/X11/xcin25/doc/modules/bimsphone
|
||||
lib/X11/xcin25/doc/modules/gen_inp
|
||||
lib/X11/xcin25/doc/modules/im_comm
|
||||
lib/X11/xcin25/doc/modules/zh_hex
|
||||
lib/X11/xcin25/tab/zh_TW.Big5/array30.cin
|
||||
lib/X11/xcin25/tab/zh_TW.Big5/array30.tab
|
||||
lib/X11/xcin25/tab/zh_TW.Big5/cantonese.cin
|
||||
lib/X11/xcin25/tab/zh_TW.Big5/cantonese.tab
|
||||
lib/X11/xcin25/tab/zh_TW.Big5/cj.cin
|
||||
lib/X11/xcin25/tab/zh_TW.Big5/cj.tab
|
||||
lib/X11/xcin25/tab/zh_TW.Big5/default.phr
|
||||
lib/X11/xcin25/tab/zh_TW.Big5/phone.cin
|
||||
lib/X11/xcin25/tab/zh_TW.Big5/phone.tab
|
||||
lib/X11/xcin25/tab/zh_TW.Big5/pinyin.cin
|
||||
lib/X11/xcin25/tab/zh_TW.Big5/pinyin.tab
|
||||
lib/X11/xcin25/tab/zh_TW.Big5/simplex.cin
|
||||
lib/X11/xcin25/tab/zh_TW.Big5/simplex.tab
|
||||
lib/X11/xcin25/tab/zh_TW.Big5/sys.cin
|
||||
lib/X11/xcin25/tab/zh_TW.Big5/sys.tab
|
||||
lib/X11/xcin25/tab/zh_CN.GB2312/default.phr
|
||||
lib/X11/xcin25/tab/zh_CN.GB2312/jtcj_gb.cin
|
||||
lib/X11/xcin25/tab/zh_CN.GB2312/jtcj_gb.tab
|
||||
lib/X11/xcin25/tab/zh_CN.GB2312/sys.cin
|
||||
lib/X11/xcin25/tab/zh_CN.GB2312/sys.tab
|
||||
lib/X11/xcin25/tab/zh_CN.GB2312/zhiranma.cin
|
||||
lib/X11/xcin25/tab/zh_CN.GB2312/zhiranma.tab
|
||||
share/locale/zh_TW.Big5/LC_MESSAGES/xcin.mo
|
||||
@dirrm lib/X11/xcin25/bin
|
||||
@dirrm lib/X11/xcin25/doc/internal
|
||||
@dirrm lib/X11/xcin25/doc/modules
|
||||
@dirrm lib/X11/xcin25/doc
|
||||
@dirrm lib/X11/xcin25/tab/zh_TW.Big5
|
||||
@dirrm lib/X11/xcin25/tab/zh_CN.GB2312
|
||||
@dirrm lib/X11/xcin25/tab
|
||||
@dirrm lib/X11/xcin25
|
||||
|
Loading…
Reference in New Issue
Block a user