MFH: r535550
databases/mariadb102-server: Security update to 10.2.32 Security: 21d59ea3-8559-11ea-a5e2-d4c9ef517024 Approved by: ports-secteam (joneum)
This commit is contained in:
parent
4d2f56007e
commit
b20b151859
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q2/; revision=535554
@ -1,6 +1,6 @@
|
||||
--- support-files/CMakeLists.txt.orig 2018-06-25 11:13:30 UTC
|
||||
--- support-files/CMakeLists.txt.orig 2020-05-08 11:45:27 UTC
|
||||
+++ support-files/CMakeLists.txt
|
||||
@@ -57,6 +59,7 @@ ENDIF()
|
||||
@@ -59,6 +59,7 @@ ENDIF()
|
||||
|
||||
IF(UNIX)
|
||||
SET(prefix ${CMAKE_INSTALL_PREFIX})
|
||||
@ -8,23 +8,22 @@
|
||||
FOREACH(script mysqld_multi.server mysql-log-rotate binary-configure wsrep_notify)
|
||||
CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/${script}.sh
|
||||
${CMAKE_CURRENT_BINARY_DIR}/${script} @ONLY )
|
||||
@@ -86,12 +89,14 @@ IF(UNIX)
|
||||
ENDFOREACH()
|
||||
@@ -98,12 +99,14 @@ IF(UNIX)
|
||||
ENDIF()
|
||||
ENDIF()
|
||||
ENDIF()
|
||||
+ ENDIF()
|
||||
|
||||
CONFIGURE_FILE(mariadb.pc.in ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc @ONLY)
|
||||
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_SHAREDIR}/pkgconfig COMPONENT Development)
|
||||
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mariadb.pc DESTINATION ${INSTALL_LIBDIR}/pkgconfig COMPONENT Development)
|
||||
|
||||
INSTALL(FILES mysql.m4 DESTINATION ${INSTALL_SHAREDIR}/aclocal COMPONENT Development)
|
||||
-
|
||||
+
|
||||
+IF(NOT WITHOUT_SERVER)
|
||||
|
||||
+ IF(NOT WITHOUT_SERVER)
|
||||
SET(bindir ${INSTALL_BINDIRABS})
|
||||
SET(sbindir ${INSTALL_SBINDIRABS})
|
||||
SET(scriptdir ${INSTALL_SCRIPTDIRABS})
|
||||
@@ -158,6 +163,7 @@ IF(UNIX)
|
||||
@@ -175,6 +178,7 @@ IF(UNIX)
|
||||
INSTALL(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/mysql.server
|
||||
DESTINATION ${INSTALL_SYSCONFDIR}/init.d
|
||||
RENAME mysql COMPONENT SupportFiles)
|
||||
|
@ -49,6 +49,7 @@ lib/mysql/plugin/dialog.so
|
||||
lib/mysql/plugin/mysql_clear_password.so
|
||||
lib/mysql/plugin/sha256_password.so
|
||||
libdata/pkgconfig/libmariadb.pc
|
||||
libdata/pkgconfig/mariadb.pc
|
||||
%%DATADIR%%/charsets/Index.xml
|
||||
%%DATADIR%%/charsets/README
|
||||
%%DATADIR%%/charsets/armscii8.xml
|
||||
|
@ -1,7 +1,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME?= mariadb
|
||||
PORTVERSION= 10.2.31
|
||||
PORTVERSION= 10.2.32
|
||||
PORTREVISION?= 0
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= http://mirrors.supportex.net/${SITESDIR}/ \
|
||||
@ -204,11 +204,13 @@ post-install:
|
||||
${RM} ${STAGEDIR}${PREFIX}/share/aclocal/mysql.m4 \
|
||||
${STAGEDIR}${PREFIX}/man/man1/aria* \
|
||||
${STAGEDIR}${PREFIX}/man/man1/myisam*
|
||||
${RM} -r ${STAGEDIR}${PREFIX}/share/pkgconfig \
|
||||
${STAGEDIR}${DATADIR}/policy \
|
||||
${RM} -r ${STAGEDIR}${DATADIR}/policy \
|
||||
${STAGEDIR}${PREFIX}/include/mysql/server
|
||||
# Fix https://mariadb.atlassian.net/browse/MDEV-9388
|
||||
@${REINPLACE_CMD} 's/-l-pthread/-pthread/' ${STAGEDIR}${PREFIX}/bin/mysql_config
|
||||
${MV} ${STAGEDIR}${PREFIX}/lib/mysql/pkgconfig/mariadb.pc \
|
||||
${STAGEDIR}${PREFIX}/libdata/pkgconfig
|
||||
${RM} -r ${STAGEDIR}${PREFIX}/lib/mysql/pkgconfig
|
||||
|
||||
post-install-GSSAPI_NONE-off:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/mysql/plugin/auth_gssapi_client.so
|
||||
@ -234,6 +236,7 @@ post-install:
|
||||
${STAGEDIR}${LOCALBASE}/storage/groonga/COPYING \
|
||||
${STAGEDIR}${LOCALBASE}/share/mysql/mroonga/COPYING
|
||||
${RM} ${STAGEDIR}${PREFIX}/include/mysql/*.h
|
||||
${RM} -r ${STAGEDIR}${PREFIX}/lib/mysql/pkgconfig
|
||||
|
||||
.endif # targets for -server
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1580332681
|
||||
SHA256 (mariadb-10.2.31.tar.gz) = 321f744c322ecbc06feddd290d5ee0bf7c68e92cb61fd93c9450eb9c05683151
|
||||
SIZE (mariadb-10.2.31.tar.gz) = 73134720
|
||||
TIMESTAMP = 1589719385
|
||||
SHA256 (mariadb-10.2.32.tar.gz) = ea4fb28095e1079297eb3ba7ec5e215c641f2dff37964db778f6e9c37e0189b3
|
||||
SIZE (mariadb-10.2.32.tar.gz) = 73646729
|
||||
|
@ -1,14 +0,0 @@
|
||||
--- plugin/auth_pam/mapper/pam_user_map.c.orig 2020-01-26 20:43:53 UTC
|
||||
+++ plugin/auth_pam/mapper/pam_user_map.c
|
||||
@@ -39,7 +39,11 @@ and usually end up in /var/log/secure file.
|
||||
#include <grp.h>
|
||||
#include <pwd.h>
|
||||
|
||||
+#ifdef __FreeBSD__
|
||||
+#include <security/pam_appl.h>
|
||||
+#else
|
||||
#include <security/pam_ext.h>
|
||||
+#endif
|
||||
#include <security/pam_modules.h>
|
||||
|
||||
#define FILENAME "/etc/security/user_map.conf"
|
@ -126,7 +126,6 @@ man/man1/mysqld_safe.1.gz
|
||||
man/man1/mysqld_safe_helper.1.gz
|
||||
man/man1/mysqldumpslow.1.gz
|
||||
man/man1/mysqlhotcopy.1.gz
|
||||
man/man1/mysqltest.1.gz
|
||||
man/man1/perror.1.gz
|
||||
man/man1/replace.1.gz
|
||||
man/man1/resolve_stack_dump.1.gz
|
||||
@ -193,6 +192,8 @@ man/man8/mysqld.8.gz
|
||||
%%DATADIR%%/wsrep_notify
|
||||
%%MROONGA%%share/groonga-normalizer-mysql/README.md
|
||||
%%MROONGA%%share/groonga/README.md
|
||||
share/pam_user_map.so
|
||||
share/user_map.conf
|
||||
@comment bin/mariadb_config
|
||||
@comment bin/mysql
|
||||
@comment bin/mysqladmin
|
||||
|
Loading…
Reference in New Issue
Block a user