- Unbreak it on FreeBSD >= 6.x

PR:		ports/85088
Submitted by:	Johan van Selst <johans@stack.nl>
Approved by:	portmgr (linimon)
This commit is contained in:
Renato Botelho 2005-08-22 16:19:30 +00:00
parent 020a46efec
commit b1f4290786
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=140954
3 changed files with 26 additions and 10 deletions

View File

@ -21,14 +21,6 @@ CONFIGURE_ARGS= --enable-tests=no --enable-maintainer=no --enable-pthread \
--disable-kernel-patch
USE_GMAKE= yes
.include <bsd.port.pre.mk>
ONLY_FOR_ARCHS= amd64 i386
.if ${ARCH} != "i386" && ${ARCH} != "amd64"
BROKEN= "Does not compile on !i386 and !amd64"
.endif
.if ${OSVERSION} >= 600031
BROKEN= "Does not compile on FreeBSD >= 6.0"
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -0,0 +1,10 @@
--- pthread.h.in.orig Thu Aug 18 13:49:14 2005
+++ pthread.h.in Thu Aug 18 13:49:07 2005
@@ -50,6 +50,7 @@
#define _SYS_PTHREAD_H_
#define SYS_PTHREAD_INCLUDED
#define _SYS_PTHREAD_INCLUDED
+#define _SYS__PTHREADTYPES_H_
#ifdef _PTHREAD_PRIVATE
#define BITS_PTHREADTYPES_H
#define _BITS_PTHREADTYPES_H

View File

@ -0,0 +1,14 @@
--- uthread_spinlock.c.orig Thu Aug 18 13:45:38 2005
+++ uthread_spinlock.c Thu Aug 18 13:44:36 2005
@@ -33,10 +33,10 @@
*
*/
+#include <pthread.h>
#include <stdio.h>
#include <sched.h>
#include <unistd.h>
-#include <pthread.h>
#include <string.h>
#include "spinlock.h"