Add a patch to nautilus to fix the freeze problem when thumbnailing certain

images.  FreeBSD has a 64K default thread stack size, and this is too small
for eel's gdk extensions.  This patch simply doubles the thumbnailing
thread size to 128K.
This commit is contained in:
Joe Marcus Clarke 2002-07-09 23:17:40 +00:00
parent 63affb72a9
commit b181342166
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=62733
2 changed files with 18 additions and 6 deletions

View File

@ -7,6 +7,7 @@
PORTNAME= nautilus2
PORTVERSION= 2.0.0
PORTREVISION= 1
CATEGORIES= x11-fm gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= 2.0.0/releases/gnome-2.0-desktop-final
@ -25,6 +26,7 @@ USE_GMAKE= yes
USE_X_PREFIX= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -fno-rtti -fno-exceptions" \
LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib -L${X11BASE}/lib -liconv" \
LIBPNG="-L${LOCALBASE}/lib -lpng -lz ${MOZILLA_LIBS}"
@ -34,12 +36,12 @@ CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
--with-freetype2-include-place=${LOCALBASE}/include/freetype2
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
s|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g ; \
s|\$\(libdir\)/bonobo/servers|\$\(prefix\)/libdata/bonobo/servers|g'
@find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
's|[(]datadir[)]/gnome/|(datadir)/|g ; \
s|[(]datadir[)]/locale|(prefix)/share/locale|g ; \
s|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g ; \
s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g'
.include <bsd.port.mk>

View File

@ -0,0 +1,10 @@
--- libnautilus-private/nautilus-thumbnails.c.orig Tue Jul 9 19:09:29 2002
+++ libnautilus-private/nautilus-thumbnails.c Tue Jul 9 19:09:19 2002
@@ -309,6 +309,7 @@
pthread_attr_init (&thread_attributes);
pthread_attr_setdetachstate (&thread_attributes,
PTHREAD_CREATE_DETACHED);
+ pthread_attr_setstacksize (&thread_attributes, 128*1024);
#ifdef DEBUG_THUMBNAILS
g_message ("(Main Thread) Creating thumbnails thread\n");
#endif