Update to 1.5.

This commit is contained in:
David Thiel 2009-02-10 16:36:55 +00:00
parent 602a05df80
commit b125f259b2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=228001
4 changed files with 74 additions and 82 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= medusa
PORTVERSION= 1.4
PORTVERSION= 1.5
CATEGORIES= security
MASTER_SITES= http://www.foofus.net/jmk/tools/ \
http://redundancy.redundancy.org/mirror/
@ -15,14 +15,12 @@ MAINTAINER= lx@FreeBSD.org
COMMENT= A speedy, massively parallel, modular, login brute-forcer
OPTIONS= SVN "Enable Subversion module" off \
POSTGRESQL "Enable PostgreSQL module" off \
WEBFORM "Enable web form module" off \
SMTPAUTH "Enable web form module" off
POSTGRESQL "Enable PostgreSQL module" off
LIB_DEPENDS+= ssh2:${PORTSDIR}/security/libssh2
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --program-transform= --disable-module-ncp
CONFIGURE_ARGS+= --program-transform= #--disable-module-ncp
MAN1= medusa.1
@ -46,21 +44,12 @@ PLIST_SUB+= POSTGRESQL=""
USE_PGSQL= yes
CONFIGURE_ARGS+= --enable-module-postgres
.else
CONFIGURE_ARGS+= --enable-module-postgres=no
PLIST_SUB+= POSTGRESQL="@comment "
.endif
.if defined(WITH_WEBFORM)
PLIST_SUB+= WEBFORM=""
CONFIGURE_ARGS+= --enable-module-web-form
.else
PLIST_SUB+= WEBFORM="@comment "
.endif
.if defined(WITH_SMTPAUTH)
PLIST_SUB+= SMTPAUTH=""
CONFIGURE_ARGS+= --enable-module-smtp-auth
.else
PLIST_SUB+= SMTPAUTH="@comment "
.endif
post-install:
${MKDIR} ${PREFIX}/share/zsh/site-functions
${INSTALL_DATA} ${WRKSRC}/misc/zsh/_medusa ${PREFIX}/share/zsh/site-functions/_medusa
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (medusa-1.4.tar.gz) = aad236c87aaadbdc9162b6658c2118e6
SHA256 (medusa-1.4.tar.gz) = 08af3917c8c53741627362ce3831f808bd8e9598b631e74cf49ec7c912adb237
SIZE (medusa-1.4.tar.gz) = 306232
MD5 (medusa-1.5.tar.gz) = 11e04f6ac4bf559d5a0c6861a1cb8604
SHA256 (medusa-1.5.tar.gz) = ae2a3cd406fedd618ecfc696a67e7239e496917e745eac639b29306d1c58a644
SIZE (medusa-1.5.tar.gz) = 346761

View File

@ -1,28 +1,28 @@
--- configure.old 2007-12-11 11:53:36.000000000 -0800
+++ configure 2007-12-11 11:54:16.000000000 -0800
@@ -5794,8 +5794,8 @@
--- configure.orig 2009-02-10 08:05:24.000000000 -0800
+++ configure 2009-02-10 08:06:05.000000000 -0800
@@ -7702,8 +7702,8 @@
else
if test "${ac_cv_header_apr_1_0_apr_tables_h+set}" = set; then
- { echo "$as_me:$LINENO: checking for apr-1.0/apr_tables.h" >&5
-echo $ECHO_N "checking for apr-1.0/apr_tables.h... $ECHO_C" >&6; }
+ { echo "$as_me:$LINENO: checking for apr-1/apr_tables.h" >&5
+echo $ECHO_N "checking for apr-1/apr_tables.h... $ECHO_C" >&6; }
- { $as_echo "$as_me:$LINENO: checking for apr-1.0/apr_tables.h" >&5
-$as_echo_n "checking for apr-1.0/apr_tables.h... " >&6; }
+ { $as_echo "$as_me:$LINENO: checking for apr-1/apr_tables.h" >&5
+$as_echo_n "checking for apr-1/apr_tables.h... " >&6; }
if test "${ac_cv_header_apr_1_0_apr_tables_h+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
$as_echo_n "(cached) " >&6
fi
@@ -5803,8 +5803,8 @@
echo "${ECHO_T}$ac_cv_header_apr_1_0_apr_tables_h" >&6; }
@@ -7711,8 +7711,8 @@
$as_echo "$ac_cv_header_apr_1_0_apr_tables_h" >&6; }
else
# Is the header compilable?
-{ echo "$as_me:$LINENO: checking apr-1.0/apr_tables.h usability" >&5
-echo $ECHO_N "checking apr-1.0/apr_tables.h usability... $ECHO_C" >&6; }
+{ echo "$as_me:$LINENO: checking apr-1/apr_tables.h usability" >&5
+echo $ECHO_N "checking apr-1/apr_tables.h usability... $ECHO_C" >&6; }
-{ $as_echo "$as_me:$LINENO: checking apr-1.0/apr_tables.h usability" >&5
-$as_echo_n "checking apr-1.0/apr_tables.h usability... " >&6; }
+{ $as_echo "$as_me:$LINENO: checking apr-1/apr_tables.h usability" >&5
+$as_echo_n "checking apr-1/apr_tables.h usability... " >&6; }
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -5812,7 +5812,7 @@
@@ -7720,7 +7720,7 @@
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
$ac_includes_default
@ -31,14 +31,14 @@
_ACEOF
rm -f conftest.$ac_objext
if { (ac_try="$ac_compile"
@@ -5844,15 +5844,15 @@
echo "${ECHO_T}$ac_header_compiler" >&6; }
@@ -7753,15 +7753,15 @@
$as_echo "$ac_header_compiler" >&6; }
# Is the header present?
-{ echo "$as_me:$LINENO: checking apr-1.0/apr_tables.h presence" >&5
-echo $ECHO_N "checking apr-1.0/apr_tables.h presence... $ECHO_C" >&6; }
+{ echo "$as_me:$LINENO: checking apr-1/apr_tables.h presence" >&5
+echo $ECHO_N "checking apr-1/apr_tables.h presence... $ECHO_C" >&6; }
-{ $as_echo "$as_me:$LINENO: checking apr-1.0/apr_tables.h presence" >&5
-$as_echo_n "checking apr-1.0/apr_tables.h presence... " >&6; }
+{ $as_echo "$as_me:$LINENO: checking apr-1/apr_tables.h presence" >&5
+$as_echo_n "checking apr-1/apr_tables.h presence... " >&6; }
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@ -50,52 +50,52 @@
_ACEOF
if { (ac_try="$ac_cpp conftest.$ac_ext"
case "(($ac_try" in
@@ -5885,30 +5885,30 @@
@@ -7795,30 +7795,30 @@
# So? What about this header?
case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
yes:no: )
- { echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: accepted by the compiler, rejected by the preprocessor!" >&5
-echo "$as_me: WARNING: apr-1.0/apr_tables.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
- { echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: proceeding with the compiler's result" >&5
-echo "$as_me: WARNING: apr-1.0/apr_tables.h: proceeding with the compiler's result" >&2;}
+ { echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: accepted by the compiler, rejected by the preprocessor!" >&5
+echo "$as_me: WARNING: apr-1/apr_tables.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
+ { echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: proceeding with the compiler's result" >&5
+echo "$as_me: WARNING: apr-1/apr_tables.h: proceeding with the compiler's result" >&2;}
- { $as_echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: accepted by the compiler, rejected by the preprocessor!" >&5
-$as_echo "$as_me: WARNING: apr-1.0/apr_tables.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
- { $as_echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: proceeding with the compiler's result" >&5
-$as_echo "$as_me: WARNING: apr-1.0/apr_tables.h: proceeding with the compiler's result" >&2;}
+ { $as_echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: accepted by the compiler, rejected by the preprocessor!" >&5
+$as_echo "$as_me: WARNING: apr-1/apr_tables.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
+ { $as_echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: proceeding with the compiler's result" >&5
+$as_echo "$as_me: WARNING: apr-1/apr_tables.h: proceeding with the compiler's result" >&2;}
ac_header_preproc=yes
;;
no:yes:* )
- { echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: present but cannot be compiled" >&5
-echo "$as_me: WARNING: apr-1.0/apr_tables.h: present but cannot be compiled" >&2;}
- { echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: check for missing prerequisite headers?" >&5
-echo "$as_me: WARNING: apr-1.0/apr_tables.h: check for missing prerequisite headers?" >&2;}
- { echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: see the Autoconf documentation" >&5
-echo "$as_me: WARNING: apr-1.0/apr_tables.h: see the Autoconf documentation" >&2;}
- { echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: section \"Present But Cannot Be Compiled\"" >&5
-echo "$as_me: WARNING: apr-1.0/apr_tables.h: section \"Present But Cannot Be Compiled\"" >&2;}
- { echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: proceeding with the preprocessor's result" >&5
-echo "$as_me: WARNING: apr-1.0/apr_tables.h: proceeding with the preprocessor's result" >&2;}
- { echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: in the future, the compiler will take precedence" >&5
-echo "$as_me: WARNING: apr-1.0/apr_tables.h: in the future, the compiler will take precedence" >&2;}
+ { echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: present but cannot be compiled" >&5
+echo "$as_me: WARNING: apr-1/apr_tables.h: present but cannot be compiled" >&2;}
+ { echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: check for missing prerequisite headers?" >&5
+echo "$as_me: WARNING: apr-1/apr_tables.h: check for missing prerequisite headers?" >&2;}
+ { echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: see the Autoconf documentation" >&5
+echo "$as_me: WARNING: apr-1/apr_tables.h: see the Autoconf documentation" >&2;}
+ { echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: section \"Present But Cannot Be Compiled\"" >&5
+echo "$as_me: WARNING: apr-1/apr_tables.h: section \"Present But Cannot Be Compiled\"" >&2;}
+ { echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: proceeding with the preprocessor's result" >&5
+echo "$as_me: WARNING: apr-1/apr_tables.h: proceeding with the preprocessor's result" >&2;}
+ { echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: in the future, the compiler will take precedence" >&5
+echo "$as_me: WARNING: apr-1/apr_tables.h: in the future, the compiler will take precedence" >&2;}
- { $as_echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: present but cannot be compiled" >&5
-$as_echo "$as_me: WARNING: apr-1.0/apr_tables.h: present but cannot be compiled" >&2;}
- { $as_echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: check for missing prerequisite headers?" >&5
-$as_echo "$as_me: WARNING: apr-1.0/apr_tables.h: check for missing prerequisite headers?" >&2;}
- { $as_echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: see the Autoconf documentation" >&5
-$as_echo "$as_me: WARNING: apr-1.0/apr_tables.h: see the Autoconf documentation" >&2;}
- { $as_echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: section \"Present But Cannot Be Compiled\"" >&5
-$as_echo "$as_me: WARNING: apr-1.0/apr_tables.h: section \"Present But Cannot Be Compiled\"" >&2;}
- { $as_echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: proceeding with the preprocessor's result" >&5
-$as_echo "$as_me: WARNING: apr-1.0/apr_tables.h: proceeding with the preprocessor's result" >&2;}
- { $as_echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: in the future, the compiler will take precedence" >&5
-$as_echo "$as_me: WARNING: apr-1.0/apr_tables.h: in the future, the compiler will take precedence" >&2;}
+ { $as_echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: present but cannot be compiled" >&5
+$as_echo "$as_me: WARNING: apr-1/apr_tables.h: present but cannot be compiled" >&2;}
+ { $as_echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: check for missing prerequisite headers?" >&5
+$as_echo "$as_me: WARNING: apr-1/apr_tables.h: check for missing prerequisite headers?" >&2;}
+ { $as_echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: see the Autoconf documentation" >&5
+$as_echo "$as_me: WARNING: apr-1/apr_tables.h: see the Autoconf documentation" >&2;}
+ { $as_echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: section \"Present But Cannot Be Compiled\"" >&5
+$as_echo "$as_me: WARNING: apr-1/apr_tables.h: section \"Present But Cannot Be Compiled\"" >&2;}
+ { $as_echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: proceeding with the preprocessor's result" >&5
+$as_echo "$as_me: WARNING: apr-1/apr_tables.h: proceeding with the preprocessor's result" >&2;}
+ { $as_echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: in the future, the compiler will take precedence" >&5
+$as_echo "$as_me: WARNING: apr-1/apr_tables.h: in the future, the compiler will take precedence" >&2;}
;;
esac
-{ echo "$as_me:$LINENO: checking for apr-1.0/apr_tables.h" >&5
-echo $ECHO_N "checking for apr-1.0/apr_tables.h... $ECHO_C" >&6; }
+{ echo "$as_me:$LINENO: checking for apr-1/apr_tables.h" >&5
+echo $ECHO_N "checking for apr-1/apr_tables.h... $ECHO_C" >&6; }
-{ $as_echo "$as_me:$LINENO: checking for apr-1.0/apr_tables.h" >&5
-$as_echo_n "checking for apr-1.0/apr_tables.h... " >&6; }
+{ $as_echo "$as_me:$LINENO: checking for apr-1/apr_tables.h" >&5
+$as_echo_n "checking for apr-1/apr_tables.h... " >&6; }
if test "${ac_cv_header_apr_1_0_apr_tables_h+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
$as_echo_n "(cached) " >&6
else

View File

@ -21,8 +21,11 @@ lib/medusa/modules/cvs.mod
lib/medusa/modules/vmauthd.mod
lib/medusa/modules/snmp.mod
lib/medusa/modules/smtp-vrfy.mod
%%SMTPAUTH%%lib/medusa/modules/smtp-auth.mod
lib/medusa/modules/smtp.mod
%%SVN%%lib/medusa/modules/svn.mod
%%WEBFORM%%lib/medusa/modules/web-form.mod
lib/medusa/modules/web-form.mod
share/zsh/site-functions/_medusa
@unexec [ -f %D/bin/zsh ] || rmdir %D/share/zsh/site-functions 2>/dev/null || true
@dirrmtry share/zsh
@dirrm lib/medusa/modules
@dirrm lib/medusa