Add opencdk, Open Crypto Development Kit, libary for basic parts of the OpenPGP message format
PR: 47103 Submitted by: Sergei Kolobov <sergei@kolobov.com>
This commit is contained in:
parent
5d967273f5
commit
b0e449e1f9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=73428
@ -139,6 +139,7 @@
|
||||
SUBDIR += ocaml-cryptokit
|
||||
SUBDIR += oidentd
|
||||
SUBDIR += op
|
||||
SUBDIR += opencdk
|
||||
SUBDIR += opensc
|
||||
SUBDIR += openssh
|
||||
SUBDIR += openssh-askpass
|
||||
|
42
security/opencdk/Makefile
Normal file
42
security/opencdk/Makefile
Normal file
@ -0,0 +1,42 @@
|
||||
# New ports collection makefile for: opencdk
|
||||
# Date created: 15 Jan 2003
|
||||
# Whom: Sergei Kolobov <sergei@kolobov.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= opencdk
|
||||
PORTVERSION= 0.4.1
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= http://gd.tuwien.ac.at/privacy/gnupg/alpha/gnutls/opencdk/ \
|
||||
ftp://ftp.gnutls.org/pub/gnutls/opencdk/ \
|
||||
ftp://ftp.gnupg.org/pub/gcrypt/alpha/gnutls/opencdk/ \
|
||||
http://www.mirrors.wiretapped.net/security/network-security/gnutls/opencdk/ \
|
||||
ftp://ftp.mirrors.wiretapped.net/security/network-security/gnutls/opencdk/
|
||||
|
||||
MAINTAINER= sergei@kolobov.com
|
||||
|
||||
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
|
||||
gcrypt.6:${PORTSDIR}/security/libgcrypt
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
|
||||
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lgnugetopt"
|
||||
|
||||
DOCS= AUTHORS NEWS README THANKS
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/tests/*.c ${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/tests/*.gpg ${EXAMPLESDIR}
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
.for file in ${DOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
|
||||
.endfor
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/opencdk-api.html ${DOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
security/opencdk/distinfo
Normal file
1
security/opencdk/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (opencdk-0.4.1.tar.gz) = 428f93034dbdbded596746c9656e270b
|
10
security/opencdk/files/patch-src::keyserver.c
Normal file
10
security/opencdk/files/patch-src::keyserver.c
Normal file
@ -0,0 +1,10 @@
|
||||
--- src/keyserver.c.orig Wed Jan 15 16:52:09 2003
|
||||
+++ src/keyserver.c Wed Jan 15 16:52:34 2003
|
||||
@@ -24,6 +24,7 @@
|
||||
#endif
|
||||
#include <stdio.h>
|
||||
#ifdef HAVE_NETDB_H
|
||||
+# include <sys/types.h>
|
||||
# include <sys/socket.h>
|
||||
# include <netinet/in.h>
|
||||
# include <arpa/inet.h>
|
1
security/opencdk/pkg-comment
Normal file
1
security/opencdk/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Open Crypto Development Kit
|
15
security/opencdk/pkg-descr
Normal file
15
security/opencdk/pkg-descr
Normal file
@ -0,0 +1,15 @@
|
||||
OpenCDK - Open Crypto Development Kit
|
||||
|
||||
This library provides basic parts of the OpenPGP message format.
|
||||
The aim of the library is *not* to replace any available OpenPGP version.
|
||||
There will be no real support for key management (sign, revoke,
|
||||
alter preferences, ...) and some other parts are only rudimentary
|
||||
available. The main purpose is to handle and understand OpenPGP
|
||||
packets and to use basic operations. For example to encrypt/decrypt
|
||||
or to sign/verify and packet routines.
|
||||
|
||||
Hint: Because of the fact that sentensive data is used, the library
|
||||
doesn't contain any real cryptographic code. For all crypto
|
||||
routines we referring to the Libgcrypt library!
|
||||
|
||||
WWW: http://www.gnutls.org/
|
20
security/opencdk/pkg-plist
Normal file
20
security/opencdk/pkg-plist
Normal file
@ -0,0 +1,20 @@
|
||||
bin/opencdk-config
|
||||
include/opencdk.h
|
||||
lib/libopencdk.so.5
|
||||
lib/libopencdk.so
|
||||
lib/libopencdk.la
|
||||
lib/libopencdk.a
|
||||
%%PORTDOCS%%share/doc/opencdk/AUTHORS
|
||||
%%PORTDOCS%%share/doc/opencdk/NEWS
|
||||
%%PORTDOCS%%share/doc/opencdk/README
|
||||
%%PORTDOCS%%share/doc/opencdk/THANKS
|
||||
%%PORTDOCS%%share/doc/opencdk/opencdk-api.html
|
||||
%%PORTDOCS%%@dirrm share/doc/opencdk
|
||||
share/examples/opencdk/minpg.c
|
||||
share/examples/opencdk/pub.gpg
|
||||
share/examples/opencdk/sec-with-pwd.gpg
|
||||
share/examples/opencdk/sec.gpg
|
||||
share/examples/opencdk/t-stream.c
|
||||
share/examples/opencdk/ts.gpg
|
||||
share/examples/opencdk/wkold.gpg
|
||||
@dirrm share/examples/opencdk
|
Loading…
Reference in New Issue
Block a user