add ocaml-sdl 0.6.3

An OCaml interface to the SDL
This commit is contained in:
Ying-Chieh Liao 2004-06-01 02:04:41 +00:00
parent b1f3b29cbd
commit b0b9916623
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=110571
5 changed files with 93 additions and 0 deletions

View File

@ -533,6 +533,7 @@
SUBDIR += ocaml-classes
SUBDIR += ocaml-findlib
SUBDIR += ocaml-pcre
SUBDIR += ocaml-sdl
SUBDIR += ocaml-ulex
SUBDIR += ocamlweb
SUBDIR += ode

52
devel/ocaml-sdl/Makefile Normal file
View File

@ -0,0 +1,52 @@
# ex:ts=8
# Ports collection makefile for: ocaml-sdl
# Date created: Jun 1, 2004
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= sdl
PORTVERSION= 0.6.3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ocamlsdl
PKGNAMEPREFIX= ocaml-
DISTNAME= ocamlsdl-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= An OCaml interface to the SDL
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib \
lablgl:${PORTSDIR}/graphics/ocaml-lablgl
USE_BZIP2= yes
USE_SDL= sdl ttf image mixer
GNU_CONFIGURE= yes
USE_GMAKE= yes
.if !defined(NOPORTDOCS)
PORTDOCS= *
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
.endif
post-install:
@${FIND} ${PREFIX}/lib/ocaml/sdl ! -type d | \
${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
@${ECHO_CMD} "@dirrm lib/ocaml/sdl" >> ${TMPPLIST}
@${FIND} ${PREFIX}/lib/ocaml/stublibs -name "dllsdl*.so" | \
${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${CP} -R ${WRKSRC}/doc/html/ ${DOCSDIR}
@${MKDIR} ${EXAMPLESDIR}
${CP} -R ${WRKSRC}/samples/ ${EXAMPLESDIR}
@${FIND} ${EXAMPLESDIR} ! -type d | \
${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
@${ECHO_CMD} "@dirrm ${EXAMPLESDIR:S,^${PREFIX}/,,}" >> ${TMPPLIST}
.endif
.include <bsd.port.mk>

2
devel/ocaml-sdl/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (ocamlsdl-0.6.3.tar.bz2) = 9e99ba5675b2d113ce2e3e139c2c8dc3
SIZE (ocamlsdl-0.6.3.tar.bz2) = 335489

View File

@ -0,0 +1,35 @@
--- configure.orig Tue Jun 1 09:27:55 2004
+++ configure Tue Jun 1 09:28:03 2004
@@ -2652,19 +2652,19 @@
fi;
echo "$as_me:$LINENO: checking lablGL directory" >&5
echo $ECHO_N "checking lablGL directory... $ECHO_C" >&6
-TMPF=conftest.ml
-cat > $TMPF << EOF
-open Gl
-EOF
-_LABLGLDIR=$LABLGLDIR
-unset LABLGLDIR
-for dir in $_LABLGLDIR +lablGL ; do
- if $OCAMLC -c -I $dir $TMPF >& /dev/null ; then
- LABLGLDIR="$dir"
- break
- fi
-done
-rm -f $TMPF
+#TMPF=conftest.ml
+#cat > $TMPF << EOF
+#open Gl
+#EOF
+#_LABLGLDIR=$LABLGLDIR
+#unset LABLGLDIR
+#for dir in $_LABLGLDIR +lablGL ; do
+# if $OCAMLC -c -I $dir $TMPF >& /dev/null ; then
+# LABLGLDIR="$dir"
+# break
+# fi
+#done
+#rm -f $TMPF
if test -n $LABLGLDIR ; then
echo "$as_me:$LINENO: result: $LABLGLDIR" >&5
echo "${ECHO_T}$LABLGLDIR" >&6

View File

@ -0,0 +1,3 @@
OCamlSDL is an OCaml interface to the SDL (Simple DirectMedia Layer) library.
WWW: http://ocamlsdl.sourceforge.net/