- Update 18.2.10
- Add CEPHFS, GFAPI and RADOS options - Add PERL5 like a run dependency
This commit is contained in:
parent
349da7e678
commit
b0aef401c6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=558146
@ -15,7 +15,13 @@ USE_RC_SUBR= bareos-fd
|
||||
PLIST= ${PKGDIR}/pkg-plist.client
|
||||
MASTERDIR= ${.CURDIR}/../../sysutils/bareos18-server
|
||||
|
||||
OPTIONS_GROUP= PLUGINS
|
||||
OPTIONS_GROUP_PLUGINS= CEPHFS GFAPI RADOS
|
||||
OPTIONS_DEFINE= NLS PYTHON LMDB SCSICRYPTO
|
||||
|
||||
CEPHFS_DESC= CEPHFS fd plugin support
|
||||
GFAPI_DESC= GFAPI fd plugin support
|
||||
RADOS_DESC= RADOS fd plugin support
|
||||
LMDB_DESC= Enable build of LMDB support
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= bareos
|
||||
DISTVERSIONPREFIX= Release/
|
||||
DISTVERSION= 18.2.8
|
||||
DISTVERSION= 18.2.10
|
||||
PORTREVISION?= 0
|
||||
CATEGORIES?= sysutils
|
||||
PKGNAMEPREFIX?= #
|
||||
@ -19,9 +19,10 @@ CONFLICTS?= bacula17*-server-* bareos16-server-* bareos-server-*
|
||||
LIB_DEPENDS+= liblzo2.so:archivers/lzo2 \
|
||||
libjansson.so:devel/jansson
|
||||
|
||||
USES+= cmake:insource compiler:c++11-lang pkgconfig readline:port \
|
||||
shebangfix
|
||||
USES+= cmake:insource compiler:c++11-lang localbase perl5 pkgconfig \
|
||||
readline:port shebangfix
|
||||
USE_GITHUB= yes
|
||||
USE_PERL5= run
|
||||
|
||||
USERS= bareos
|
||||
GROUPS= ${USERS}
|
||||
@ -45,11 +46,16 @@ NDMP_DESC= Enable build of NDMP support
|
||||
SCSICRYPTO_DESC= Build LTO AME crypto plugin
|
||||
|
||||
.if ${PKGNAMESUFFIX} == "18-server"
|
||||
OPTIONS_GROUP= BACKENDS
|
||||
OPTIONS_GROUP_BACKENDS= CEPHFS GFAPI RADOS
|
||||
OPTIONS_DEFINE= MTX PYTHON NDMP NLS SCSICRYPTO
|
||||
OPTIONS_DEFAULT+= PGSQL SCSICRYPTO
|
||||
OPTIONS_SINGLE_DATABASE= SQLITE3 MYSQL PGSQL
|
||||
OPTIONS_SINGLE+= DATABASE
|
||||
DATABASE_DESC= Database support
|
||||
CEPHFS_DESC= CEPHFS backend support
|
||||
GFAPI_DESC= GFAPI backend support
|
||||
RADOS_DESC= RADOS backend support
|
||||
|
||||
NDMP_CMAKE_ON= -Dndmp=ON
|
||||
NDMP_CMAKE_OFF= -Dndmp=OFF
|
||||
@ -83,7 +89,7 @@ SUB_FILES+= pkg-message.server
|
||||
.endif
|
||||
|
||||
CMAKE_ARGS+= -Dtcp-wrappers=ON \
|
||||
-Dsmartalloc=ON \
|
||||
-Dsmartalloc=OFF \
|
||||
-Dsysconfdir=${PREFIX}/etc \
|
||||
-Darchivedir=${BAREOS_DIR}/storage \
|
||||
-Dworkingdir=${BAREOS_DIR} \
|
||||
@ -140,6 +146,12 @@ SUB_LIST= BAREOS_USER=${BAREOS_USER} \
|
||||
|
||||
NLS_USES= gettext
|
||||
NLS_CMAKE_ON= -Dnls=ON
|
||||
CEPHFS_CMAKE_ON= -Dcephfs=ON
|
||||
CEPHFS_LIB_DEPENDS= libcephfs.so:net/ceph14
|
||||
GFAPI_CMAKE_ON= -Dgfapi=ON
|
||||
GFAPI_LIB_DEPENDS= libglusterfs.so:net/glusterfs
|
||||
RADOS_CMAKE_ON= -Drados=ON -Dcephfs=ON
|
||||
RADOS_LIB_DEPENDS= librados.so:net/ceph14
|
||||
|
||||
# Client only or full server version
|
||||
.if defined(WITH_CLIENT_ONLY)
|
||||
@ -193,6 +205,10 @@ MAKE_ENV+= MAN8="${MP8}" MAN1="${MP1}"
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} '42d' ${WRKSRC}/CMakeLists.txt
|
||||
@${REINPLACE_CMD} -e 's|api/glfs.h|glusterfs/api/glfs.h|g' \
|
||||
${WRKSRC}/core/src/stored/backends/gfapi_device.h
|
||||
@${REINPLACE_CMD} -e 's|sm_dump(false)|sm_dump(jcr,false)|g' \
|
||||
${WRKSRC}/core/src/tools/btestls.cc
|
||||
.if ${PKGNAMESUFFIX} == "18-server"
|
||||
@${REINPLACE_CMD} '25d' ${WRKSRC}/core/src/plugins/CMakeLists.txt
|
||||
.endif
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1589241653
|
||||
SHA256 (bareos-bareos-Release-18.2.8_GH0.tar.gz) = 705e15d3f30e8f656c805e3051e429c26217ffefde8900d1fdd0f2a25b7698f6
|
||||
SIZE (bareos-bareos-Release-18.2.8_GH0.tar.gz) = 10552800
|
||||
TIMESTAMP = 1608000734
|
||||
SHA256 (bareos-bareos-Release-18.2.10_GH0.tar.gz) = 55ef90b2efaa8cb665ef0f9b89e8155e05fcc73da97addfb74f3b7aa57218f63
|
||||
SIZE (bareos-bareos-Release-18.2.10_GH0.tar.gz) = 10558902
|
||||
|
@ -1,32 +1,32 @@
|
||||
--- core/CMakeLists.txt 2019-12-12 12:04:14.000000000 -0500
|
||||
+++ core/CMakeLists.txt 2019-12-28 16:17:19.843397000 -0500
|
||||
@@ -117,7 +117,9 @@
|
||||
set(PSCMD "ps -ax -o pid,command")
|
||||
include_directories(/usr/local/include)
|
||||
link_directories(/usr/local/lib)
|
||||
- link_libraries(intl)
|
||||
+ IF(nls)
|
||||
+ link_libraries(intl)
|
||||
+ ENDIF()
|
||||
--- core/CMakeLists.txt 2020-12-11 10:27:01.000000000 -0500
|
||||
+++ core/CMakeLists.txt 2020-12-14 21:56:05.412121000 -0500
|
||||
@@ -115,7 +115,9 @@
|
||||
set(PSCMD "ps -ax -o pid,command")
|
||||
include_directories(/usr/local/include)
|
||||
link_directories(/usr/local/lib)
|
||||
- link_libraries(intl)
|
||||
+ IF(nls)
|
||||
+ link_libraries(intl)
|
||||
+ ENDIF()
|
||||
endif()
|
||||
|
||||
IF (${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
|
||||
@@ -176,7 +178,9 @@
|
||||
add_definitions("-D_FILE_OFFSET_BITS=64")
|
||||
if(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
|
||||
@@ -187,7 +189,9 @@
|
||||
add_definitions("-D_FILE_OFFSET_BITS=64")
|
||||
endif()
|
||||
|
||||
-INCLUDE(FindIntl)
|
||||
-include(FindIntl)
|
||||
+IF(nls)
|
||||
+ INCLUDE(FindIntl)
|
||||
+ include(FindIntl)
|
||||
+ENDIF()
|
||||
|
||||
IF(developer)
|
||||
add_definitions("-DDEVELOPER=1")
|
||||
@@ -586,7 +590,6 @@
|
||||
if(developer)
|
||||
add_definitions("-DDEVELOPER=1")
|
||||
@@ -600,7 +604,6 @@
|
||||
|
||||
add_subdirectory(scripts)
|
||||
add_subdirectory(manpages)
|
||||
-add_subdirectory(platforms)
|
||||
add_subdirectory(src)
|
||||
|
||||
STRING(TIMESTAMP NOW "%Y-%m-%d %H:%M:%S")
|
||||
string(TIMESTAMP NOW "%Y-%m-%d %H:%M:%S")
|
||||
|
@ -0,0 +1,34 @@
|
||||
--- core/cmake/BareosCheckIncludes.cmake 2020-12-14 22:02:44.192311000 -0500
|
||||
+++ core/cmake/BareosCheckIncludes.cmake 2020-12-14 22:06:25.053879000 -0500
|
||||
@@ -103,20 +103,20 @@
|
||||
CHECK_INCLUDE_FILES(sys/xattr.h HAVE_SYS_XATTR_H)
|
||||
CHECK_INCLUDE_FILES(api/glfs.h HAVE_API_GLFS_H)
|
||||
|
||||
-CHECK_INCLUDE_FILES(cephfs/libcephfs.h HAVE_CEPHFS_LIBCEPHFS_H)
|
||||
+if(cephfs)
|
||||
+ CHECK_INCLUDE_FILES(cephfs/libcephfs.h HAVE_CEPHFS_LIBCEPHFS_H)
|
||||
+ CHECK_INCLUDE_FILES("sys/stat.h;cephfs/ceph_ll_client.h" HAVE_CEPHFS_CEPH_STATX_H)
|
||||
+endif()
|
||||
|
||||
-include(CheckSymbolExists)
|
||||
-include(CMakePushCheckState)
|
||||
-cmake_push_check_state()
|
||||
-set(CMAKE_REQUIRED_LIBRARIES cephfs)
|
||||
-check_symbol_exists(ceph_statx "sys/stat.h;cephfs/libcephfs.h" HAVE_CEPHFS_CEPH_STATX_H)
|
||||
-cmake_pop_check_state()
|
||||
+if(rados)
|
||||
+ CHECK_INCLUDE_FILES(rados/librados.h HAVE_RADOS_LIBRADOS_H)
|
||||
+ CHECK_INCLUDE_FILES(radosstriper/libradosstriper.h HAVE_RADOSSTRIPER_LIBRADOSSTRIPER_H)
|
||||
+endif()
|
||||
|
||||
-CHECK_INCLUDE_FILES(rados/librados.h HAVE_RADOS_LIBRADOS_H)
|
||||
-CHECK_INCLUDE_FILES(radosstriper/libradosstriper.h HAVE_RADOSSTRIPER_LIBRADOSSTRIPER_H)
|
||||
-
|
||||
#CHECK_INCLUDE_FILES(glusterfs/glusterfs.h HAVE_GLUSTERFS_GLUSTERFS_H)
|
||||
-CHECK_INCLUDE_FILES(glusterfs/api/glfs.h HAVE_GLUSTERFS_API_GLFS_H)
|
||||
+if(gfapi)
|
||||
+ CHECK_INCLUDE_FILES(glusterfs/api/glfs.h HAVE_GLUSTERFS_API_GLFS_H)
|
||||
+endif()
|
||||
|
||||
CHECK_INCLUDE_FILES(elasto/data.h HAVE_ELASTO_DATA_H)
|
||||
CHECK_INCLUDE_FILES(elasto/file.h HAVE_ELASTO_FILE_H)
|
@ -1,5 +1,5 @@
|
||||
--- core/cmake/BareosFindAllLibraries.cmake 2019-05-10 00:27:21.421777000 -0500
|
||||
+++ core/cmake/BareosFindAllLibraries.cmake 2019-05-10 00:28:47.016424000 -0500
|
||||
--- core/cmake/BareosFindAllLibraries.cmake 2020-12-11 10:27:01.000000000 -0500
|
||||
+++ core/cmake/BareosFindAllLibraries.cmake 2020-12-14 22:52:06.210892000 -0500
|
||||
@@ -25,13 +25,15 @@
|
||||
|
||||
|
||||
@ -22,3 +22,30 @@
|
||||
endif()
|
||||
|
||||
INCLUDE(FindPostgreSQL)
|
||||
@@ -52,13 +54,21 @@
|
||||
|
||||
BareosFindLibraryAndHeaders("fastlz" "fastlzlib.h")
|
||||
BareosFindLibraryAndHeaders("jansson" "jansson.h")
|
||||
-BareosFindLibraryAndHeaders("rados" "rados/librados.h")
|
||||
-BareosFindLibraryAndHeaders("radosstriper" "radosstriper/libradosstriper.h")
|
||||
-BareosFindLibraryAndHeaders("cephfs" "cephfs/libcephfs.h")
|
||||
+if(rados)
|
||||
+ BareosFindLibraryAndHeaders("rados" "rados/librados.h")
|
||||
+ BareosFindLibraryAndHeaders("radosstriper" "radosstriper/libradosstriper.h")
|
||||
+endif()
|
||||
+if(cephfs)
|
||||
+ BareosFindLibraryAndHeaders("cephfs" "cephfs/libcephfs.h")
|
||||
+endif()
|
||||
BareosFindLibraryAndHeaders("pthread" "pthread.h")
|
||||
BareosFindLibraryAndHeaders("cap" "sys/capability.h")
|
||||
-BareosFindLibraryAndHeaders("gfapi" "glusterfs/api/glfs.h")
|
||||
-BareosFindLibraryAndHeaders("droplet" "droplet.h")
|
||||
+if(gfapi)
|
||||
+ BareosFindLibraryAndHeaders("gfapi" "glusterfs/api/glfs.h")
|
||||
+endif()
|
||||
+if(droplet)
|
||||
+ BareosFindLibraryAndHeaders("droplet" "droplet.h")
|
||||
+endif()
|
||||
|
||||
BareosFindLibraryAndHeaders("pam" "security/pam_appl.h")
|
||||
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- core/cmake/BareosInstallConfigFiles.cmake 2019-02-13 09:25:55.000000000 -0500
|
||||
+++ core/cmake/BareosInstallConfigFiles.cmake 2019-05-08 22:47:21.128268000 -0500
|
||||
--- core/cmake/BareosInstallConfigFiles.cmake 2020-12-11 10:27:01.000000000 -0500
|
||||
+++ core/cmake/BareosInstallConfigFiles.cmake 2020-12-15 01:25:25.641687000 -0500
|
||||
@@ -43,18 +43,9 @@
|
||||
get_filename_component(resname ${resdir} NAME)
|
||||
foreach(configfile ${configfiles})
|
||||
@ -22,7 +22,7 @@
|
||||
endforeach()
|
||||
endforeach()
|
||||
|
||||
@@ -82,15 +73,9 @@
|
||||
@@ -82,21 +73,16 @@
|
||||
get_filename_component(dir ${configfile} DIRECTORY)
|
||||
get_filename_component(fname ${configfile} NAME)
|
||||
|
||||
@ -41,17 +41,25 @@
|
||||
endforeach()
|
||||
|
||||
file(GLOB_RECURSE configfiles RELATIVE "${BackendConfigSrcDir}" "${BackendConfigSrcDir}/*.example")
|
||||
@@ -104,7 +89,8 @@
|
||||
foreach(configfile ${configfiles})
|
||||
get_filename_component(dir ${configfile} DIRECTORY)
|
||||
- #get_filename_component(fname ${configfile} NAME)
|
||||
+ get_filename_component(fname ${configfile} NAME)
|
||||
+ get_filename_component(fsname ${configfile} NAME_WE)
|
||||
|
||||
if (EXISTS ${DESTCONFDIR}/${configfile})
|
||||
MESSAGE(STATUS "overwriting ${configfile}")
|
||||
@@ -104,7 +90,8 @@
|
||||
MESSAGE(STATUS "${configfile} as ${configfile}")
|
||||
endif()
|
||||
|
||||
- FILE(COPY "${BackendConfigSrcDir}/${configfile}" DESTINATION "${DESTCONFDIR}/${dir}")
|
||||
+ FILE(RENAME "${BackendConfigSrcDir}/${configfile}" "${BackendConfigSrcDir}/${configfile}.sample")
|
||||
+ FILE(COPY "${BackendConfigSrcDir}/${configfile}.sample" DESTINATION "${DESTCONFDIR}/${dir}")
|
||||
+ FILE(RENAME "${BackendConfigSrcDir}/${configfile}" "${BackendConfigSrcDir}/${fsname}.conf.sample")
|
||||
+ FILE(COPY "${BackendConfigSrcDir}/${fsname}.conf.sample" DESTINATION "${DESTCONFDIR}/${dir}")
|
||||
endforeach()
|
||||
|
||||
ENDFOREACH()
|
||||
@@ -122,15 +108,9 @@
|
||||
@@ -122,15 +109,13 @@
|
||||
STRING(REGEX MATCH "\\.in\$" IS_INFILE ${configfile})
|
||||
if (NOT "${IS_INFILE}" STREQUAL ".in")
|
||||
get_filename_component(fname ${configfile} NAME)
|
||||
@ -64,9 +72,13 @@
|
||||
- MESSAGE(STATUS "${resname}/${fname} as ${resname}/${fname}")
|
||||
- FILE (COPY "${configfile}" DESTINATION "${DESTCONFDIR}/${resname}")
|
||||
- endif()
|
||||
+ get_filename_component(fsname ${configfile} NAME_WE)
|
||||
+ MESSAGE(STATUS "${resname}/${fname} as ${resname}/${fname}")
|
||||
+ FILE (RENAME "${configfile}" "${configfile}.sample")
|
||||
+ FILE (COPY "${configfile}.sample" DESTINATION "${DESTCONFDIR}/${resname}")
|
||||
+ FILE(RENAME "${configfile}" "${resdir}/${fsname}.conf.sample")
|
||||
+ FILE(
|
||||
+ COPY "${resdir}/${fsname}.conf.sample"
|
||||
+ DESTINATION "${DESTCONFDIR}/${resname}"
|
||||
+ )
|
||||
else()
|
||||
MESSAGE(STATUS "skipping .in file ${configfile}:${IS_INFILE}")
|
||||
endif()
|
||||
|
@ -0,0 +1,24 @@
|
||||
--- core/src/plugins/filed/gfapi-fd.cc 2020-12-14 23:47:04.832213000 -0500
|
||||
+++ core/src/plugins/filed/gfapi-fd.cc 2020-12-14 23:47:56.824952000 -0500
|
||||
@@ -30,7 +30,7 @@
|
||||
#include "lib/path_list.h"
|
||||
#include "lib/edit.h"
|
||||
|
||||
-#include <api/glfs.h>
|
||||
+#include <glusterfs/api/glfs.h>
|
||||
|
||||
|
||||
/* avoid missing config.h problem on Debian 8 and Ubuntu 16:
|
||||
@@ -39,10 +39,10 @@
|
||||
*/
|
||||
#ifndef _CONFIG_H
|
||||
#define _CONFIG_H
|
||||
-#include <compat-errno.h>
|
||||
+#include <glusterfs/compat-errno.h>
|
||||
#undef _CONFIG_H
|
||||
#else
|
||||
-#include <compat-errno.h>
|
||||
+#include <glusterfs/compat-errno.h>
|
||||
#endif
|
||||
|
||||
namespace filedaemon {
|
@ -11,12 +11,22 @@ bin/timelimit
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/fileset/LinuxAll.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/fileset/SelfTest.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/fileset/WindowsAllDrives.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/fileset/plugin-ldap.conf.example.sample
|
||||
%%CEPHFS%%@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/fileset/plugin-cephfs.conf.sample
|
||||
%%GFAPI%%@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/fileset/plugin-gfapi.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/fileset/plugin-ldap.conf.sample
|
||||
%%RADOS%%@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/fileset/plugin-rados.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/fileset/plugin-ldap.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/job/BackupCatalog.conf.sample
|
||||
%%CEPHFS%%@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/job/BackupCephfs.conf.sample
|
||||
%%GFAPI%%@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/job/BackupGFAPI.conf.sample
|
||||
%%RADOS%%@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/job/BackupRados.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/job/RestoreFiles.conf.sample
|
||||
%%CEPHFS%%@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/job/RestoreCephfs.conf.sample
|
||||
%%GFAPI%%@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/job/RestoreGFAPI.conf.sample
|
||||
%%RADOS%%@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/job/RestoreRados.conf.sampl
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/job/backup-bareos-fd.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/job/backup-ldap.conf.example.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/job/restore-ldap.conf.example.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/job/backup-ldap.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/job/restore-ldap.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/jobdefs/DefaultJob.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/messages/Daemon.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/messages/Standard.conf.sample
|
||||
@ -28,13 +38,15 @@ bin/timelimit
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/schedule/WeeklyCycle.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/schedule/WeeklyCycleAfterBackup.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/storage/File.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/storage/NULL.conf.example.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/storage/Tape.conf.example.sample
|
||||
%%GFAPI%%@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/storage/Gluster.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/storage/NULL.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-dir.d/storage/Tape.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-regress.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-sd.d/autochanger/autochanger-0.conf.example.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-sd.d/autochanger/autochanger-0.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-sd.d/device/FileStorage.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-sd.d/device/NULL.conf.example.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-sd.d/device/tapedrive-0.conf.example.sample
|
||||
%%GFAPI%%@sample(,bareos,640) %%ETCDIR%%/bareos-sd.d/device/GlusterStorage.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-sd.d/device/NULL.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-sd.d/device/tapedrive-0.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-sd.d/director/bareos-dir.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-sd.d/director/bareos-mon.conf.sample
|
||||
@sample(,bareos,640) %%ETCDIR%%/bareos-sd.d/messages/Standard.conf.sample
|
||||
@ -44,6 +56,9 @@ etc/logrotate.d/bareos-dir
|
||||
lib/bareos/backends/libbareoscats-%%DBTYPE%%.so
|
||||
lib/bareos/backends/libbareossd-fifo.so
|
||||
lib/bareos/backends/libbareossd-gentape.so
|
||||
%%CEPHFS%%lib/bareos/backends/libbareossd-cephfs.so
|
||||
%%GFAPI%%lib/bareos/backends/libbareossd-gfapi.so
|
||||
%%RADOS%%lib/bareos/backends/libbareossd-rados.so
|
||||
lib/bareos/backends/libbareossd-tape.so
|
||||
%%PYTHON%%lib/bareos/plugins/BareosDirPluginBaseclass.py
|
||||
%%PYTHON%%lib/bareos/plugins/BareosDirWrapper.py
|
||||
|
@ -28,7 +28,10 @@ lib/libbareosfind.so.%%LIB_VERSION%%
|
||||
%%PYTHON%%lib/bareos/plugins/bareos-fd.py.template
|
||||
%%PYTHON%%lib/bareos/plugins/bareos_fd_consts.py
|
||||
lib/bareos/plugins/bpipe-fd.so
|
||||
%%CEPHFS%%lib/bareos/plugins/cephfs-fd.so
|
||||
%%GFAPI%%lib/bareos/plugins/gfapi-fd.so
|
||||
%%PYTHON%%lib/bareos/plugins/python-fd.so
|
||||
%%RADOS%%lib/bareos/plugins/rados-fd.so
|
||||
lib/bareos/scripts/bareos
|
||||
lib/bareos/scripts/bareos-config
|
||||
lib/bareos/scripts/bareos-config-lib.sh
|
||||
|
Loading…
Reference in New Issue
Block a user