parent
83777bd90c
commit
b0a674bdfb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=552531
@ -1,7 +1,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= yuzu
|
||||
PORTVERSION= s20201012
|
||||
PORTVERSION= s20201015
|
||||
PORTREVISION?= 0
|
||||
CATEGORIES= emulators
|
||||
|
||||
@ -35,7 +35,7 @@ LIB_DEPENDS= liblz4.so:archivers/liblz4 \
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= yuzu-emu
|
||||
GH_TAGNAME= 4c348f406
|
||||
GH_TAGNAME= 64f967fd4
|
||||
GH_TUPLE= yuzu-emu:unicorn:1.0.1-153-g73f45735:unicorn/externals/unicorn \
|
||||
DarkLordZach:mbedtls:a280e60:mbedtls/externals/mbedtls \
|
||||
KhronosGroup:SPIRV-Headers:2c51218:SPIRV_Headers/externals/sirit/externals/SPIRV-Headers \
|
||||
@ -93,6 +93,8 @@ post-patch:
|
||||
@${REINPLACE_CMD} -e 's/@GIT_BRANCH@/master/' \
|
||||
-e 's/@GIT_DESC@/${GH_TAGNAME}/' \
|
||||
${WRKSRC}/src/common/scm_rev.cpp.in
|
||||
# https://github.com/yuzu-emu/yuzu/issues/4795
|
||||
@${REINPLACE_CMD} '/-Werror/d' ${WRKSRC}/src/*/CMakeLists.txt
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
@ -1,8 +1,8 @@
|
||||
TIMESTAMP = 1602532437
|
||||
TIMESTAMP = 1602820774
|
||||
SHA256 (libcxx-10.0.1.src.tar.xz) = def674535f22f83131353b3c382ccebfef4ba6a35c488bdb76f10b68b25be86c
|
||||
SIZE (libcxx-10.0.1.src.tar.xz) = 1839172
|
||||
SHA256 (yuzu-emu-yuzu-s20201012-4c348f406_GH0.tar.gz) = fd9747cb31c27baedb0873cdb6c4fde5a6719ad7f0305c5e471caa15aa89936a
|
||||
SIZE (yuzu-emu-yuzu-s20201012-4c348f406_GH0.tar.gz) = 4004466
|
||||
SHA256 (yuzu-emu-yuzu-s20201015-64f967fd4_GH0.tar.gz) = 9c8e28b0ca8714766b90185831fc7c2d9b7df5a33f67a337a07b305db743ac75
|
||||
SIZE (yuzu-emu-yuzu-s20201015-64f967fd4_GH0.tar.gz) = 4014141
|
||||
SHA256 (yuzu-emu-unicorn-1.0.1-153-g73f45735_GH0.tar.gz) = 8f7b4d8eb998c2a4c146268d83b44fc22ca8d4d276f26d6af1071e51f4b5bd4f
|
||||
SIZE (yuzu-emu-unicorn-1.0.1-153-g73f45735_GH0.tar.gz) = 3296254
|
||||
SHA256 (DarkLordZach-mbedtls-a280e60_GH0.tar.gz) = 4fc6ddc256bc75b975fd5ad8bb7d31ff79c62d49daafb0108585c9ef80c6c5a7
|
||||
|
@ -12,17 +12,17 @@ Revert https://github.com/yuzu-emu/yuzu/commit/2a3d4cad63f8
|
||||
[submodule "libusb"]
|
||||
path = externals/libusb/libusb
|
||||
url = https://github.com/libusb/libusb.git
|
||||
--- CMakeLists.txt.orig 2020-06-30 00:16:03 UTC
|
||||
--- CMakeLists.txt.orig 2020-10-16 03:59:34 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -152,6 +152,7 @@ macro(yuzu_find_packages)
|
||||
"Boost 1.71 boost/1.72.0"
|
||||
"Catch2 2.11 catch2/2.11.0"
|
||||
@@ -162,6 +161,7 @@ macro(yuzu_find_packages)
|
||||
"Boost 1.72 boost/1.72.0"
|
||||
"Catch2 2.13 catch2/2.13.0"
|
||||
"fmt 7.0 fmt/7.0.3"
|
||||
+ "OpenSSL 1.0 openssl/1.1.1f"
|
||||
# can't use until https://github.com/bincrafters/community/issues/1173
|
||||
#"libzip 1.5 libzip/1.5.2@bincrafters/stable"
|
||||
"lz4 1.8 lz4/1.9.2"
|
||||
@@ -312,6 +313,15 @@ if (TARGET Boost::Boost)
|
||||
@@ -326,6 +326,15 @@ if (TARGET Boost::Boost)
|
||||
elseif (TARGET Boost::boost)
|
||||
set_target_properties(Boost::boost PROPERTIES IMPORTED_GLOBAL TRUE)
|
||||
add_library(boost ALIAS Boost::boost)
|
||||
@ -38,7 +38,7 @@ Revert https://github.com/yuzu-emu/yuzu/commit/2a3d4cad63f8
|
||||
endif()
|
||||
|
||||
if (TARGET sdl2::sdl2)
|
||||
--- externals/CMakeLists.txt.orig 2020-06-29 05:12:38 UTC
|
||||
--- externals/CMakeLists.txt.orig 2020-10-16 03:59:34 UTC
|
||||
+++ externals/CMakeLists.txt
|
||||
@@ -73,15 +73,6 @@ if (NOT LIBZIP_FOUND)
|
||||
endif()
|
||||
@ -56,10 +56,12 @@ Revert https://github.com/yuzu-emu/yuzu/commit/2a3d4cad63f8
|
||||
# lurlparser
|
||||
add_subdirectory(lurlparser EXCLUDE_FROM_ALL)
|
||||
|
||||
@@ -89,5 +80,5 @@ if (ENABLE_WEB_SERVICE)
|
||||
@@ -89,7 +80,7 @@ if (ENABLE_WEB_SERVICE)
|
||||
add_library(httplib INTERFACE)
|
||||
target_include_directories(httplib INTERFACE ./httplib)
|
||||
target_compile_definitions(httplib INTERFACE -DCPPHTTPLIB_OPENSSL_SUPPORT)
|
||||
- target_link_libraries(httplib INTERFACE ${OPENSSL_LIBRARIES})
|
||||
+ target_link_libraries(httplib INTERFACE OpenSSL::SSL OpenSSL::Crypto)
|
||||
endif()
|
||||
if (WIN32)
|
||||
target_link_libraries(httplib INTERFACE crypt32 cryptui ws2_32)
|
||||
endif()
|
||||
|
@ -20,11 +20,11 @@ Revert https://github.com/yuzu-emu/yuzu/commit/d5dfe34c4935
|
||||
"ZLIB 1.2 zlib/1.2.11"
|
||||
"zstd 1.4 zstd/1.4.5"
|
||||
)
|
||||
--- externals/CMakeLists.txt.orig 2020-07-07 22:13:55 UTC
|
||||
--- externals/CMakeLists.txt.orig 2020-10-16 03:59:34 UTC
|
||||
+++ externals/CMakeLists.txt
|
||||
@@ -82,6 +82,3 @@ if (ENABLE_WEB_SERVICE)
|
||||
target_compile_definitions(httplib INTERFACE -DCPPHTTPLIB_OPENSSL_SUPPORT)
|
||||
target_link_libraries(httplib INTERFACE OpenSSL::SSL OpenSSL::Crypto)
|
||||
@@ -85,6 +85,3 @@ if (ENABLE_WEB_SERVICE)
|
||||
target_link_libraries(httplib INTERFACE crypt32 cryptui ws2_32)
|
||||
endif()
|
||||
endif()
|
||||
-
|
||||
-# Opus
|
||||
|
Loading…
Reference in New Issue
Block a user