Add mplayerplug-in, a Mozilla plugin that uses MPlayer to play videos on

websites.
This commit is contained in:
Joe Marcus Clarke 2003-02-20 21:40:57 +00:00
parent 2e62290655
commit b0a32a451c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=75990
6 changed files with 49 additions and 0 deletions

View File

@ -231,6 +231,7 @@
SUBDIR += mozilla-headers-devel
SUBDIR += mozilla-headers-vendor
SUBDIR += mozilla-vendor
SUBDIR += mplayer-plugin
SUBDIR += nautilus-gtkhtml
SUBDIR += nd
SUBDIR += neon

View File

@ -0,0 +1,29 @@
# New ports collection makefile for: mplayerplug-in
# Date Created: 20 February 2003
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= mplayerplug-in
PORTVERSION= 0.40
CATEGORIES= www multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mplayerplug-in
DISTNAME= ${PORTNAME}_v${PORTVERSION}
MAINTAINER= marcus@FreeBSD.org
COMMENT= A Mozilla plugin for the MPlayer media player
RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_X_PREFIX= yes
USE_GMAKE= yes
do-install:
${MKDIR} ${PREFIX}/lib/browser_plugins
${INSTALL_PROGRAM} ${WRKSRC}/mplayerplug-in.so \
${PREFIX}/lib/browser_plugins
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (mplayerplug-in_v0.40.tar.gz) = 45378ac240c9aff7aec25ad30f49ae60

View File

@ -0,0 +1,13 @@
--- Makefile.orig Thu Feb 20 16:38:02 2003
+++ Makefile Thu Feb 20 16:38:09 2003
@@ -30,8 +30,8 @@
PLUGIN_DEFINES= -DXP_UNIX -Iinclude -ISource/_gen -I/usr/X11R6/include
CC= gcc
-OPTIMIZER= -g
-CFLAGS= $(OPTIMIZER) $(PLUGIN_DEFINES) -I. -I/usr/include
+OPTIMIZER=
+CFLAGS+= $(OPTIMIZER) $(PLUGIN_DEFINES) -I. -I/usr/include
SRC= Source/mplayerplug-in.c Source/stubs.c
OBJ= mplayerplug-in.o stubs.o

View File

@ -0,0 +1,3 @@
A Mozilla plugin that uses MPlayer to play videos from websites.
WWW: http://mplayerplug-in.sourceforge.net/

View File

@ -0,0 +1,2 @@
lib/browser_plugins/mplayerplug-in.so
@unexec rmdir %D/lib/browser_plugins 2>/dev/null || /usr/bin/true