net/py-pyzmq: update to 18.0.1
Drop patch for the issue fixed upstream.
This commit is contained in:
parent
db27816abb
commit
b0807db29f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=495289
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pyzmq
|
||||
PORTVERSION= 18.0.0
|
||||
PORTVERSION= 18.0.1
|
||||
CATEGORIES= net devel
|
||||
MASTER_SITES= CHEESESHOP
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1551109436
|
||||
SHA256 (pyzmq-18.0.0.tar.gz) = b30c339eb58355f51f4f54dd61d785f1ff58c86bca1c3a5916977631d121867b
|
||||
SIZE (pyzmq-18.0.0.tar.gz) = 1155815
|
||||
TIMESTAMP = 1552212088
|
||||
SHA256 (pyzmq-18.0.1.tar.gz) = 8b319805f6f7c907b101c864c3ca6cefc9db8ce0791356f180b1b644c7347e4c
|
||||
SIZE (pyzmq-18.0.1.tar.gz) = 1156396
|
||||
|
@ -1,27 +0,0 @@
|
||||
--- setup.py.orig 2019-02-19 12:38:50 UTC
|
||||
+++ setup.py
|
||||
@@ -1,4 +1,6 @@
|
||||
#!/usr/bin/env python
|
||||
+# -*- coding: utf-8 -*-
|
||||
+#
|
||||
#-----------------------------------------------------------------------------
|
||||
# Copyright (C) PyZMQ Developers
|
||||
# Distributed under the terms of the Modified BSD License.
|
||||
@@ -24,6 +26,7 @@ import sys
|
||||
import time
|
||||
import errno
|
||||
import platform
|
||||
+import codecs
|
||||
from traceback import print_exc
|
||||
|
||||
# whether any kind of bdist is happening
|
||||
@@ -1236,8 +1239,7 @@ def find_packages():
|
||||
#-----------------------------------------------------------------------------
|
||||
# Main setup
|
||||
#-----------------------------------------------------------------------------
|
||||
-
|
||||
-with open("README.md") as f:
|
||||
+with codecs.open('README.md', 'r', 'utf-8') as f:
|
||||
long_desc = f.read()
|
||||
|
||||
setup_args = dict(
|
Loading…
Reference in New Issue
Block a user