New port docbook-to-man version 1.0: A DocBook SGML DTD into

nroff/troff -man macros converter

PR:		31060
Submitted by:	Cyrille Lefevre <clefevre@citeweb.net>
This commit is contained in:
Mario Sergio Fujikawa Ferreira 2001-10-07 16:33:04 +00:00
parent 6ecd568c10
commit b054015461
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=48525
10 changed files with 189 additions and 0 deletions

View File

@ -31,6 +31,7 @@
SUBDIR += docbook-400
SUBDIR += docbook-410
SUBDIR += docbook-tdg
SUBDIR += docbook-to-man
SUBDIR += docbook-xml
SUBDIR += docproj
SUBDIR += dsssl-docbook-cygnus

View File

@ -0,0 +1,70 @@
# New ports collection makefile for: gnupg-devel
# Date created: 5 Oct 2001
# Whom: Cyrille Lefevre <clefevre@citeweb.net>
#
# $FreeBSD$
#
PORTNAME= docbook-to-man
PORTVERSION= 1.0
CATEGORIES= textproc
MASTER_SITES= http://www.oasis-open.org/docbook/tools/dtm/
DISTNAME= ${PORTNAME}
MAINTAINER= clefevre@citeweb.net
.include <bsd.port.pre.mk>
# Global variables
#
# There are two ports that satisfy the nsgmls requirement.
# Jade is preferred, but it currently doesn't compile on 2.1.x
# system, so use sp in that case.
.if ${MACHINE_ARCH} == "alpha"
WITH_OPENJADE= yes
.endif
.if ${OSVERSION} < 220000
RUN_DEPENDS= nsgmls:${PORTSDIR}/textproc/sp
.elif defined(WITH_OPENJADE)
RUN_DEPENDS= onsgmls:${PORTSDIR}/textproc/openjade
.else
RUN_DEPENDS= nsgmls:${PORTSDIR}/textproc/jade
.endif
RUN_DEPENDS+= ${LOCALBASE}/share/sgml/docbook:${PORTSDIR}/textproc/docbook
USE_IMAKE= yes
USE_X_PREFIX= no
XFREE86_HTML_MAN= no
MAN1= oinstant.1
# Local variables
#
.if defined(WITH_OPENJADE)
NSGMLS= onsgmls
.else
NSGMLS= nsgmls
.endif
# Post extract
#
post-extract: move-instant.1
move-instant.1:
@${MV} ${WRKSRC}/Doc/instant.1 ${WRKSRC}/Instant/oinstant.man
# Post patch
#
post-patch: patch-docbook-to-man
patch-docbook-to-man:
@${PERL} -pi.fbsd -e 's|%%PREFIX%%|${PREFIX}|;s|%%NSGMLS%%|${NSGMLS}|' \
${WRKSRC}/cmd/docbook-to-man.sh
.include <bsd.port.post.mk>

View File

@ -0,0 +1 @@
MD5 (docbook-to-man.tar.gz) = b28ddaaa8eb4b775100c67fd1205240a

View File

@ -0,0 +1,29 @@
--- Instant/Imakefile.orig Mon Jun 17 05:50:29 1996
+++ Instant/Imakefile Fri Oct 5 18:18:22 2001
@@ -1,14 +1,18 @@
#define IHaveSubdirs
#define PassCDebugFlags
+#undef BuildInstallHtmlManPage
+#define BuildInstallHtmlManPage(x,y,z) /**/
SUBDIRS = tptregexp
-ROOT = /usr/local
+PREFIX ?= /usr/local
+ROOT = ${PREFIX}
+MANPATH = ${ROOT}/man
BINDIR = $(ROOT)/bin
INCLUDES = -Itptregexp
LOCAL_LIBRARIES = -Ltptregexp -ltptregexp
-TPTLIB = $(ROOT)/lib/tpt
+TPTLIB = $(ROOT)/share/sgml/otranspec
DEFINES = -DDEF_TPT_LIB=\"$(TPTLIB)\"
SRCS = main.c util.c info.c translate.c traninit.c tranvar.c tables.c \
@@ -19,4 +23,4 @@
MakeSubdirs($(SUBDIRS))
DependSubdirs($(SUBDIRS))
-ComplexProgramTarget(instant)
+ComplexProgramTarget(oinstant)

View File

@ -0,0 +1,11 @@
--- Transpec/Imakefile.orig Mon Jun 17 05:50:28 1996
+++ Transpec/Imakefile Fri Oct 5 18:20:17 2001
@@ -1,5 +1,6 @@
-ROOT = /usr/local
-TPTLIB = $(ROOT)/lib/tpt
+PREFIX ?= /usr/local
+ROOT = ${PREFIX}
+TPTLIB = $(ROOT)/share/sgml/otranspec
all::

View File

@ -0,0 +1,9 @@
--- cmd/Imakefile.orig Mon Jun 17 05:50:30 1996
+++ cmd/Imakefile Fri Oct 5 18:18:22 2001
@@ -1,4 +1,5 @@
-ROOT = /usr/local
+PREFIX ?= /usr/local
+ROOT = ${PREFIX}
BINDIR = $(ROOT)/bin
all::

View File

@ -0,0 +1,57 @@
--- cmd/docbook-to-man.sh.orig Mon Jun 17 05:50:30 1996
+++ cmd/docbook-to-man.sh Fri Oct 5 18:18:22 2001
@@ -40,9 +40,9 @@
# ***** change the following paths if your installation of nsgmls and / or
# ***** DocBook isn't into the default places.
-ROOT=/usr/local
-SGMLS=$ROOT/lib/sgml
-DOCBOOK=$SGMLS/Davenport/dtd
+ROOT=%%PREFIX%%
+SGMLS=$ROOT/share/sgml
+DOCBOOK=$SGMLS/docbook
# ***** modify the following line (to "=false") if you're not using the
@@ -51,19 +51,16 @@
doElanPSInclude=true
-
# Everything below this line should be pretty standard and not require
# modification.
#ulimit -c unlimited
PARSER=nsgmls
-INSTANT=instant
+INSTANT=oinstant
INSTANT_OPT=-d
-CATALOG=$DOCBOOK/docbook.cat
-DECL=$DOCBOOK/docbook.dcl
-#PROLOG=$DOCBOOK/docbook.prolog
+CATALOG=$DOCBOOK/catalog
error=false
@@ -159,17 +156,8 @@
.ds f4\"
!
-
-#if [ ! -f $PROLOG ]
-#then cat > $PROLOG <<!
-#<!DOCTYPE RefEntry PUBLIC "-//Davenport//DTD DocBook V2.4.1//EN" [
-#<!ENTITY npzwc "">
-#]>
-#!
-#fi
-
(cat /tmp/dtm.$$.psinc;
- $PARSER -gl -m$CATALOG $DECL $INSTANCE |
+ $PARSER -gl -c $CATALOG $INSTANCE |
$INSTANT $INSTANT_OPT -croff.cmap -sroff.sdata -tdocbook-to-man.ts)
-rm -f /tmp/dtm.$$.psinc
+rm -f /tmp/dtm.$$.psinc

View File

@ -0,0 +1 @@
A DocBook SGML DTD into nroff/troff -man macros converter

View File

@ -0,0 +1,4 @@
A batch converter that transforms UNIX-style manpages from the
DocBook SGML DTD into nroff/troff -man macros.
WWW: http://www.oasis-open.org/docbook/tools/dtm/

View File

@ -0,0 +1,6 @@
@comment $FreeBSD$
bin/docbook-to-man
bin/oinstant
share/sgml/otranspec/docbook-to-man.ts
share/sgml/otranspec/roff.cmap
share/sgml/otranspec/roff.sdata