- Borrow the patch from PR ports/97443;

- Upgrade to 7.1.2;

- Add a regression-test target;

- Portlint;

- Reset maintainership.

PR:		ports/100392
This commit is contained in:
Thierry Thomas 2006-07-16 19:53:22 +00:00
parent 42de19ceda
commit afdc61f588
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=168000
6 changed files with 146 additions and 30 deletions

View File

@ -6,41 +6,23 @@
#
PORTNAME= lam7
PORTVERSION= 7.1.1
PORTVERSION= 7.1.2
CATEGORIES= net parallel
MASTER_SITES= http://www.lam-mpi.org/download/files/ \
http://www.thinkingnerds.com/lam/download/files/
DISTNAME= lam-${PORTVERSION}
MAINTAINER= jan.lentfer@web.de
MAINTAINER= ports@FreeBSD.org
COMMENT= Local Area Multicomputer MPI implementation
BROKEN= fails to configure
USE_BZIP2= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-rsh=ssh
CONFIGURE_ARGS= --with-rsh=ssh
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFLICTS= lam-6.*
.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -E -e 's|/usr/bin/env perl|${PERL} -w| ; \
s|use warnings;||' ${WRKSRC}/tools/mpiexec/mpiexec
.if ${PERL_LEVEL} < 500800
BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.endif
.if ${ARCH} == "i386"
PLIST_FILES= lib/lam/liblam_totalview.la \
lib/lam/liblam_totalview.so.0 \
lib/lam/liblam_totalview.so
.endif
MAN1= hboot.1 \
hcc.1 \
hcp.1 \
@ -52,7 +34,9 @@ MAN1= hboot.1 \
lamd.1 \
lamexec.1 \
lamgrow.1 \
lamhalt.1 \
laminfo.1 \
lamnodes.1 \
lamrestart.1 \
lamshrink.1 \
lamtrace.1 \
@ -389,4 +373,27 @@ MAN7= LAM.7 \
libmpi.7 \
mpi.7
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500800
BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.endif
.if ${ARCH} == "i386"
PLIST_SUB= I386=""
.else
PLIST_SUB= I386="@comment "
.endif
pre-configure:
@${REINPLACE_CMD} -E -e 's|/usr/bin/env perl|${PERL} -w| ; \
s|use warnings;||' ${WRKSRC}/tools/mpiexec/mpiexec
.if defined(MAINTAINER_MODE)
regression-test: install
(cd ${BUILD_WRKSRC}/examples; \
${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
.endif
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (lam-7.1.1.tar.bz2) = 0a3eee53281884a063ce2c44793672b3
SHA256 (lam-7.1.1.tar.bz2) = e927edf77dc77969ed635cd749c82fb4c3880da670a18f0d1ec781fad90b248a
SIZE (lam-7.1.1.tar.bz2) = 7589413
MD5 (lam-7.1.2.tar.bz2) = 07c59cf03c773a67199e066e500e499b
SHA256 (lam-7.1.2.tar.bz2) = b3826e79f1a674ed275d2a0e32895aefe63d4278126bd5fa01dbe43cc1c1960b
SIZE (lam-7.1.2.tar.bz2) = 7851483

View File

@ -1,7 +1,11 @@
--- man/mans/Makefile.in Mon Jan 27 17:03:38 2003
+++ man/mans/Makefile.in Wed Jun 18 12:18:05 2003
@@ -193,3 +193,3 @@
--- man/mans/Makefile.in.orig Fri Mar 10 22:31:27 2006
+++ man/mans/Makefile.in Sun Jul 16 16:43:58 2006
@@ -134,7 +134,7 @@
CONFIG_CLEAN_FILES =
SOURCES =
DIST_SOURCES =
-mansdir = $(mandir)/mans
+mansdir = $(datadir)/lam
am__installdirs = "$(DESTDIR)$(mansdir)"
NROFF = nroff
MANS = $(man_MANS)

View File

@ -0,0 +1,38 @@
--- ./otb/lamcheckpoint/lamcheckpoint.c.orig Fri Feb 24 00:26:54 2006
+++ ./otb/lamcheckpoint/lamcheckpoint.c Sun Jul 16 12:31:41 2006
@@ -36,7 +36,7 @@
OPT *ad;
int param_crlam;
-static int strtonum(const char *, pid_t *);
+static int istrtonum(const char *, pid_t *);
/*
* main
@@ -80,7 +80,7 @@
pid_arg = ao_param(ad, "pid", 0, 0);
- if (strtonum(pid_arg, &pid) != 0) {
+ if (istrtonum(pid_arg, &pid) != 0) {
show_help("lamcheckpoint", "usage", NULL);
lam_ssi_base_close();
ao_free(ad);
@@ -125,7 +125,7 @@
/*
- * strtonum
+ * istrtonum
*
* Function: - convert string to number if possible
* - handles decimal/octal/hexadecimal
@@ -135,7 +135,7 @@
* Returns: - 0 or LAMERROR
*/
static int
-strtonum(const char *str, pid_t *pnum)
+istrtonum(const char *str, pid_t *pnum)
{
char *endstr; /* end of parsed string */

View File

@ -0,0 +1,64 @@
--- share/args/all_opt.c.orig Sun Sep 26 17:35:02 2004
+++ share/args/all_opt.c Sun Jul 16 12:07:07 2006
@@ -19,6 +19,7 @@
*/
#include <stdlib.h>
+#include <limits.h>
#include <string.h>
#include <all_opt.h>
@@ -33,7 +34,7 @@
static int addinst(struct ao_opt *opt, int nparam, char **params);
static int countparam(OPT *aod, struct ao_opt *opt, char **argv);
static int mutexchk(struct ao_opt *opt);
-static int strtonum(const char *str, int *pnum);
+static int istrtonum(const char *str, int *pnum);
static struct ao_opt *findopt(OPT *desc, const char *optstr);
@@ -652,7 +653,7 @@
/*
* If a number, assume '#' option.
*/
- else if (strtonum(++str, &num) == 0) {
+ else if (istrtonum(++str, &num) == 0) {
popt = findopt(aod, "#");
if ((popt == 0) || (mutexchk(popt))) {
@@ -884,7 +885,7 @@
/*
- * strtonum
+ * istrtonum
*
* Function: - convert string to number if possible
* - handles decimal/octal/hexadecimal
@@ -894,7 +895,7 @@
* Returns: - 0 or LAMERROR
*/
static int
-strtonum(const char *str, int *pnum)
+istrtonum(const char *str, int *pnum)
{
char *endstr; /* end of parsed string */
@@ -956,7 +957,7 @@
if (strcmp(string, "--") == 0) break;
- if ((strtonum(string + 1, &num) == 0) &&
+ if ((istrtonum(string + 1, &num) == 0) &&
(findopt(aod, "#") != 0)) break;
if (findopt(aod, string + 1)) break;
@@ -1036,7 +1037,7 @@
for (; nparam > 0; --nparam, ++params, parmbuf += size) {
if (fl_int) {
- if (strtonum(*params, &num)) {
+ if (istrtonum(*params, &num)) {
errno = EUSAGE;
return(LAMERROR);
}

View File

@ -89,6 +89,9 @@ include/mpicxx.h
include/mpif.h
include/mpio.h
include/mpiof.h
%%I386%%lib/lam/liblam_totalview.la
%%I386%%lib/lam/liblam_totalview.so
%%I386%%lib/lam/liblam_totalview.so.0
lib/liblam.a
lib/liblam.la
lib/liblamf77mpi.a
@ -107,6 +110,6 @@ share/lam/doc/ptmalloc2-COPYRIGHT
share/lam/doc/romio-users-guide.ps.gz
share/lam/mpi.share
@dirrm include/mpi2cxx
@dirrm lib/lam
%%I386%%@dirrm lib/lam
@dirrm share/lam/doc
@dirrm share/lam