New port: sysutils/lockfile-progs

This package includes several programs to safely lock and unlock
files and mailboxes from the command line.  These include:

   lockfile-create
   lockfile-remove
   lockfile-touchlock
   mail-lock
   mail-unlock
   mail-touchlock

These programs use liblockfile to perform the file locking and
unlocking, so they are guaranteed compatible with Debian's
file locking policies.

WWW: https://tracker.debian.org/pkg/lockfile-progs

PR:		224508
Submitted by:	Yasuhiro KIMURA <yasu@utahime.org>
This commit is contained in:
Kurt Jaeger 2018-02-14 17:10:36 +00:00
parent f8f24ef9fe
commit afb9e97ec9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=461821
6 changed files with 96 additions and 0 deletions

View File

@ -575,6 +575,7 @@
SUBDIR += lmmon
SUBDIR += lmon
SUBDIR += lnav
SUBDIR += lockfile-progs
SUBDIR += log_analysis
SUBDIR += logrotate
SUBDIR += logstalgia

View File

@ -0,0 +1,40 @@
# Created by: Yasuhiro KIMURA <yasu@utahime.org>
# $FreeBSD$
PORTNAME= lockfile-progs
PORTVERSION= 0.1.17
CATEGORIES= sysutils
MASTER_SITES= DEBIAN_POOL
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= yasu@utahime.org
COMMENT= Programs for locking and unlocking files and mailboxes
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= liblockfile.so:devel/liblockfile
ALL_TARGET= lockfile-create
WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
OPTIONS_DEFINE= DOCS
PORTDOCS= TODO changelog
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/lockfile-create ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/lockfile-progs.1 ${STAGEDIR}${MANPREFIX}/man/man1
.for f in lockfile-remove lockfile-touch lockfile-check mail-lock mail-unlock mail-touchlock
${LN} ${STAGEDIR}${PREFIX}/bin/lockfile-create ${STAGEDIR}${PREFIX}/bin/${f}
${LN} -s lockfile-progs.1 ${STAGEDIR}${MANPREFIX}/man/man1/${f}.1
.endfor
${LN} -s lockfile-progs.1 ${STAGEDIR}${MANPREFIX}/man/man1/lockfile-create.1
do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in TODO debian/changelog
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1513867442
SHA256 (lockfile-progs_0.1.17.tar.gz) = 03fb05d25499532f497775b1747b61fa6beebf12d3bcc951e125349ae166c511
SIZE (lockfile-progs_0.1.17.tar.gz) = 14833

View File

@ -0,0 +1,21 @@
--- Makefile.orig 2011-08-21 23:28:35 UTC
+++ Makefile
@@ -1,5 +1,5 @@
-LOADLIBES := -llockfile
+LOADLIBES := -L${LOCALBASE}/lib -llockfile
CFLAGS := -g -Wall -Wformat-security -Werror -O2
all: lockfile-create
@@ -24,7 +24,10 @@ all: lockfile-create
.PHONY: all
lockfile-create: lockfile-progs.o
- ${CC} -o $@ ${LDFLAGS} $^ ${LOADLIBES}
+ ${CC} -o $@ ${LDFLAGS} lockfile-progs.o ${LOADLIBES}
+
+lockfile-progs.o:
+ ${CC} ${CFLAGS} -c -I${LOCALBASE}/include lockfile-progs.c
# These tests are quite insufficient, but perhaps better than nothing for now.
check: all

View File

@ -0,0 +1,15 @@
This package includes several programs to safely lock and unlock
files and mailboxes from the command line. These include:
lockfile-create
lockfile-remove
lockfile-touchlock
mail-lock
mail-unlock
mail-touchlock
These programs use liblockfile to perform the file locking and
unlocking, so they are guaranteed compatible with Debian's
file locking policies.
WWW: https://tracker.debian.org/pkg/lockfile-progs

View File

@ -0,0 +1,16 @@
@comment $FreeBSD$
bin/lockfile-check
bin/lockfile-create
bin/lockfile-remove
bin/lockfile-touch
bin/mail-lock
bin/mail-touchlock
bin/mail-unlock
man/man1/lockfile-check.1.gz
man/man1/lockfile-create.1.gz
man/man1/lockfile-progs.1.gz
man/man1/lockfile-remove.1.gz
man/man1/lockfile-touch.1.gz
man/man1/mail-lock.1.gz
man/man1/mail-touchlock.1.gz
man/man1/mail-unlock.1.gz