devel/meson: update to 0.58.1
Changes: https://mesonbuild.com/Release-notes-for-0-58-0.html Reported by: GitHub (watch releases) PR: 255550 Exp-run by: antoine Approved by: tcberner
This commit is contained in:
parent
0e39c83d51
commit
afb3593eef
22
audio/ncmpc/files/patch-doc_meson.build
Normal file
22
audio/ncmpc/files/patch-doc_meson.build
Normal file
@ -0,0 +1,22 @@
|
||||
Keep rsync optional with meson >= 0.58 after
|
||||
https://github.com/mesonbuild/meson/commit/80c89a650b6f
|
||||
|
||||
--- doc/meson.build.orig 2020-10-16 10:59:17 UTC
|
||||
+++ doc/meson.build
|
||||
@@ -18,6 +18,8 @@ if get_option('html_manual')
|
||||
install_dir: join_paths(get_option('datadir'), 'doc', meson.project_name()),
|
||||
)
|
||||
|
||||
+ rsync = find_program('rsync', required: false)
|
||||
+ if rsync.found()
|
||||
custom_target(
|
||||
'upload',
|
||||
input: sphinx_output,
|
||||
@@ -29,6 +31,7 @@ if get_option('html_manual')
|
||||
'--chmod=a+rX',
|
||||
],
|
||||
)
|
||||
+ endif
|
||||
endif
|
||||
|
||||
if get_option('manual')
|
@ -1,8 +1,7 @@
|
||||
# Created by: Ting-Wei Lan <lantw44@gmail.com>
|
||||
|
||||
PORTNAME= meson
|
||||
PORTVERSION= 0.57.1
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.58.1
|
||||
CATEGORIES= devel python
|
||||
MASTER_SITES= https://github.com/mesonbuild/${PORTNAME}/releases/download/${PORTVERSION}/
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1613827273
|
||||
SHA256 (meson-0.57.1.tar.gz) = 72e1c782ba9bda204f4a1ed57f98d027d7b6eb9414c723eebbd6ec7f1955c8a6
|
||||
SIZE (meson-0.57.1.tar.gz) = 1849222
|
||||
TIMESTAMP = 1623087375
|
||||
SHA256 (meson-0.58.1.tar.gz) = 3144a3da662fcf79f1e5602fa929f2821cba4eba28c2c923fe0a7d3e3db04d5d
|
||||
SIZE (meson-0.58.1.tar.gz) = 1896205
|
||||
|
@ -1,24 +0,0 @@
|
||||
From c24a0f852489124fa002bdc90b5753547899b1cb Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Krzysztof=20Ma=C5=82ysa?= <varqox@gmail.com>
|
||||
Date: Tue, 16 Feb 2021 18:46:06 +0100
|
||||
Subject: [PATCH] compilers: clang: Drop -Xclang before -fcolor-diagnostics
|
||||
flag
|
||||
|
||||
Using -Xclang -fcolor-diagnostics provides no advantage to using just -fcolor-diagnostics option and sometimes causes problems:
|
||||
* uncolored diagnostics on Arch Linux: https://bugs.archlinux.org/task/69662
|
||||
* simple problem with removing flag -fcolor-diagnostics: https://github.com/clangd/clangd/issues/279
|
||||
--- mesonbuild/compilers/mixins/clang.py.orig 2021-02-20 13:17:16 UTC
|
||||
+++ mesonbuild/compilers/mixins/clang.py
|
||||
@@ -29,9 +29,9 @@ if T.TYPE_CHECKING:
|
||||
from ...dependencies import Dependency # noqa: F401
|
||||
|
||||
clang_color_args = {
|
||||
- 'auto': ['-Xclang', '-fcolor-diagnostics'],
|
||||
- 'always': ['-Xclang', '-fcolor-diagnostics'],
|
||||
- 'never': ['-Xclang', '-fno-color-diagnostics'],
|
||||
+ 'auto': ['-fcolor-diagnostics'],
|
||||
+ 'always': ['-fcolor-diagnostics'],
|
||||
+ 'never': ['-fno-color-diagnostics'],
|
||||
} # type: T.Dict[str, T.List[str]]
|
||||
|
||||
clang_optimization_args = {
|
@ -1,13 +1,13 @@
|
||||
https://github.com/mesonbuild/meson/pull/4324
|
||||
|
||||
--- run_unittests.py.orig 2019-10-06 17:01:35 UTC
|
||||
--- run_unittests.py.orig 2021-05-02 09:37:39 UTC
|
||||
+++ run_unittests.py
|
||||
@@ -5680,7 +5703,7 @@ c = ['{0}']
|
||||
@@ -7840,7 +7840,7 @@ class LinuxlikeTests(BasePlatformTests):
|
||||
# Test that installed libraries works
|
||||
self.new_builddir()
|
||||
self.prefix = oldprefix
|
||||
- meson_args = ['-Dc_link_args=-L{}'.format(libdir),
|
||||
+ meson_args = ['-Dc_link_args=-L{} -Wl,-rpath,{}'.format(libdir, libdir),
|
||||
- meson_args = [f'-Dc_link_args=-L{libdir}',
|
||||
+ meson_args = [f'-Dc_link_args=-L{libdir} -Wl,-rpath,{libdir}',
|
||||
'--fatal-meson-warnings']
|
||||
testdir = os.path.join(self.unit_test_dir, '69 static link')
|
||||
testdir = os.path.join(self.unit_test_dir, '67 static link')
|
||||
env = {'PKG_CONFIG_LIBDIR': os.path.join(libdir, 'pkgconfig')}
|
||||
|
@ -1,3 +1,6 @@
|
||||
- Keep graphviz optional with meson >= 0.58 after
|
||||
https://github.com/mesonbuild/meson/commit/80c89a650b6f
|
||||
|
||||
--- docs/reference/libnice/meson.build.orig 2020-11-25 16:39:27 UTC
|
||||
+++ docs/reference/libnice/meson.build
|
||||
@@ -26,7 +26,7 @@ ignore_headers = [
|
||||
@ -9,3 +12,17 @@
|
||||
fake_makefile = custom_target ('libnice-docs-test-Makefile',
|
||||
output: 'Makefile',
|
||||
command: [
|
||||
@@ -67,6 +67,8 @@ gnome.gtkdoc('libnice',
|
||||
# If we ever need to regenerate this diagram.
|
||||
# Since it’s not expected to change much, let’s not depend on GraphViz to
|
||||
# build the docs (that's also why we don't use find_program('dot') here)
|
||||
+dot = find_program('dot', required: false)
|
||||
+if dot.found()
|
||||
run_target('update-states.png',
|
||||
command: ['dot',
|
||||
'-Tpng',
|
||||
@@ -74,3 +76,4 @@ run_target('update-states.png',
|
||||
'-Gsize=9.6,2.9!',
|
||||
'-Gdpi=200',
|
||||
files('states.gv')])
|
||||
+endif
|
||||
|
Loading…
Reference in New Issue
Block a user