emulators/aqemu: updating to version 0.9.2

Submitted by:	Le Baron d'Merde <lbdm@privacychain.ch>
Differential Revision:	https://reviews.freebsd.org/D13704
This commit is contained in:
Steve Wills 2018-01-13 01:18:32 +00:00
parent ec1a47a286
commit af6e3d306f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=458888
8 changed files with 50 additions and 90 deletions

View File

@ -1,22 +1,23 @@
# $FreeBSD$
PORTNAME= aqemu
PORTVERSION= 0.8.2
PORTREVISION= 3
DISTVERSIONPREFIX= v
DISTVERSION= 0.9.2
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:S,.0$,,}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Qt 4 based Qemu frontend
COMMENT= Qt5 based QEMU frontend
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libvncclient.so:net/libvncserver
USE_QT4= corelib gui network qtestlib xml linguisttools_build \
moc_build qmake_build rcc_build uic_build
USES= cmake tar:bzip2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S,.0$,,}
USES= cmake:noninja
USE_QT5= buildtools_build linguisttools_build qmake_build \
core dbus gui network printsupport testlib widgets
USE_GITHUB= yes
GH_ACCOUNT= tobimensch
.include <bsd.port.mk>

View File

@ -1,2 +1,3 @@
SHA256 (aqemu-0.8.2.tar.bz2) = 03c4a95328f78238021168ca4887f9735641f10eb4eb1eff58b08c15b748bf03
SIZE (aqemu-0.8.2.tar.bz2) = 1025129
TIMESTAMP = 1514676669
SHA256 (tobimensch-aqemu-v0.9.2_GH0.tar.gz) = e3d54de00ebdce3754f97f7e0e7cce8cebb588e8ce6bc249401cc909281b08de
SIZE (tobimensch-aqemu-v0.9.2_GH0.tar.gz) = 1373465

View File

@ -1,22 +1,16 @@
The libvncclient target was removed because it was not used anywhere (aqemu
links against the systems libvncclient.so, only the definitions and includes
are needed from this block) and did not declare its dependency on the moc and
ui files, possibly causing problems in parallel builds.
--- CMakeLists.txt.orig 2011-01-14 19:38:53 UTC
--- CMakeLists.txt.orig 2017-12-31 01:02:19 UTC
+++ CMakeLists.txt
@@ -164,7 +164,6 @@ IF( NOT WITHOUT_EMBEDDED_DISPLAY )
Embedded_Display/vncclientthread.cpp Embedded_Display/vncview.cpp )
ADD_DEFINITIONS( -DVNC_DISPLAY -DQTONLY )
- ADD_LIBRARY( libvncclient SHARED ${aqemu_headers} ${aqemu_sources} )
INCLUDE_DIRECTORIES( ${VNCCLIENT_INCLUDE_DIRS} ${LIBVNCCLIENT_INCLUDE_DIR} )
ENDIF( NOT WITHOUT_EMBEDDED_DISPLAY )
@@ -318,6 +317,6 @@ IF( INSTALL_MAN )
@@ -327,11 +327,11 @@ IF( INSTALL_MAN )
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR} )
# Install MAN
- INSTALL( FILES ${CMAKE_SOURCE_DIR}/${aqemu_man_page}.${COMPRESSOR_SUFFIX} DESTINATION share/man/man1 )
+ INSTALL( FILES ${CMAKE_SOURCE_DIR}/${aqemu_man_page}.${COMPRESSOR_SUFFIX} DESTINATION man/man1 )
ELSE( COMPRESSOR_SUFFIX )
MESSAGE( STATUS "MAN_PAGE_COMPRESSOR flag not set. Available values: gzip, bzip2, lzma" )
MESSAGE( STATUS "Will be installed not compressed MAN pages" )
- INSTALL( FILES ${CMAKE_SOURCE_DIR}/aqemu.1 DESTINATION share/man/man1 )
+ INSTALL( FILES ${CMAKE_SOURCE_DIR}/aqemu.1 DESTINATION man/man1 )
- INSTALL( FILES ${CMAKE_SOURCE_DIR}/${aqemu_man_page} DESTINATION share/man/man1 )
+ INSTALL( FILES ${CMAKE_SOURCE_DIR}/${aqemu_man_page} DESTINATION man/man1 )
ENDIF( COMPRESSOR_SUFFIX )
ENDIF( INSTALL_MAN )

View File

@ -1,26 +0,0 @@
--- Embedded_Display/vncview.cpp.orig 2010-02-26 13:40:40 UTC
+++ Embedded_Display/vncview.cpp
@@ -23,6 +23,11 @@
#include "vncview.h"
+#include <QApplication>
+#include <QImage>
+#include <QPainter>
+#include <QMouseEvent>
+
#ifdef QTONLY
#include <QMessageBox>
#include <QInputDialog>
@@ -38,11 +43,6 @@
#include <KXMLGUIClient>
#endif
-#include <QApplication>
-#include <QImage>
-#include <QPainter>
-#include <QMouseEvent>
-
// Definition of key modifier mask constants
#define KMOD_Alt_R 0x01
#define KMOD_Alt_L 0x02

View File

@ -1,20 +0,0 @@
--- VM.cpp.orig 2011-07-26 19:36:32 UTC
+++ VM.cpp
@@ -4563,7 +4563,7 @@ bool Virtual_Machine::Load_VM( const QSt
else
AQError( "bool Virtual_Machine::Load_VM( const QString &file_name )", "SPICE image compression type invalid!" );
- SPICE.Use_Video_Stream_Compression( Second_Element.firstChildElement( ! "Use_Video_Stream_Compression" ).text() == "false" );
+ SPICE.Use_Video_Stream_Compression( ! (Second_Element.firstChildElement( "Use_Video_Stream_Compression" ).text() == "false") );
SPICE.Use_Renderer( Second_Element.firstChildElement( "Use_Renderer" ).text() == "true" );
@@ -4595,7 +4595,7 @@ bool Virtual_Machine::Load_VM( const QSt
SPICE.Set_Renderer_List( rendererList );
}
- SPICE.Use_Playback_Compression( Second_Element.firstChildElement( ! "Use_Playback_Compression" ).text() == "false" );
+ SPICE.Use_Playback_Compression( ! (Second_Element.firstChildElement( "Use_Playback_Compression" ).text() == "false") );
SPICE.Use_Password( Second_Element.firstChildElement( "Use_Password" ).text() == "true" );

View File

@ -1,6 +1,6 @@
--- System_Info.cpp.orig 2011-07-26 19:34:58 UTC
+++ System_Info.cpp
@@ -20,6 +20,7 @@
--- src/System_Info.cpp.orig 2017-12-31 00:45:58 UTC
+++ src/System_Info.cpp
@@ -21,6 +21,7 @@
**
****************************************************************************/

View File

@ -1,4 +1,5 @@
AQEMU is a QEMU GUI written in Qt4. The program have user-friendly
interface and allows to set up the majority of QEMU options.
AQEMU is a Qt5 GUI for virtual machines using QEMU as the backend.
The application has a user-friendly interface and allows to set a
large number of options.
WWW: https://sourceforge.net/projects/aqemu/
WWW: https://github.com/tobimensch/aqemu

View File

@ -1,31 +1,37 @@
bin/aqemu
man/man1/aqemu.1.gz
share/applications/aqemu.desktop
%%DATADIR%%/English.qm
%%DATADIR%%/French.qm
%%DATADIR%%/German.qm
%%DATADIR%%/Russian.qm
%%DATADIR%%/Ukrainian.qm
%%DATADIR%%/aqemu_links.html
%%DATADIR%%/crystalsvg_icons.rcc
%%DATADIR%%/docs/links.html
%%DATADIR%%/icons.rcc
%%DATADIR%%/os_icons/alt.png
%%DATADIR%%/os_icons/aptosid.png
%%DATADIR%%/os_icons/arch.png
%%DATADIR%%/os_icons/asp.png
%%DATADIR%%/os_icons/bodhi.png
%%DATADIR%%/os_icons/calculate.png
%%DATADIR%%/os_icons/centos.png
%%DATADIR%%/os_icons/chakra.png
%%DATADIR%%/os_icons/clearos.png
%%DATADIR%%/os_icons/damnsmalllinux.png
%%DATADIR%%/os_icons/debian.png
%%DATADIR%%/os_icons/dragonfly.png
%%DATADIR%%/os_icons/fedora.png
%%DATADIR%%/os_icons/freebsd.png
%%DATADIR%%/os_icons/frugalware.png
%%DATADIR%%/os_icons/fuduntu.png
%%DATADIR%%/os_icons/gentoo.png
%%DATADIR%%/os_icons/gnewsense.png
%%DATADIR%%/os_icons/knoppix.png
%%DATADIR%%/os_icons/knoppix_v2.png
%%DATADIR%%/os_icons/kubuntu.png
%%DATADIR%%/os_icons/kubuntu_v2.png
%%DATADIR%%/os_icons/lubuntu.png
%%DATADIR%%/os_icons/lunar.png
%%DATADIR%%/os_icons/mac.png
%%DATADIR%%/os_icons/mageia.png
%%DATADIR%%/os_icons/mandriva.png
%%DATADIR%%/os_icons/mepis.png
%%DATADIR%%/os_icons/minix.png
%%DATADIR%%/os_icons/mint.png
%%DATADIR%%/os_icons/netbsd.png
%%DATADIR%%/os_icons/novell.png
@ -35,6 +41,7 @@ share/applications/aqemu.desktop
%%DATADIR%%/os_icons/puppy.png
%%DATADIR%%/os_icons/redhat.png
%%DATADIR%%/os_icons/sabayon.png
%%DATADIR%%/os_icons/scientific.png
%%DATADIR%%/os_icons/slackware.png
%%DATADIR%%/os_icons/slackware_v2.png
%%DATADIR%%/os_icons/solaris.png
@ -43,6 +50,7 @@ share/applications/aqemu.desktop
%%DATADIR%%/os_icons/symphony.png
%%DATADIR%%/os_icons/ubuntu.png
%%DATADIR%%/os_icons/ubuntu_v2.png
%%DATADIR%%/os_icons/vector.png
%%DATADIR%%/os_icons/xubuntu.png
%%DATADIR%%/os_templates/FreeBSD 4.aqvmt
%%DATADIR%%/os_templates/FreeBSD 7.aqvmt
@ -60,10 +68,11 @@ share/applications/aqemu.desktop
%%DATADIR%%/os_templates/Windows Vista.aqvmt
%%DATADIR%%/os_templates/Windows XP x64.aqvmt
%%DATADIR%%/os_templates/Windows XP.aqvmt
%%DATADIR%%/oxygen_icons.rcc
%%DOCSDIR%%/AUTHORS.bz2
%%DOCSDIR%%/CHANGELOG.bz2
%%DOCSDIR%%/README.bz2
%%DOCSDIR%%/TODO.bz2
%%DATADIR%%/shared_images.rcc
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.bz2
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG.bz2
%%PORTDOCS%%%%DOCSDIR%%/README.bz2
%%PORTDOCS%%%%DOCSDIR%%/TODO.bz2
share/pixmaps/aqemu.png
share/pixmaps/aqemu_48x48.png
share/pixmaps/aqemu_64x64.png