Add new port games/searchandrescue:

This is a 3D flight simulator in which the player flies around
the map rescuing people. The game has a selection of several different
helicoptors and a jet airplane to choose from. The game includes
training missions, more complete missions and a campaign mode as
well as a free flight option for people who just want to explore.

WWW:	http://searchandrescue.sourceforge.net/

PR:		based on ports/148292
Submitted by:	Jesse Smith <jessefrgsmith at yahoo.ca>
This commit is contained in:
Max Brazhnikov 2010-07-22 21:17:27 +00:00
parent e14a8ac90d
commit af327e27d3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=258073
6 changed files with 126 additions and 0 deletions

View File

@ -0,0 +1,47 @@
# New ports collection makefile for: SearchAndRescue
# Date created: 10 June 2010
# Whom: Jesse Smith <jessefrgsmith@yahoo.ca>
#
# $FreeBSD$
#
PORTNAME= SearchAndRescue
PORTVERSION= 1.0.0
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME:L}/Program/
MAINTAINER= jessefrgsmith@yahoo.ca
COMMENT= A flight simulator in which the player rescues people
RUN_DEPENDS= ${LOCALBASE}/share/searchandrescue/human.ini:${PORTSDIR}/games/searchandrescue-data
USE_SDL= mixer
USE_XORG= x11 xau xdmcp xext xmu xpm xxf86vm
USE_GL= glu
WRKSRC= ${WRKDIR}/${PORTNAME:L}_${PORTVERSION}
PLIST_FILES= bin/${PORTNAME} \
${DESKTOPDIR:S,${PREFIX}/,,}/${PORTNAME}.desktop \
share/pixmaps/${PORTNAME}.xpm
PLIST_DIRS= ${DESKTOPDIR:S,${PREFIX}/,,}
#Respect PREFIX, LOCALBASE, CC, etc.
post-patch:
${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g' \
-e 's,%%PREFIX%%,${PREFIX},g' \
${WRKSRC}/sar/config.h
${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' \
-e 's,/usr/local,${LOCALBASE},g' \
-e 's,/usr/X11R6,${LOCALBASE},g' \
-e '/^CFLAGS = /s,=,= ${CFLAGS},g' \
-e '/^CC = /s, = .*, = ${CC},' \
-e '/^CPP = /s, = .*, = ${CXX},' \
${WRKSRC}/sar/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sar/${PORTNAME} ${PREFIX}/bin
${MKDIR} ${DESKTOPDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop ${DESKTOPDIR}
${INSTALL_DATA} ${WRKSRC}/sar/icons/${PORTNAME}.xpm ${PREFIX}/share/pixmaps
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
MD5 (SearchAndRescue-1.0.0.tar.gz) = 3197fe440472e27d36477daaba3b1023
SHA256 (SearchAndRescue-1.0.0.tar.gz) = 5e88306c20e5595a1931b4358931c40bd1b318e3d2f54a797c4f8dd3253c3e5d
SIZE (SearchAndRescue-1.0.0.tar.gz) = 852443

View File

@ -0,0 +1,10 @@
--- ./SearchAndRescue.desktop.orig 2010-03-05 22:10:43.000000000 +0300
+++ ./SearchAndRescue.desktop 2010-07-22 23:03:07.163020299 +0400
@@ -2,6 +2,7 @@
Encoding=UTF-8
Name=Search and rescue
Exec=SearchAndRescue
+Icon=SearchAndRescue.xpm
Terminal=False
Type=Application
Categories=Game

View File

@ -0,0 +1,39 @@
--- ./sar/Makefile.orig 2010-06-04 04:33:22.000000000 +0400
+++ ./sar/Makefile 2010-07-20 23:58:53.189939887 +0400
@@ -1,12 +1,12 @@
# Platform Configurator generated Makefile
#
-PREFIX = /usr
+PREFIX = %%PREFIX%%
-CFLAGS = -Wall -O2 -funroll-loops -fomit-frame-pointer -ffast-math -finline-functions -fexpensive-optimizations -D__USE_BSD -DUSE_XSHM -DHAVE_MWMUTIL_H -DHAVE_LIBXPM -DHAVE_XF86_VIDMODE -Wno-write-strings -DHAVE_SDL_MIXER -I/usr/local/include
+CFLAGS = -Wall -O6 -funroll-loops -fomit-frame-pointer -ffast-math -D__USE_BSD -DUSE_XSHM -DHAVE_MWMUTIL_H -DHAVE_LIBXPM -DHAVE_XF86_VIDMODE -DHAVE_SDL_MIXER -I/usr/local/include
INC_DIRS =
-LIBS = -lm -lSM -lICE -lX11 -lXext -lXi -lXmu -lXpm -lXxf86vm -lGL -lGLU -lpthread -lSDL -lSDL_mixer
+LIBS = -lm -lSM -lICE -lX11 -lXext -lXmu -lXpm -lXxf86vm -lGL -lGLU -lSDL -lSDL_mixer
LIB_DIRS = -L/usr/X11R6/lib/ -L/usr/X11R6/lib/ -L/usr/X11R6/lib/
@@ -39,7 +39,7 @@
# Programs
LS = ls
-LSFLAGS = -s -h -c --color=auto
+LSFLAGS = -s -h -c
RM = rm
RMFLAGS = -f
@@ -56,9 +56,8 @@
@echo "Building program \"$(BIN)\"..."
postbuild:
- @echo "Build done. To install..."
- @echo "On Ubuntu and related distributions type \"sudo make install\"."
- @echo "On most other distributions, type \"su\" to gain root privileges and then type \"make install\"."
+ @echo "Build done."
+ @echo "To install, type \"su\" (to gain root privileges) and then type \"make install\"."
all: $(BIN)

View File

@ -0,0 +1,20 @@
--- ./sar/config.h.orig 2010-06-03 02:05:00.000000000 +0400
+++ ./sar/config.h 2010-07-22 23:21:05.772021076 +0400
@@ -477,7 +477,7 @@
#define SAR_DEF_LOCAL_DATA_DIR ".SearchAndRescue"
/* Global game dir */
-#define SAR_DEF_GLOBAL_DATA_DIR "/usr/share/games/searchandrescue"
+#define SAR_DEF_GLOBAL_DATA_DIR "%%LOCALBASE%%/share/searchandrescue"
/* Subdirs, one of each in the local and global game dirs */
#define SAR_DEF_AIRCRAFTS_DIR "aircrafts"
@@ -539,7 +539,7 @@
#ifdef __MSW__
# define SAR_DEF_SAR_ICON_FILE "SearchAndRescue.ico"
#else
-# define SAR_DEF_SAR_ICON_FILE "/usr/share/pixmaps/SearchAndRescue.xpm"
+# define SAR_DEF_SAR_ICON_FILE "%%PREFIX%%/share/pixmaps/SearchAndRescue.xpm"
#endif
/* Standard Texture Reference Names

View File

@ -0,0 +1,7 @@
This is a 3D flight simulator in which the player flies around
the map rescuing people. The game has a selection of several different
helicoptors and a jet airplane to choose from. The game includes
training missions, more complete missions and a campaign mode as
well as a free flight option for people who just want to explore.
WWW: http://searchandrescue.sourceforge.net/