- fix build with gcc46

This commit is contained in:
Dirk Meyer 2012-01-04 05:26:10 +00:00
parent 1c5d9b9f3f
commit af1e780abc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=288497
2 changed files with 23 additions and 0 deletions

View File

@ -25,4 +25,8 @@ USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
DEFAULT_LIBVERSION= 1.2
.if !defined(WITH_GNUSTEP_DEVEL)
EXTRA_PATCHES= ${FILESDIR}/NSString+Extensions.m.patch
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1,19 @@
--- Framework/Pantomime/NSString+Extensions.m.orig 2011-06-05 06:45:21.000000000 +0200
+++ Framework/Pantomime/NSString+Extensions.m 2012-01-02 22:46:00.000000000 +0100
@@ -38,7 +38,15 @@
#include <CoreFoundation/CFString.h>
#include <CoreFoundation/CFStringEncodingExt.h>
#else
-#include <GNUstepBase/Additions.h>
+#import <GNUstepBase/GSVersionMacros.h>
+#import <GNUstepBase/GNUstep.h>
+
+#import <GNUstepBase/GSFunctions.h>
+#import <GNUstepBase/GSLocale.h>
+#import <GNUstepBase/GSLock.h>
+#import <GNUstepBase/GSMime.h>
+#import <GNUstepBase/GSXML.h>
+#import <GNUstepBase/Unicode.h>
#endif
#include <ctype.h>