audio/audacity: Update to 2.2.2

Release notes:
http://wiki.audacityteam.org/wiki/Release_Notes_2.2.2

Port changes:
* Added to LIB_DEPENDS
* Removed ALSA option
* Corrected LV2 option, added option dependencies
* Use system libsoxr
* Updated WWW
* A lot of patch changes

PR:		226136
Submitted by:	xxjack12xx@gmail.com (maintainer)
Approved by:	tcberner (mentor, implicit)
This commit is contained in:
Yuri Victorovich 2018-03-01 10:22:46 +00:00
parent cfd695984e
commit aef08ccdca
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=463291
14 changed files with 100 additions and 133 deletions

View File

@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= audacity
PORTVERSION= 2.1.3
PORTVERSION= 2.2.2
DISTVERSIONPREFIX= Audacity-
PORTREVISION= 3
CATEGORIES= audio
MAINTAINER= xxjack12xx@gmail.com
@ -13,17 +12,19 @@ COMMENT= GUI editor for digital audio waveforms
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= autogen:devel/autogen \
bash:shells/bash \
cmake:devel/cmake
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libsndfile.so:audio/libsndfile
BROKEN_aarch64= fails to configure: checking whether C++ compiler accepts -msse... no
BROKEN_powerpc64= fails to build
GNU_CONFIGURE= yes
BUILD_DEPENDS= autogen:devel/autogen \
bash:shells/bash \
cmake:devel/cmake
LIB_DEPENDS= libasound.so:audio/alsa-lib \
libexpat.so:textproc/expat2 \
libsoxr.so:audio/libsoxr \
libsndfile.so:audio/libsndfile
USES= autoreconf compiler:c++11-lib cpe desktop-file-utils gettext-tools gmake iconv libtool pkgconfig shared-mime-info shebangfix dos2unix localbase
GNU_CONFIGURE= yes
NLS_USES= gettext-runtime
NLS_CONFIGURE_ENABLE= nls
NLS_CONFIGURE_WITH= libintl-prefix="${LOCALBASE}"
@ -36,7 +37,7 @@ DOS2UNIX_GLOB= Makefile.* *.c* *.h
SHEBANG_FILES= lib-src/lv2/build
USE_GITHUB= yes
OPTIONS_DEFINE= NLS DEBUG DOCS ALSA DYNLOAD FFMPEG FLAC ID3TAG LADSPA LAME LV2 \
OPTIONS_DEFINE= NLS DEBUG DOCS DYNLOAD FFMPEG FLAC ID3TAG LADSPA LAME LV2 \
MAD SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS VST
OPTIONS_DEFAULT= FLAC ID3TAG LADSPA MAD \
SBSMS SOUNDTOUCH TWOLAME VAMP VORBIS VST
@ -65,7 +66,7 @@ CONFIGURE_ARGS+= --disable-option-checking \
--with-lib-preference="local" \
--with-expat=system \
--with-libsndfile=system \
--with-libsoxr \
--with-libsoxr=system \
--with-midi \
--with-portaudio \
--with-portmixer=yes \
@ -78,13 +79,6 @@ DEBUG_CONFIGURE_WITH= debug
DOCS_BUILD_DEPENDS= docbook-to-man:textproc/docbook-to-man \
docbook2man:textproc/docbook-utils
ALSA_CONFIGURE_OFF= --disable-alsa
ALSA_CONFIGURE_WITH= alsa
ALSA_CFLAGS= -I${LOCALBASE}/include
ALSA_CXXFLAGS= -I${LOCALBASE}/include
ALSA_LDFLAGS= -L${LOCALBASE}/lib
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
DYNLOAD_BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/libavcodec.pc:multimedia/ffmpeg
DYNLOAD_BUILD_DEPENDS= ${LOCALBASE}/include/lame/lame.h:audio/lame
DYNLOAD_CONFIGURE_ENABLE= dynamic-loading
@ -114,7 +108,9 @@ LAME_CPPFLAGS= -I${LOCALBASE}/include
LAME_LDFLAGS= -L${LOCALBASE}/lib
LAME_LIB_DEPENDS= libmp3lame.so:audio/lame
LV2_CONFIGURE_WITH= lv2
LV2_CONFIGURE_WITH= lv2=system
LV2_LIB_DEPENDS= liblilv-0.so:audio/lilv \
libsuil-0.so:audio/suil
SBSMS_CONFIGURE_WITH= sbsms

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1496739477
SHA256 (audacity-audacity-Audacity-2.1.3_GH0.tar.gz) = cb30870b93c7f6f90b2ec70807ab6dcd9c3a3a29015478ae7b19af46d63bbd86
SIZE (audacity-audacity-Audacity-2.1.3_GH0.tar.gz) = 24106855
TIMESTAMP = 1519297034
SHA256 (audacity-audacity-Audacity-2.2.2_GH0.tar.gz) = 759e8efd5e4ff6cc2fdd31b36bc631307330c1a6e2d3426e3f1d46ebcf8907a3
SIZE (audacity-audacity-Audacity-2.2.2_GH0.tar.gz) = 25947462

View File

@ -1,12 +1,12 @@
--- configure.ac.orig 2016-01-08 22:05:48 UTC
--- configure.ac.orig 2016-01-08 22:05:48 UTC
+++ configure.ac
@@ -235,20 +236,7 @@
@@ -235,20 +235,7 @@
dnl Solaris builds, by defining HAVE_ALLOCA_H
AC_CHECK_HEADERS_ONCE(alloca.h)
-
-dnl Enable C++ 11 support. Use gnu++11 on GCC since wxWidgets uses extensions
-if test "${ax_cv_c_compiler_vendor}" = "gnu"; then
-if "${CXX}" -v 2>&1 | grep -q '^gcc version'; then
-
- dnl GCC < 4.9 has known bugs (#1397) and can't be used
- AX_GCC_VERSION_ATLEAST(4,9,0,[gcc_ok=yes], [gcc_ok=no])

View File

@ -1,10 +1,10 @@
--- include/audacity/Types.h.orig 2017-03-13 21:02:21 UTC
--- include/audacity/Types.h.orig 2017-03-13 21:02:21 UTC
+++ include/audacity/Types.h
@@ -70,7 +70,7 @@ public:
sampleCount ( int v ) : value { v } {}
sampleCount ( unsigned v ) : value { v } {}
@@ -72,7 +72,7 @@
sampleCount ( long v ) : value { v } {}
- sampleCount ( unsigned long v ) : value { v } {}
// unsigned long is 64 bit on some platforms. Let it narrow.
- sampleCount ( unsigned long v ) : value ( v ) {}
+ sampleCount ( unsigned long v ) : value { static_cast<type>(v) } {}
// Beware implicit conversions from floating point values!

View File

@ -1,33 +0,0 @@
--- lib-src/libmad/configure.ac.orig 2016-01-08 22:05:48 UTC
+++ lib-src/libmad/configure.ac
@@ -141,22 +141,25 @@ then
case "$optimize" in
-O|"-O "*)
+dnl (using audio/libmad/files/patch-configure as reference)
+AC_PROG_GREP
+AS_IF([$CC -v 2>&1 | $GREP -q clang], [CLANG=yes], [CLANG=])
optimize="-O"
: #x optimize="$optimize -fforce-mem"
: #x optimize="$optimize -fforce-addr"
: #x optimize="$optimize -finline-functions"
: #- optimize="$optimize -fstrength-reduce"
- optimize="$optimize -fthread-jumps"
- optimize="$optimize -fcse-follow-jumps"
- optimize="$optimize -fcse-skip-blocks"
+ if @<:@ x$CLANG != xyes @:>@ ; then optimize="$optimize -fthread-jumps" ; fi
+ if @<:@ x$CLANG != xyes @:>@ ; then optimize="$optimize -fcse-follow-jumps" ; fi
+ if @<:@ x$CLANG != xyes @:>@ ; then optimize="$optimize -fcse-skip-blocks" ; fi
: #x optimize="$optimize -frerun-cse-after-loop"
: #x optimize="$optimize -frerun-loop-opt"
: #x optimize="$optimize -fgcse"
optimize="$optimize -fexpensive-optimizations"
- optimize="$optimize -fregmove"
+ if @<:@ x$CLANG != xyes @:>@ ; then optimize="$optimize -fregmove" ; fi
: #* optimize="$optimize -fdelayed-branch"
: #x optimize="$optimize -fschedule-insns"
- optimize="$optimize -fschedule-insns2"
+ if @<:@ x$CLANG != xyes @:>@ ; then optimize="$optimize -fschedule-insns2" ; fi
: #? optimize="$optimize -ffunction-sections"
: #? optimize="$optimize -fcaller-saves"
: #> optimize="$optimize -funroll-loops"

View File

@ -0,0 +1,42 @@
--- lib-src/portmidi/porttime/ptlinux.c.orig 2018-02-22 17:57:15.438232000 -0800
+++ lib-src/portmidi/porttime/ptlinux.c 2018-02-22 19:12:15.820418000 -0800
@@ -31,14 +31,13 @@
#include "porttime.h"
#include "sys/time.h"
#include "sys/resource.h"
-#include "sys/timeb.h"
#include "pthread.h"
#define TRUE 1
#define FALSE 0
static int time_started_flag = FALSE;
-static struct timeb time_offset = {0, 0, 0, 0};
+static struct timeval time_offset = {0};
static pthread_t pt_thread_pid;
static int pt_thread_created = FALSE;
@@ -79,7 +78,7 @@
PtError Pt_Start(int resolution, PtCallback *callback, void *userData)
{
if (time_started_flag) return ptNoError;
- ftime(&time_offset); /* need this set before process runs */
+ gettimeofday(&time_offset, 0);
if (callback) {
int res;
pt_callback_parameters *parms = (pt_callback_parameters *)
@@ -121,10 +120,10 @@
PtTimestamp Pt_Time()
{
long seconds, milliseconds;
- struct timeb now;
- ftime(&now);
- seconds = now.time - time_offset.time;
- milliseconds = now.millitm - time_offset.millitm;
+ struct timeval now;
+ gettimeofday(&now, 0);
+ seconds = now.tv_sec - time_offset.tv_sec;
+ milliseconds = (now.tv_usec / 1000) - (time_offset.tv_usec / 1000);
return seconds * 1000 + milliseconds;
}

View File

@ -1,32 +0,0 @@
--- lib-src/portmixer/configure.ac.orig 2016-01-08 22:05:48 UTC
+++ lib-src/portmixer/configure.ac
@@ -35,6 +35,9 @@ AC_ARG_ENABLE([debug],
[AC_SUBST( cflags, ["$cflags -g"] ) AC_MSG_RESULT(yes)],
[AC_SUBST( cflags, ["$cflags -O2"] ) AC_MSG_RESULT(no)])
+AC_ARG_ENABLE([alsa],
+ AC_HELP_STRING([--disable-alsa], []))
+
PKG_CHECK_MODULES([PORTAUDIO], [portaudio-2.0 >= 19])
#
@@ -43,7 +46,7 @@ PKG_CHECK_MODULES([PORTAUDIO], [portaudi
dnl The following tests need to have the header files of portaudio available.
cppflags_save="$CPPFLAGS"
-CPPFLAGS="$CPPFLAGS $PORTAUDIO_CFLAGS"
+CPPFLAGS="$PORTAUDIO_CFLAGS $CPPFLAGS"
have_oss=no
AC_CHECK_HEADERS([sys/soundcard.h linux/soundcard.h machine/soundcard.h], have_oss=yes)
@@ -123,8 +126,8 @@ if [[ $have_oss = "yes" ]] ; then
have_support=yes
fi
-AM_CONDITIONAL([USE_LINUX_ALSA], [test "$have_alsa" = yes])
-if [[ $have_alsa = "yes" ]] ; then
+AM_CONDITIONAL([USE_LINUX_ALSA], [test "$have_alsa" = yes -a "x$enable_alsa" != "xno"])
+if [[ $have_alsa = "yes" -a "x$enable_alsa" != "xno" ]] ; then
AC_MSG_NOTICE([Including support for ALSA])
AC_DEFINE(PX_USE_LINUX_ALSA)
have_support=yes

View File

@ -1,10 +0,0 @@
--- lib-src/portmixer/src/px_linux_alsa.c.orig 2016-07-26 13:34:06 UTC
+++ lib-src/portmixer/src/px_linux_alsa.c
@@ -42,6 +42,7 @@
#include "portaudio.h"
#include "pa_unix_oss.h"
+#include <pa_linux_alsa.h>
#include "portmixer.h"
#include "px_mixer.h"

View File

@ -1,16 +0,0 @@
--- src/Audacity.h.orig 2017-06-16 13:26:40 UTC
+++ src/Audacity.h
@@ -24,13 +24,6 @@
#ifndef __AUDACITY_H__
#define __AUDACITY_H__
-// If building with GNU compiler, then must be 4.9 or later.
-// TODO: This would be much nicer as a standalone test in configure.ac
-#if !defined(__APPLE__) && defined __GNUC__ && ( __GNUC__ < 4 || (__GNUC__ == 4 && __GNUC_MINOR__ < 9))
-#error insufficient compiler
-#endif
-
-
// We only do alpha builds and release versions.
// Most of the time we're in development, so IS_ALPHA should be defined
// to 1.

View File

@ -0,0 +1,11 @@
--- src/AudioIO.cpp.orig 2018-02-22 14:12:03.835431000 -0800
+++ src/AudioIO.cpp 2018-02-22 14:01:49.487127000 -0800
@@ -985,7 +985,7 @@
if (usingAlsa) {
struct timespec now;
// CLOCK_MONOTONIC_RAW is unaffected by NTP or adj-time
- clock_gettime(CLOCK_MONOTONIC_RAW, &now);
+ clock_gettime(CLOCK_REALTIME, &now);
//return now.tv_sec + now.tv_nsec * 0.000000001;
return (now.tv_sec + now.tv_nsec * 0.000000001) - streamStartTime;
}

View File

@ -1,11 +0,0 @@
--- src/BatchCommands.cpp.orig 2016-07-26 13:34:06 UTC
+++ src/BatchCommands.cpp
@@ -151,7 +151,7 @@ bool BatchCommands::ReadChain(const wxSt
else if (cmd == wxT("ExportWav"))
cmd = wxT("ExportWAV");
else if (cmd == wxT("Compressor") && (parm.find(wxT("DecayTime")) != parm.npos))
- parm.Replace(wxT("DecayTime"), wxT("ReleaseTime"), NULL); // 2.0.6
+ parm.Replace(wxT("DecayTime"), wxT("ReleaseTime"), false); // 2.0.6
// Add to lists
mCommandChain.Add(cmd);

View File

@ -0,0 +1,19 @@
--- src/MemoryX.h.orig 2018-02-22 14:12:04.240599000 -0800
+++ src/MemoryX.h 2018-02-22 14:01:53.685861000 -0800
@@ -1,6 +1,7 @@
#ifndef __AUDACITY_MEMORY_X_H__
#define __AUDACITY_MEMORY_X_H__
+#include <stdlib.h>
// C++ standard header <memory> with a few extensions
#include <memory>
#ifndef safenew
@@ -1171,7 +1172,7 @@
namespace tr1
{
#endif
- template<typename T> struct hash;
+ //template<typename T> struct hash;
template<> struct hash< wxString > {
size_t operator () (const wxString &str) const // noexcept
{

View File

@ -8,4 +8,4 @@ also has a built-in amplitude envelope editor, a customizable
spectrogram mode and a frequency analysis window for audio
analysis applications.
WWW: http://audacityteam.org/
WWW: https://www.audacityteam.org/

View File

@ -100,6 +100,7 @@ share/icons/hicolor/scalable/apps/audacity.svg
%%NLS%%share/locale/el/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/es/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/eu/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/eu_ES/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/fa/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/fi/LC_MESSAGES/audacity.mo
%%NLS%%share/locale/fr/LC_MESSAGES/audacity.mo