www/py-django-dpaste: Update to 2.10

- Update PORTVERSION and distinfo checksum (2.10)
- Switch MASTER_SITES to CHEESESHOP (PyPI)
- Update RUN_DEPENDS
- Mark architecture independent (NO_ARCH)
- Patch setup.py/runtests.py so standard test methods work. Tox isn't required.
- Modernize test target (do-test: setup.py.test)


  https://github.com/bartTC/dpaste/blob/v2.10/CHANGELOG
This commit is contained in:
Kubilay Kocak 2016-08-15 04:57:48 +00:00
parent 1ff5c9e049
commit aeea74f55f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=420214
4 changed files with 55 additions and 9 deletions

View File

@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= dpaste
PORTVERSION= 2.9
PORTREVISION= 1
PORTVERSION= 2.10
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}django-
MAINTAINER= koobs@FreeBSD.org
@ -14,7 +14,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/django/bin/django-admin.py:www/py-django18 \
${PYTHON_PKGNAMEPREFIX}django-mptt>=0.7.4:www/py-django-mptt \
${PYTHON_PKGNAMEPREFIX}django-mptt>=0.8.3:www/py-django-mptt \
${PYTHON_PKGNAMEPREFIX}pygments>=1.6:textproc/py-pygments \
${PYTHON_PKGNAMEPREFIX}requests>=2.0.0:www/py-requests
@ -25,12 +25,11 @@ MIGRATIONS_DESC= Schema and data migration support (via south)
MIGRATIONS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}south>=0.8.2:databases/py-south
USES= python
USE_GITHUB= yes
USE_PYTHON= autoplist distutils
GH_ACCOUNT= bartTC
NO_ARCH= yes
regression-test: build
@cd ${WRKSRC} && ${PYTHON_CMD} runtests.py
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>

View File

@ -1,2 +1,3 @@
SHA256 (bartTC-dpaste-2.9_GH0.tar.gz) = 1e8d44619cf7fba61a3771783890f304bee98e2fc5ccba2cea14766bd008deba
SIZE (bartTC-dpaste-2.9_GH0.tar.gz) = 147108
TIMESTAMP = 1471231865
SHA256 (dpaste-2.10.tar.gz) = 6b24217865194c7a3036cd4f50d12a5f11de28b879ac74593aff810bb89a5d58
SIZE (dpaste-2.10.tar.gz) = 128149

View File

@ -0,0 +1,12 @@
--- runtests.py.orig 2016-08-15 03:40:49 UTC
+++ runtests.py
@@ -63,8 +63,7 @@ def runtests(*test_args):
test_runner = TestRunner(verbosity=1)
failures = test_runner.run_tests(['dpaste'])
- if failures:
- sys.exit(failures)
+ sys.exit(failures)
if __name__ == '__main__':
runtests(*sys.argv[1:])

View File

@ -0,0 +1,34 @@
--- setup.py.orig 2016-08-15 03:37:55 UTC
+++ setup.py
@@ -4,19 +4,6 @@ from sys import exit
from setuptools import find_packages, setup
from setuptools.command.test import test as TestCommand
-
-class Tox(TestCommand):
- def finalize_options(self):
- TestCommand.finalize_options(self)
- self.test_args = []
- self.test_suite = True
-
- def run_tests(self):
- #import here, cause outside the eggs aren't loaded
- import tox
- errno = tox.cmdline(self.test_args)
- exit(errno)
-
long_description = u'\n\n'.join((
open('README.rst').read(),
open('CHANGELOG').read()
@@ -54,10 +41,5 @@ setup(
'pygments>=1.6',
'requests>=2.0.0',
],
- tests_require=[
- 'tox>=1.6.1'
- ],
- cmdclass={
- 'test': Tox
- },
+ test_suite='runtests.runtests',
)