- Update to 0.93

- More helpful BROKEN-message

PR:		ports/75989
Submitted by:	Xin LI (maintainer)
This commit is contained in:
Volker Stolz 2005-02-13 16:21:48 +00:00
parent a5860aa97a
commit aee83933eb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=128704
10 changed files with 48 additions and 30 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= gps
PORTVERSION= 0.9
PORTVERSION= 0.93
CATEGORIES= mail security
MASTER_SITES= http://mimo.gn.apc.org/gps/
PKGNAMEPREFIX= postfix-
@ -17,7 +17,7 @@ EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= delphij@FreeBSD.org
COMMENT= Greylist Policy Service for postfix
BROKEN= Broken dependency
BROKEN= databases/libdbi-drivers package build does not build necessary files yet
LIB_DEPENDS= dbi.0:${PORTSDIR}/databases/libdbi
RUN_DEPENDS= ${LOCALBASE}/lib/dbd:${PORTSDIR}/databases/libdbi-drivers
@ -28,7 +28,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_AUTOCONF_VER= 259
USE_AUTOMAKE_VER= 19
USE_GCC= 3.3
USE_GCC= 3.4
CONFIGURE_ARGS= --bindir=${PREFIX}/libexec --includedir=${PREFIX}/include
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${PREFIX}/include" \
CXXFLAGS="${CXXFLAGS} -I${PREFIX}/include" \
@ -41,6 +41,6 @@ post-install:
.for f in ${SCRIPT_FILES}
@${INSTALL_SCRIPT} ${_DISTDIR}/${f} ${PREFIX}/libexec
.endfor
@${PAGER} pkg-message
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -1,4 +1,4 @@
MD5 (gps-0.9.tar.gz) = a5ede393225b799a855fd91e5d017c57
SIZE (gps-0.9.tar.gz) = 321568
MD5 (gps-0.93.tar.gz) = cd12ea6ca4b4bea06690a3356aabd7b2
SIZE (gps-0.93.tar.gz) = 338790
MD5 (gps-maintain.pl) = e42d47d0b093d54277de826f24ccb1bd
SIZE (gps-maintain.pl) = 3502

View File

@ -1,9 +1,9 @@
--- src/Makefile.am.orig Wed Sep 15 05:25:25 2004
+++ src/Makefile.am Mon Sep 20 01:49:53 2004
@@ -7,5 +7,5 @@
# the library search path.
gps_LDFLAGS = $(all_libraries)
noinst_HEADERS = configreader.h db.h read.h triplet.h defs.h strtrim.h cfg.h wlmodule.h wldb.h tmplwlmod.h dbdefs.h doxygen.h wlcacheddb.h dbiquote.h
-gps_LDADD = -ldbi -ldl
+gps_LDADD = -ldbi
--- src/Makefile.am.orig Sun Nov 21 01:41:36 2004
+++ src/Makefile.am Sun Jan 9 16:45:10 2005
@@ -9,5 +9,5 @@
noinst_HEADERS = configreader.h db.h read.h triplet.h defs.h strtrim.h cfg.h \
wlmodule.h wldb.h tmplwlmod.h dbdefs.h doxygen.h wlcacheddb.h dbiquote.h \
regexcpp.h pmatcher.h action.h
-gps_LDADD = -lpthread -ldbi -ldl
+gps_LDADD = -ldbi ${PTHREAD_LIBS}
METASOURCES = AUTO

View File

@ -0,0 +1,10 @@
--- src/pmatcher.h.orig Sun Nov 21 05:37:49 2004
+++ src/pmatcher.h Sun Jan 9 16:50:54 2005
@@ -24,6 +24,7 @@
#include <string>
//getnameinfo
#include <netdb.h>
+#include <sys/socket.h>
//
#include "regexcpp.h"
#include "triplet.h"

View File

@ -1,4 +1,3 @@
etc/gps.conf-dist
libexec/gps
libexec/gps-maintain.pl

View File

@ -6,7 +6,7 @@
#
PORTNAME= gps
PORTVERSION= 0.9
PORTVERSION= 0.93
CATEGORIES= mail security
MASTER_SITES= http://mimo.gn.apc.org/gps/
PKGNAMEPREFIX= postfix-
@ -17,7 +17,7 @@ EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= delphij@FreeBSD.org
COMMENT= Greylist Policy Service for postfix
BROKEN= Broken dependency
BROKEN= databases/libdbi-drivers package build does not build necessary files yet
LIB_DEPENDS= dbi.0:${PORTSDIR}/databases/libdbi
RUN_DEPENDS= ${LOCALBASE}/lib/dbd:${PORTSDIR}/databases/libdbi-drivers
@ -28,7 +28,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_AUTOCONF_VER= 259
USE_AUTOMAKE_VER= 19
USE_GCC= 3.3
USE_GCC= 3.4
CONFIGURE_ARGS= --bindir=${PREFIX}/libexec --includedir=${PREFIX}/include
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${PREFIX}/include" \
CXXFLAGS="${CXXFLAGS} -I${PREFIX}/include" \
@ -41,6 +41,6 @@ post-install:
.for f in ${SCRIPT_FILES}
@${INSTALL_SCRIPT} ${_DISTDIR}/${f} ${PREFIX}/libexec
.endfor
@${PAGER} pkg-message
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -1,4 +1,4 @@
MD5 (gps-0.9.tar.gz) = a5ede393225b799a855fd91e5d017c57
SIZE (gps-0.9.tar.gz) = 321568
MD5 (gps-0.93.tar.gz) = cd12ea6ca4b4bea06690a3356aabd7b2
SIZE (gps-0.93.tar.gz) = 338790
MD5 (gps-maintain.pl) = e42d47d0b093d54277de826f24ccb1bd
SIZE (gps-maintain.pl) = 3502

View File

@ -1,9 +1,9 @@
--- src/Makefile.am.orig Wed Sep 15 05:25:25 2004
+++ src/Makefile.am Mon Sep 20 01:49:53 2004
@@ -7,5 +7,5 @@
# the library search path.
gps_LDFLAGS = $(all_libraries)
noinst_HEADERS = configreader.h db.h read.h triplet.h defs.h strtrim.h cfg.h wlmodule.h wldb.h tmplwlmod.h dbdefs.h doxygen.h wlcacheddb.h dbiquote.h
-gps_LDADD = -ldbi -ldl
+gps_LDADD = -ldbi
--- src/Makefile.am.orig Sun Nov 21 01:41:36 2004
+++ src/Makefile.am Sun Jan 9 16:45:10 2005
@@ -9,5 +9,5 @@
noinst_HEADERS = configreader.h db.h read.h triplet.h defs.h strtrim.h cfg.h \
wlmodule.h wldb.h tmplwlmod.h dbdefs.h doxygen.h wlcacheddb.h dbiquote.h \
regexcpp.h pmatcher.h action.h
-gps_LDADD = -lpthread -ldbi -ldl
+gps_LDADD = -ldbi ${PTHREAD_LIBS}
METASOURCES = AUTO

View File

@ -0,0 +1,10 @@
--- src/pmatcher.h.orig Sun Nov 21 05:37:49 2004
+++ src/pmatcher.h Sun Jan 9 16:50:54 2005
@@ -24,6 +24,7 @@
#include <string>
//getnameinfo
#include <netdb.h>
+#include <sys/socket.h>
//
#include "regexcpp.h"
#include "triplet.h"

View File

@ -1,4 +1,3 @@
etc/gps.conf-dist
libexec/gps
libexec/gps-maintain.pl