The pftabled daemon is a small helper to make your pf

tables reachable from other hosts. You can add/delete/flush
IP addresses to/from a remote table with a single UDP
datagram. A simple client program is included to do this
from the command line.

WWW:	http://wolfermann.org/pftabled.html

PR:		ports/105713
Submitted by:	Bartlomiej Rutkowski <r at robakdesign.com>
This commit is contained in:
Martin Wilke 2006-11-23 12:02:29 +00:00
parent 6e65d26f6e
commit aec6dd3dc7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=177886
6 changed files with 82 additions and 0 deletions

View File

@ -162,6 +162,7 @@
SUBDIR += pads
SUBDIR += pancho
SUBDIR += pfpro
SUBDIR += pftabled
SUBDIR += php4-snmp
SUBDIR += php5-snmp
SUBDIR += pixilate

View File

@ -0,0 +1,31 @@
# New ports collection makefile for: pftabled
# Date created: 2006-11-21
# Whom: Bartlomiej Rutkowski <r@robakdesign.com>
#
# $FreeBSD$
#
PORTNAME= pftabled
PORTVERSION= 1.06
CATEGORIES= net-mgmt
MASTER_SITES= http://www.wolfermann.org/
MAINTAINER= r@robakdesign.com
COMMENT= The pftabled is a tool to manage your pf tables remotely
USE_RC_SUBR= pftabled
MAN1= pftabled.0
PLIST_FILES= bin/pftabled-client sbin/pftabled
GNU_CONFIGURE= yes
USE_GMAKE= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
BROKEN= Does not compile on 4.x
.endif
.include <bsd.port.post.mk>

View File

@ -0,0 +1,3 @@
MD5 (pftabled-1.06.tar.gz) = 27946f75ae8c5f93b8c0c9232215a21c
SHA256 (pftabled-1.06.tar.gz) = 46a82e70433fca3513600c1f70f7d9e488b8b756a3cfe124f32b103b79becc7b
SIZE (pftabled-1.06.tar.gz) = 45174

View File

@ -0,0 +1,11 @@
--- Makefile.in.orig Tue Nov 21 14:31:41 2006
+++ Makefile.in Tue Nov 21 14:33:13 2006
@@ -35,7 +35,7 @@
server-install: pftabled pftabled.cat1
${INSTALL} -s -m 555 pftabled ${sbindir}
- ${INSTALL} -m 444 pftabled.cat1 ${mandir}/cat1/pftabled.0
+ ${INSTALL} -m 444 pftabled.cat1 ${mandir}/man1/pftabled.0
client-install: pftabled-client
${INSTALL} -s -m 555 pftabled-client ${bindir}

View File

@ -0,0 +1,29 @@
#!/bin/sh
#
# $FreeBSD$
#
# PROVIDE: pftabled
# REQUIRE: NETWORKING SERVERS
# BEFORE: DAEMON
# KEYWORD: shutdown
#
# Add the following lines to /etc/rc.conf to enable pftabled:
# pftabled_enable (bool): Set it to "YES" to enable pftabled.
# Default is "NO".
# pftabled_flags (flags): Set flags to alter default behaviour of pftabled.
# Consult with the man page for more info.
#
. %%RC_SUBR%%
name="pftabled"
rcvar=${name}_enable
load_rc_config $name
: ${pftabled_enable="NO"}
: ${pftabled_flags=""}
command="%%PREFIX%%/sbin/${name}"
run_rc_command "$1"

View File

@ -0,0 +1,7 @@
The pftabled daemon is a small helper to make your pf
tables reachable from other hosts. You can add/delete/flush
IP addresses to/from a remote table with a single UDP
datagram. A simple client program is included to do this
from the command line.
WWW: http://wolfermann.org/pftabled.html