Disable sse on non-x86 architectures to fix build.

Approved by:	portmgr (tier-2 blanket)
This commit is contained in:
Mark Linimon 2019-03-06 18:41:08 +00:00
parent f1637728b0
commit aeb723dd90
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=494830
2 changed files with 18 additions and 1 deletions

View File

@ -29,4 +29,11 @@ MAKE_JOBS_UNSAFE= yes
CMAKE_ARGS= -DWITHOUT_EERIE:BOOL=ON
.include <bsd.port.mk>
.include <bsd.port.pre.mk>
# disable sse on non-x86 archs
.if ${ARCH} != amd64 && ${ARCH} != i386
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-CMakeLists.txt
.endif
.include <bsd.port.post.mk>

View File

@ -0,0 +1,10 @@
--- CMakeLists.txt.orig 2018-08-07 11:40:49 UTC
+++ CMakeLists.txt
@@ -41,7 +41,6 @@ IF(CMAKE_COMPILER_IS_GNUCC OR (CMAKE_C_C
SET(CMAKE_BUILD_TYPE_DebugFast)
SET(CMAKE_CXX_FLAGS_DEBUGFAST "-g -O0")
SET(CMAKE_C_FLAGS_DEBUGFAST "-g -O0")
- SET(CMAKE_C_FLAGS "-msse2")
if(NOT CMAKE_BUILD_TYPE)
SET(CMAKE_BUILD_TYPE "DebugFast")
endif(NOT CMAKE_BUILD_TYPE)