finance/py-stripe: Update to 1.25.0

- Update to 1.25.0
- Switch to CHEESEHOP for distribution files (Geo-aware CDN)
- Canonicalize COMMENT (According to setup.py:description=)
- Switch to requests (2.x)
- Add TESTS option
- Update TEST_DEPENDS values and assignment
- Replace post-patch with a patch, submitted upstream [1]
- Use PYDISTUTILS_SETUP to ensure its setuptools wrapped
- Run pycurl tests that are disabled by default with this weird reverse
  logic bit of code, issue created upstream [2]

    if not os.environ.get('SKIP_PYCURL_TESTS'):
        self.skipTest('Pycurl skipped as SKIP_PYCURL_TESTS is set'

[1] https://github.com/stripe/stripe-python/pull/170
[2] https://github.com/stripe/stripe-python/issues/172

QA: Ran 195 tests in 44.446s OK (skipped=9)
This commit is contained in:
Kubilay Kocak 2015-09-06 11:43:08 +00:00
parent 3acded794f
commit aeb5f2cef4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=396212
3 changed files with 27 additions and 12 deletions

View File

@ -3,28 +3,32 @@
#
PORTNAME= stripe
PORTVERSION= 1.9.8
PORTREVISION= 2
PORTVERSION= 1.25.0
CATEGORIES= finance python
MASTER_SITES= https://code.stripe.com/stripe/
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= koobs@FreeBSD.org
COMMENT= Python bindings for the Stripe.com payment system
COMMENT= Stripe Python bindings
LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests1>=0.8.8:${PORTSDIR}/www/py-requests1
TEST_DEPENDS:= ${RUN_DEPENDS}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0.8.8:${PORTSDIR}/www/py-requests
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}curl>=7.19:${PORTSDIR}/ftp/py-curl \
${PYTHON_PKGNAMEPREFIX}mock>=1.0.1:${PORTSDIR}/devel/py-mock
OPTIONS_DEFINE= TESTS
TESTS_DESC= Install test suite requirements
TESTS_BUILD_DEPENDS= ${RUN_DEPENDS} \
${TEST_DEPENDS}
USES= python
USE_PYTHON= autoplist distutils
NO_ARCH= yes
post-patch:
@${REINPLACE_CMD} "s|, '../VERSION'||" ${WRKSRC}/setup.py
regression-test: build
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
@cd ${WRKSRC} && ${SETENV} SKIP_PYCURL_TESTS=no ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (stripe-1.9.8.tar.gz) = 6fa50635daf56340fda495b1cb6cbaeefea0b73ef3d1ef4e69cafe9437e52479
SIZE (stripe-1.9.8.tar.gz) = 143137
SHA256 (stripe-1.25.0.tar.gz) = f74090fe0e54209c45b143485fd1f9fa4e60d06bb94cd437a45161c9feef390a
SIZE (stripe-1.25.0.tar.gz) = 175168

View File

@ -0,0 +1,11 @@
--- setup.py.orig 2015-09-06 11:22:57 UTC
+++ setup.py
@@ -54,7 +54,7 @@ setup(
author_email='support@stripe.com',
url='https://github.com/stripe/stripe-python',
packages=['stripe', 'stripe.test'],
- package_data={'stripe': ['data/ca-certificates.crt', '../VERSION']},
+ package_data={'stripe': ['data/ca-certificates.crt']},
install_requires=install_requires,
test_suite='stripe.test.all',
use_2to3=True,