sysutils/lxtask: update to 0.1.10

While here:

 * Remove useless USE_LDCONFIG (no .so installed)
 * Remove post-patch commented target
 * Respect CFLAGS
 * Regenerate patches

Reported by:	portscout
This commit is contained in:
Fernando Apesteguía 2020-10-27 15:03:40 +00:00
parent e4f8161135
commit ae9df7ec0f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=553449
5 changed files with 27 additions and 28 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= lxtask
PORTVERSION= 0.1.9
PORTVERSION= 0.1.10
CATEGORIES= sysutils gnome
MASTER_SITES= SF/lxde/LXTask%20%28task%20manager%29/LXTask%200.1.x/
@ -12,12 +12,14 @@ COMMENT= Lightweight desktop-independent task manager
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
USES= gmake gnome iconv pkgconfig tar:xz
USE_GNOME= gtk20 intlhack
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
CFLAGS= -fcommon
USES= gmake gnome iconv pkgconfig tar:xz
USE_GNOME= cairo gdkpixbuf2 gtk20 intlhack
GNU_CONFIGURE= yes
CFLAGS+= -fcommon
PORTDOCS= AUTHORS README
@ -27,9 +29,6 @@ OPTIONS_SUB= yes
NLS_USES= gettext localbase
NLS_USES_OFF= gettext-tools
# post-patch-NLS-off:
# @${REINPLACE_CMD} -e 's|po src|src|' ${WRKSRC}/Makefile.in
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1603309717
SHA256 (lxtask-0.1.9.tar.xz) = 41ea88f0adf31a840e4b9d137ca5ea802860d1a117845ba25f3080d74a876433
SIZE (lxtask-0.1.9.tar.xz) = 138000
TIMESTAMP = 1603794060
SHA256 (lxtask-0.1.10.tar.xz) = 2216df9bc4bb2d80733e788966512ac58c421e0a0a1ff85210f34a29d1eb4e2c
SIZE (lxtask-0.1.10.tar.xz) = 138116

View File

@ -1,6 +1,6 @@
--- src/main.c.orig 2019-01-13 11:41:23.000000000 -0800
+++ src/main.c 2020-10-21 12:50:26.931353000 -0700
@@ -57,8 +57,6 @@
--- src/main.c.orig 2019-01-13 19:41:23 UTC
+++ src/main.c
@@ -57,8 +57,6 @@ gint win_height;
gint refresh_interval;
guint rID;
@ -9,7 +9,7 @@
int main (int argc, char *argv[])
{
@@ -73,7 +71,6 @@
@@ -73,7 +71,6 @@ int main (int argc, char *argv[])
#endif
gtk_init (&argc, &argv);

View File

@ -1,8 +1,8 @@
--- src/types.h.orig 2019-01-13 11:41:23.000000000 -0800
+++ src/types.h 2020-10-21 12:52:03.313788000 -0700
@@ -80,6 +80,4 @@
const gchar *custom_signal_0;
const gchar *custom_signal_1;
--- src/types.h.orig 2020-10-26 22:55:04 UTC
+++ src/types.h
@@ -77,6 +77,4 @@ extern gboolean full_view;
extern gint win_width;
extern gint win_height;
-extern int page_size;
-

View File

@ -1,5 +1,5 @@
--- src/xfce-taskmanager-linux.c.orig 2019-01-13 13:25:38.000000000 -0800
+++ src/xfce-taskmanager-linux.c 2020-10-21 12:58:00.556146000 -0700
--- src/xfce-taskmanager-linux.c.orig 2019-01-13 21:25:38 UTC
+++ src/xfce-taskmanager-linux.c
@@ -30,6 +30,8 @@
#include "xfce-taskmanager-linux.h"
/* #include <sys/sysinfo.h> */
@ -9,7 +9,7 @@
void get_task_details(pid_t pid,struct task *task)
{
int fd;
@@ -41,7 +43,7 @@
@@ -41,7 +43,7 @@ void get_task_details(pid_t pid,struct task *task)
task->checked=FALSE;
task->size=0;
@ -18,7 +18,7 @@
fd=open(line,O_RDONLY);
if(fd==-1) return;
ret = read(fd,line,255);
@@ -57,7 +59,7 @@
@@ -57,7 +59,7 @@ void get_task_details(pid_t pid,struct task *task)
task->size = t_size * page_size;
task->rss = t_rss * page_size;
@ -27,7 +27,7 @@
fd=open(line,O_RDONLY);
if(fd!=-1)
{
@@ -98,7 +100,7 @@
@@ -98,7 +100,7 @@ void get_task_details(pid_t pid,struct task *task)
if(show_full_path)
{
FILE *fp;
@ -36,7 +36,7 @@
fp=fopen(line,"r");
if(fp)
{
@@ -124,7 +126,7 @@
@@ -124,7 +126,7 @@ void get_task_details(pid_t pid,struct task *task)
else if(len>=15)
{
FILE *fp;
@ -45,7 +45,7 @@
fp=fopen(line,"r");
if(fp)
{
@@ -169,7 +171,7 @@
@@ -169,7 +171,7 @@ void get_task_details(pid_t pid,struct task *task)
task->time_percentage = 0;
task->ppid = ppid;