Update to latest commit.
This commit is contained in:
parent
b7620a40cd
commit
ae928de41b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=529912
@ -46,15 +46,15 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
|
||||
.endif
|
||||
|
||||
# XXX: remove tar:bz2
|
||||
USES= compiler:c11 cpe libedit pkgconfig ssl tar:bz2
|
||||
USES= compiler:c11 cpe libedit libtool pkgconfig ssl tar:bz2
|
||||
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
|
||||
ISCVERSION= 9.17.0a0.2020.02.28
|
||||
ISCVERSION= 9.17.0a0.2020.03.30
|
||||
# XXX: Remove gitlab
|
||||
USE_GITLAB= yes
|
||||
GL_SITE= https://gitlab.isc.org
|
||||
GL_ACCOUNT= isc-projects
|
||||
GL_PROJECT= bind9
|
||||
GL_COMMIT= c309fcabec0f2a2ce3cb7d064efb2b1b8903789a
|
||||
GL_COMMIT= 2df610a882d57fd95221ece4df03c04cd0f702b7
|
||||
|
||||
CPE_VENDOR= isc
|
||||
CPE_VERSION= ${ISCVERSION:C/-.*//}
|
||||
@ -67,13 +67,13 @@ CONFIGURE_ARGS= --disable-linux-caps \
|
||||
--localstatedir=/var \
|
||||
--sysconfdir=${ETCDIR} \
|
||||
--with-dlopen=yes \
|
||||
--disable-shared \
|
||||
--with-libxml2 \
|
||||
--with-openssl=${OPENSSLBASE} \
|
||||
--with-readline="-L${LOCALBASE}/lib -ledit"
|
||||
ETCDIR= ${PREFIX}/etc/namedb
|
||||
|
||||
.if defined(BIND_TOOLS_SLAVE)
|
||||
CONFIGURE_ARGS+= --disable-shared
|
||||
EXTRA_PATCHES= ${PATCHDIR}/extrapatch-bind-tools
|
||||
.else
|
||||
USE_RC_SUBR= named
|
||||
@ -227,8 +227,6 @@ CONFIGURE_ARGS+= --enable-developer \
|
||||
USES+= perl5
|
||||
USE_PERL5= build
|
||||
BUILD_DEPENDS+= cmocka>0:sysutils/cmocka
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-symtable
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1583151235
|
||||
SHA256 (isc-projects-bind9-c309fcabec0f2a2ce3cb7d064efb2b1b8903789a_GL0.tar.gz) = 0d63d733d7d3151f5d68090e7b0e0a6ae727c09b7f03eec9142bb3a4e86c4d9c
|
||||
SIZE (isc-projects-bind9-c309fcabec0f2a2ce3cb7d064efb2b1b8903789a_GL0.tar.gz) = 6313818
|
||||
TIMESTAMP = 1585571421
|
||||
SHA256 (isc-projects-bind9-2df610a882d57fd95221ece4df03c04cd0f702b7_GL0.tar.gz) = 15695727f29d643611cf17d2daa857f8829ddfb7c6beddbabf451ee7958d5fb9
|
||||
SIZE (isc-projects-bind9-2df610a882d57fd95221ece4df03c04cd0f702b7_GL0.tar.gz) = 6345127
|
||||
|
@ -1,8 +1,8 @@
|
||||
Add the override-cache-ttl feature.
|
||||
|
||||
--- bin/named/config.c.orig 2020-02-24 10:03:07 UTC
|
||||
--- bin/named/config.c.orig 2020-03-30 08:17:31 UTC
|
||||
+++ bin/named/config.c
|
||||
@@ -177,6 +177,7 @@ options {\n\
|
||||
@@ -180,6 +180,7 @@ options {\n\
|
||||
notify-source *;\n\
|
||||
notify-source-v6 *;\n\
|
||||
nsec3-test-zone no;\n\
|
||||
@ -10,9 +10,9 @@ Add the override-cache-ttl feature.
|
||||
provide-ixfr true;\n\
|
||||
qname-minimization relaxed;\n\
|
||||
query-source address *;\n\
|
||||
--- bin/named/server.c.orig 2020-02-24 10:03:07 UTC
|
||||
--- bin/named/server.c.orig 2020-03-30 08:17:31 UTC
|
||||
+++ bin/named/server.c
|
||||
@@ -4322,6 +4322,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
|
||||
@@ -4331,6 +4331,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
|
||||
}
|
||||
|
||||
obj = NULL;
|
||||
@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
|
||||
result = named_config_get(maps, "max-cache-ttl", &obj);
|
||||
INSIST(result == ISC_R_SUCCESS);
|
||||
view->maxcachettl = cfg_obj_asduration(obj);
|
||||
--- lib/dns/include/dns/view.h.orig 2020-02-24 10:03:07 UTC
|
||||
--- lib/dns/include/dns/view.h.orig 2020-03-30 08:17:31 UTC
|
||||
+++ lib/dns/include/dns/view.h
|
||||
@@ -152,6 +152,7 @@ struct dns_view {
|
||||
bool requestnsid;
|
||||
@ -34,7 +34,7 @@ Add the override-cache-ttl feature.
|
||||
dns_ttl_t maxncachettl;
|
||||
dns_ttl_t mincachettl;
|
||||
dns_ttl_t minncachettl;
|
||||
--- lib/dns/resolver.c.orig 2020-02-24 10:03:07 UTC
|
||||
--- lib/dns/resolver.c.orig 2020-03-30 08:17:31 UTC
|
||||
+++ lib/dns/resolver.c
|
||||
@@ -6233,6 +6233,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_adb
|
||||
}
|
||||
@ -49,9 +49,9 @@ Add the override-cache-ttl feature.
|
||||
* Enforce the configure maximum cache TTL.
|
||||
*/
|
||||
if (rdataset->ttl > res->view->maxcachettl) {
|
||||
--- lib/isccfg/namedconf.c.orig 2020-02-24 10:03:07 UTC
|
||||
--- lib/isccfg/namedconf.c.orig 2020-03-30 08:17:31 UTC
|
||||
+++ lib/isccfg/namedconf.c
|
||||
@@ -1990,6 +1990,7 @@ static cfg_clausedef_t view_clauses[] = {
|
||||
@@ -1992,6 +1992,7 @@ static cfg_clausedef_t view_clauses[] = {
|
||||
#endif /* ifdef HAVE_LMDB */
|
||||
{ "max-acache-size", &cfg_type_sizenodefault, CFG_CLAUSEFLAG_OBSOLETE },
|
||||
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
|
||||
|
@ -1,6 +1,6 @@
|
||||
Exclude the "tools" from building and installing.
|
||||
|
||||
--- bin/Makefile.in.orig 2019-06-28 12:33:29 UTC
|
||||
--- bin/Makefile.in.orig 2020-03-30 08:17:31 UTC
|
||||
+++ bin/Makefile.in
|
||||
@@ -11,8 +11,8 @@ srcdir = @srcdir@
|
||||
VPATH = @srcdir@
|
||||
@ -13,9 +13,9 @@ Exclude the "tools" from building and installing.
|
||||
TARGETS =
|
||||
|
||||
@BIND9_MAKE_RULES@
|
||||
--- bin/tools/Makefile.in.orig 2019-06-28 12:33:29 UTC
|
||||
--- bin/tools/Makefile.in.orig 2020-03-30 08:17:31 UTC
|
||||
+++ bin/tools/Makefile.in
|
||||
@@ -41,10 +41,7 @@ SUBDIRS =
|
||||
@@ -40,10 +40,7 @@ SUBDIRS =
|
||||
|
||||
DNSTAPTARGETS = dnstap-read@EXEEXT@
|
||||
NZDTARGETS = named-nzd2nzf@EXEEXT@
|
||||
@ -27,7 +27,7 @@ Exclude the "tools" from building and installing.
|
||||
|
||||
DNSTAPSRCS = dnstap-read.c
|
||||
NZDSRCS = named-nzd2nzf.c
|
||||
@@ -120,21 +117,6 @@ dnstap:
|
||||
@@ -119,21 +116,6 @@ dnstap:
|
||||
${INSTALL_DATA} ${srcdir}/dnstap-read.1 ${DESTDIR}${mandir}/man1
|
||||
|
||||
install:: ${TARGETS} installdirs @DNSTAP@ @NZD_TOOLS@
|
||||
|
@ -1,8 +1,8 @@
|
||||
Fixup gssapi and db detection.
|
||||
|
||||
--- configure.orig 2020-02-28 14:30:04 UTC
|
||||
--- configure.orig 2020-03-30 08:17:31 UTC
|
||||
+++ configure
|
||||
@@ -17436,27 +17436,9 @@ done
|
||||
@@ -17391,27 +17391,9 @@ done
|
||||
# problems start to show up.
|
||||
saved_libs="$LIBS"
|
||||
for TRY_LIBS in \
|
||||
@ -32,7 +32,7 @@ Fixup gssapi and db detection.
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
|
||||
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
@@ -17499,47 +17481,7 @@ $as_echo "no" >&6; } ;;
|
||||
@@ -17454,47 +17436,7 @@ $as_echo "no" >&6; } ;;
|
||||
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
|
||||
esac
|
||||
|
||||
@ -81,7 +81,7 @@ Fixup gssapi and db detection.
|
||||
DNS_GSSAPI_LIBS="$LIBS"
|
||||
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
|
||||
@@ -23048,7 +22990,7 @@ $as_echo "" >&6; }
|
||||
@@ -23239,7 +23181,7 @@ $as_echo "" >&6; }
|
||||
# Check other locations for includes.
|
||||
# Order is important (sigh).
|
||||
|
||||
|
@ -49,8 +49,10 @@ include/dns/geoip.h
|
||||
include/dns/ipkeylist.h
|
||||
include/dns/iptable.h
|
||||
include/dns/journal.h
|
||||
include/dns/kasp.h
|
||||
include/dns/keydata.h
|
||||
include/dns/keyflags.h
|
||||
include/dns/keymgr.h
|
||||
include/dns/keytable.h
|
||||
include/dns/keyvalues.h
|
||||
include/dns/lib.h
|
||||
@ -122,6 +124,7 @@ include/irs/resconf.h
|
||||
include/irs/types.h
|
||||
include/irs/version.h
|
||||
include/isc/aes.h
|
||||
include/isc/align.h
|
||||
include/isc/app.h
|
||||
include/isc/assertions.h
|
||||
include/isc/astack.h
|
||||
@ -147,6 +150,7 @@ include/isc/file.h
|
||||
include/isc/formatcheck.h
|
||||
include/isc/fsaccess.h
|
||||
include/isc/fuzz.h
|
||||
include/isc/glob.h
|
||||
include/isc/hash.h
|
||||
include/isc/heap.h
|
||||
include/isc/hex.h
|
||||
@ -168,10 +172,12 @@ include/isc/md.h
|
||||
include/isc/mem.h
|
||||
include/isc/meminfo.h
|
||||
include/isc/mutex.h
|
||||
include/isc/mutexatomic.h
|
||||
include/isc/mutexblock.h
|
||||
include/isc/net.h
|
||||
include/isc/netaddr.h
|
||||
include/isc/netdb.h
|
||||
include/isc/netmgr.h
|
||||
include/isc/netscope.h
|
||||
include/isc/nonce.h
|
||||
include/isc/offset.h
|
||||
@ -233,6 +239,7 @@ include/isccfg/aclconf.h
|
||||
include/isccfg/cfg.h
|
||||
include/isccfg/dnsconf.h
|
||||
include/isccfg/grammar.h
|
||||
include/isccfg/kaspconf.h
|
||||
include/isccfg/log.h
|
||||
include/isccfg/namedconf.h
|
||||
include/isccfg/version.h
|
||||
|
Loading…
Reference in New Issue
Block a user