MFH: r469611
emulators/rpcs3: disable assertions Assertion failed: (ObjectBufferMap.find(Key) == ObjectBufferMap.end() && "Second attempt to perform debug registration."), function NotifyObjectEmitted, file llvm/lib/ExecutionEngine/GDBRegistrationListener.cpp, line 167. Approved by: ports-secteam blanket
This commit is contained in:
parent
ad95343da3
commit
ae42f7a6e6
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q2/; revision=469612
@ -4,6 +4,7 @@ PORTNAME= rpcs3
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.0.5-259
|
||||
DISTVERSIONSUFFIX= -g76a1d0d8f
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= emulators
|
||||
|
||||
MAINTAINER= jbeich@FreeBSD.org
|
||||
|
15
emulators/rpcs3/files/patch-no-asserts
Normal file
15
emulators/rpcs3/files/patch-no-asserts
Normal file
@ -0,0 +1,15 @@
|
||||
https://github.com/RPCS3/rpcs3/issues/3745
|
||||
|
||||
--- rpcs3/CMakeLists.txt.orig 2018-05-09 22:44:51.000000000 +0000
|
||||
+++ rpcs3/CMakeLists.txt
|
||||
@@ -81,6 +81,10 @@ add_custom_command(OUTPUT something_that_never_exists
|
||||
# Check for a sufficient compiler and set build options
|
||||
include(ConfigureCompiler)
|
||||
|
||||
+if(NOT CMAKE_BUILD_TYPE STREQUAL "Debug")
|
||||
+ add_definitions(-DNDEBUG)
|
||||
+endif()
|
||||
+
|
||||
if(WIN32)
|
||||
add_definitions(-DUNICODE)
|
||||
add_definitions(-D_WIN32_WINNT=0x0601)
|
Loading…
Reference in New Issue
Block a user