devel/boost-all: update Boost to 1.79.0 release (+)
Please welcome a longawaited boost-* upgrade. It introduces a full support for OpenSSL3.0, Clang13+, C++17/C++20 standards and more. Since 1.74 release Boost library introduced some internal changes which breaks comsumers of outdated API. All failed consumers will be marked as BROKEN in separated commits. Special thanks for all community members who take a long survey with real environments testing. Changelogs: https://www.boost.org/users/history/version_1_73_0.html https://www.boost.org/users/history/version_1_74_0.html https://www.boost.org/users/history/version_1_75_0.html https://www.boost.org/users/history/version_1_76_0.html https://www.boost.org/users/history/version_1_77_0.html https://www.boost.org/users/history/version_1_78_0.html https://www.boost.org/users/history/version_1_79_0.html PR: 246106 Exp-runs by: antoine
This commit is contained in:
parent
7c80d3875f
commit
ae17808e4a
@ -1,12 +1,12 @@
|
||||
|
||||
PORTVERSION= 1.72.0
|
||||
PORTVERSION= 1.79.0
|
||||
PORTVERSUFFIX= ${PORTVERSION:C/\.[0-9]+$//}
|
||||
DISTNAME= boost_${PORTVERSION:S/./_/g}
|
||||
|
||||
CATEGORIES= devel
|
||||
MAINTAINER= office@FreeBSD.org
|
||||
|
||||
MASTER_SITES= https://dl.bintray.com/boostorg/release/${PORTVERSION}/source/ \
|
||||
MASTER_SITES= https://boostorg.jfrog.io/artifactory/main/release/${PORTVERSION}/source/ \
|
||||
SF/boost/boost/${PORTVERSION}
|
||||
|
||||
USES+= tar:bzip2
|
||||
|
@ -7,8 +7,8 @@ ALL_TARGET= stage
|
||||
USES+= compiler:c++17-lang
|
||||
USE_CXXSTD= gnu++17
|
||||
|
||||
PLIST_SUB+= MAJOR_VER=${PORTVERSION:R:R} \
|
||||
MINOR_VER=${PORTVERSION:R:E} \
|
||||
PLIST_SUB+= BOOST_MAJOR_VER=${PORTVERSION:R:R} \
|
||||
BOOST_MINOR_VER=${PORTVERSION:R:E} \
|
||||
BOOST_SHARED_LIB_VER=${PORTVERSION}
|
||||
|
||||
PKG_MESSAGE_FILE_THREADS= ${PORTSDIR}/devel/boost-all/pkg-message.threads
|
||||
|
@ -5,15 +5,21 @@ COMMENT= Documentation for libraries from boost.org
|
||||
|
||||
USES= python:env shebangfix
|
||||
|
||||
LICENSE= BSL
|
||||
LICENSE_FILE= ${WRKDIR}/${DISTNAME}/LICENSE_1_0.txt
|
||||
|
||||
DOCSDIR= ${PREFIX}/share/doc/boost
|
||||
UNIQ= /usr/bin/uniq
|
||||
|
||||
NO_ARCH= yes
|
||||
NO_BUILD= yes
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
SHEBANG_GLOB= *.py
|
||||
|
||||
PORTDOCS= *
|
||||
|
||||
.include "${.CURDIR}/..//boost-all/common.mk"
|
||||
|
||||
do-install:
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1575937106
|
||||
SHA256 (boost_1_72_0.tar.bz2) = 59c9b274bc451cf91a9ba1dd2c7fdcaf5d60b1b3aa83f2c9fa143417cc660722
|
||||
SIZE (boost_1_72_0.tar.bz2) = 106907358
|
||||
TIMESTAMP = 1649916765
|
||||
SHA256 (boost_1_79_0.tar.bz2) = 475d589d51a7f8b3ba2ba4eda022b170e562ca3b760ee922c146b6c65856ef39
|
||||
SIZE (boost_1_79_0.tar.bz2) = 113456811
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -5,6 +5,8 @@ COMMENT= Build tool from the boost.org
|
||||
|
||||
PLIST_FILES= bin/bjam
|
||||
|
||||
LICENSE= BSL
|
||||
|
||||
EXTRACT_AFTER_ARGS= --no-same-owner --no-same-permissions ${DISTNAME}/${WRKSRC_SUBDIR}
|
||||
MAKE_CMD= ./build.sh
|
||||
ALL_TARGET= ${CHOSEN_COMPILER_TYPE} ${WITH_DEBUG:D--debug}
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1575937106
|
||||
SHA256 (boost_1_72_0.tar.bz2) = 59c9b274bc451cf91a9ba1dd2c7fdcaf5d60b1b3aa83f2c9fa143417cc660722
|
||||
SIZE (boost_1_72_0.tar.bz2) = 106907358
|
||||
TIMESTAMP = 1649916765
|
||||
SHA256 (boost_1_79_0.tar.bz2) = 475d589d51a7f8b3ba2ba4eda022b170e562ca3b760ee922c146b6c65856ef39
|
||||
SIZE (boost_1_79_0.tar.bz2) = 113456811
|
||||
|
@ -1,10 +1,11 @@
|
||||
# Created by: Alexander Churanov <churanov.port.maintainer@gmail.com>
|
||||
|
||||
PORTNAME= boost-libs
|
||||
PORTREVISION= 7
|
||||
|
||||
COMMENT= Free portable C++ libraries (without Boost.Python)
|
||||
|
||||
LICENSE= BSL
|
||||
|
||||
BROKEN_sparc64= https://github.com/boostorg/context/commit/f2ef6326b6ed
|
||||
|
||||
BUILD_DEPENDS+= bjam:devel/boost-jam
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1575937106
|
||||
SHA256 (boost_1_72_0.tar.bz2) = 59c9b274bc451cf91a9ba1dd2c7fdcaf5d60b1b3aa83f2c9fa143417cc660722
|
||||
SIZE (boost_1_72_0.tar.bz2) = 106907358
|
||||
TIMESTAMP = 1649916765
|
||||
SHA256 (boost_1_79_0.tar.bz2) = 475d589d51a7f8b3ba2ba4eda022b170e562ca3b760ee922c146b6c65856ef39
|
||||
SIZE (boost_1_79_0.tar.bz2) = 113456811
|
||||
|
29
devel/boost-libs/files/patch-boost-disable-icu-rpath
Normal file
29
devel/boost-libs/files/patch-boost-disable-icu-rpath
Normal file
@ -0,0 +1,29 @@
|
||||
--- libs/locale/build/Jamfile.v2.orig 2021-04-13 16:22:15 UTC
|
||||
+++ libs/locale/build/Jamfile.v2
|
||||
@@ -65,8 +65,8 @@ ICU_LINK = [ modules.peek : ICU_LINK ] ;
|
||||
|
||||
if $(ICU_LINK)
|
||||
{
|
||||
- ICU_OPTS = <include>$(ICU_PATH)/include <linkflags>$(ICU_LINK) <dll-path>$(ICU_PATH)/bin <runtime-link>shared ;
|
||||
- ICU64_OPTS = <include>$(ICU_PATH)/include <linkflags>$(ICU_LINK) <dll-path>$(ICU_PATH)/bin64 <runtime-link>shared ;
|
||||
+ ICU_OPTS = <include>$(ICU_PATH)/include <linkflags>$(ICU_LINK) <runtime-link>shared ;
|
||||
+ ICU64_OPTS = <include>$(ICU_PATH)/include <linkflags>$(ICU_LINK) <runtime-link>shared ;
|
||||
}
|
||||
else
|
||||
{
|
||||
@@ -124,7 +124,6 @@ else
|
||||
<library>icuuc/<link>shared/<runtime-link>shared
|
||||
<library>icudt/<link>shared/<runtime-link>shared
|
||||
<library>icuin/<link>shared/<runtime-link>shared
|
||||
- <dll-path>$(ICU_PATH)/bin
|
||||
<runtime-link>shared ;
|
||||
|
||||
|
||||
@@ -183,7 +182,6 @@ else
|
||||
<library>icuuc_64/<link>shared/<runtime-link>shared
|
||||
<library>icudt_64/<link>shared/<runtime-link>shared
|
||||
<library>icuin_64/<link>shared/<runtime-link>shared
|
||||
- <dll-path>$(ICU_PATH)/bin64
|
||||
<runtime-link>shared ;
|
||||
|
||||
|
17
devel/boost-libs/files/patch-boost-mpi-python-PEP-328
Normal file
17
devel/boost-libs/files/patch-boost-mpi-python-PEP-328
Normal file
@ -0,0 +1,17 @@
|
||||
--- libs/mpi/build/__init__.py.orig 2021-04-13 16:22:27 UTC
|
||||
+++ libs/mpi/build/__init__.py
|
||||
@@ -1,10 +1,12 @@
|
||||
+from __future__ import absolute_import
|
||||
+
|
||||
import sys
|
||||
if sys.platform == 'linux2':
|
||||
import DLFCN as dl
|
||||
flags = sys.getdlopenflags()
|
||||
sys.setdlopenflags(dl.RTLD_NOW|dl.RTLD_GLOBAL)
|
||||
- import mpi
|
||||
+ from . import mpi
|
||||
sys.setdlopenflags(flags)
|
||||
else:
|
||||
- import mpi
|
||||
+ from . import mpi
|
||||
|
@ -1,43 +0,0 @@
|
||||
https://github.com/boostorg/coroutine/pull/45
|
||||
|
||||
--- boost/coroutine/asymmetric_coroutine.hpp.orig 2019-12-10 00:18:47 UTC
|
||||
+++ boost/coroutine/asymmetric_coroutine.hpp
|
||||
@@ -2361,32 +2361,32 @@ struct coroutine
|
||||
template< typename R >
|
||||
typename pull_coroutine< R >::iterator
|
||||
begin( pull_coroutine< R > & c)
|
||||
-{ return boost::begin( c); }
|
||||
+{ return coroutines::range_begin( c); }
|
||||
|
||||
template< typename R >
|
||||
typename pull_coroutine< R >::const_iterator
|
||||
begin( pull_coroutine< R > const& c)
|
||||
-{ return boost::begin( c); }
|
||||
+{ return coroutines::range_begin( c); }
|
||||
|
||||
template< typename R >
|
||||
typename pull_coroutine< R >::iterator
|
||||
end( pull_coroutine< R > & c)
|
||||
-{ return boost::end( c); }
|
||||
+{ return coroutines::range_end( c); }
|
||||
|
||||
template< typename R >
|
||||
typename pull_coroutine< R >::const_iterator
|
||||
end( pull_coroutine< R > const& c)
|
||||
-{ return boost::end( c); }
|
||||
+{ return coroutines::range_end( c); }
|
||||
|
||||
template< typename R >
|
||||
typename push_coroutine< R >::iterator
|
||||
begin( push_coroutine< R > & c)
|
||||
-{ return boost::begin( c); }
|
||||
+{ return coroutines::range_begin( c); }
|
||||
|
||||
template< typename R >
|
||||
typename push_coroutine< R >::iterator
|
||||
end( push_coroutine< R > & c)
|
||||
-{ return boost::end( c); }
|
||||
+{ return coroutines::range_end( c); }
|
||||
|
||||
}
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- boost/math/tools/config.hpp.orig 2016-09-21 14:33:24 UTC
|
||||
+++ boost/math/tools/config.hpp
|
||||
@@ -28,7 +28,7 @@
|
||||
|
||||
#include <boost/math/tools/user.hpp>
|
||||
|
||||
-#if (defined(__CYGWIN__) || defined(__FreeBSD__) || defined(__NetBSD__) \
|
||||
+#if (defined(__CYGWIN__) || defined(__NetBSD__) \
|
||||
|| (defined(__hppa) && !defined(__OpenBSD__)) || (defined(__NO_LONG_DOUBLE_MATH) && (DBL_MANT_DIG != LDBL_MANT_DIG))) \
|
||||
&& !defined(BOOST_MATH_NO_LONG_DOUBLE_MATH_FUNCTIONS)
|
||||
# define BOOST_MATH_NO_LONG_DOUBLE_MATH_FUNCTIONS
|
@ -1,13 +0,0 @@
|
||||
https://github.com/boostorg/regex/issues/72
|
||||
|
||||
--- boost/regex/config.hpp.orig 2018-10-30 22:45:30 UTC
|
||||
+++ boost/regex/config.hpp
|
||||
@@ -117,7 +117,7 @@
|
||||
* Clang fails to export template instances with -fvisibility=hidden, see
|
||||
* https://github.com/boostorg/regex/issues/49
|
||||
*/
|
||||
-#ifdef __clang__
|
||||
+#if defined(__clang__) || defined(_LIBCPP_VERSION)
|
||||
# define BOOST_REGEX_NO_EXTERNAL_TEMPLATES
|
||||
#endif
|
||||
|
@ -1,69 +0,0 @@
|
||||
From a707db8193b30b6cc4a3d10ee946f7f245e07097 Mon Sep 17 00:00:00 2001
|
||||
From: Christopher Kohlhoff <chris@kohlhoff.com>
|
||||
Date: Tue, 7 Apr 2020 11:18:31 +1000
|
||||
Subject: [PATCH] Support C++20 concept syntax.
|
||||
|
||||
---
|
||||
include/boost/asio/async_result.hpp | 18 +++++++++++-------
|
||||
include/boost/asio/detail/config.hpp | 10 +++++++---
|
||||
2 files changed, 18 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/include/boost/asio/async_result.hpp b/include/boost/asio/async_result.hpp
|
||||
index 2f4b337d1..0eea0f471 100644
|
||||
--- boost/asio/async_result.hpp
|
||||
+++ boost/asio/async_result.hpp
|
||||
@@ -66,9 +66,10 @@ BOOST_ASIO_CONCEPT completion_signature =
|
||||
#define BOOST_ASIO_COMPLETION_SIGNATURE \
|
||||
::boost::asio::completion_signature
|
||||
|
||||
-template <typename T, completion_signature Signature>
|
||||
+template <typename T, typename Signature>
|
||||
BOOST_ASIO_CONCEPT completion_handler_for =
|
||||
- detail::is_completion_handler_for<T, Signature>::value;
|
||||
+ detail::is_completion_signature<Signature>::value
|
||||
+ && detail::is_completion_handler_for<T, Signature>::value;
|
||||
|
||||
#define BOOST_ASIO_COMPLETION_HANDLER_FOR(s) \
|
||||
::boost::asio::completion_handler_for<s>
|
||||
@@ -488,11 +489,14 @@ struct initiation_archetype
|
||||
|
||||
} // namespace detail
|
||||
|
||||
-template <typename T, completion_signature Signature>
|
||||
-BOOST_ASIO_CONCEPT completion_token_for = requires(T&& t)
|
||||
-{
|
||||
- async_initiate<T, Signature>(detail::initiation_archetype<Signature>{}, t);
|
||||
-};
|
||||
+template <typename T, typename Signature>
|
||||
+BOOST_ASIO_CONCEPT completion_token_for =
|
||||
+ detail::is_completion_signature<Signature>::value
|
||||
+ &&
|
||||
+ requires(T&& t)
|
||||
+ {
|
||||
+ async_initiate<T, Signature>(detail::initiation_archetype<Signature>{}, t);
|
||||
+ };
|
||||
|
||||
#define BOOST_ASIO_COMPLETION_TOKEN_FOR(s) \
|
||||
::boost::asio::completion_token_for<s>
|
||||
diff --git a/include/boost/asio/detail/config.hpp b/include/boost/asio/detail/config.hpp
|
||||
index 27d1d6753..6b85cccea 100644
|
||||
--- boost/asio/detail/config.hpp
|
||||
+++ boost/asio/detail/config.hpp
|
||||
@@ -343,10 +343,14 @@
|
||||
// Support concepts on compilers known to allow them.
|
||||
#if !defined(BOOST_ASIO_HAS_CONCEPTS)
|
||||
# if !defined(BOOST_ASIO_DISABLE_CONCEPTS)
|
||||
-# if __cpp_concepts
|
||||
+# if defined(__cpp_concepts)
|
||||
# define BOOST_ASIO_HAS_CONCEPTS 1
|
||||
-# define BOOST_ASIO_CONCEPT concept bool
|
||||
-# endif // __cpp_concepts
|
||||
+# if (__cpp_concepts >= 201707)
|
||||
+# define BOOST_ASIO_CONCEPT concept
|
||||
+# else // (__cpp_concepts >= 201707)
|
||||
+# define BOOST_ASIO_CONCEPT concept bool
|
||||
+# endif // (__cpp_concepts >= 201707)
|
||||
+# endif // defined(__cpp_concepts)
|
||||
# endif // !defined(BOOST_ASIO_DISABLE_CONCEPTS)
|
||||
#endif // !defined(BOOST_ASIO_HAS_CONCEPTS)
|
||||
|
@ -0,0 +1,38 @@
|
||||
--- tools/boost_install/boost-install.jam.orig 2021-04-13 16:23:18 UTC
|
||||
+++ tools/boost_install/boost-install.jam
|
||||
@@ -1252,16 +1252,16 @@ rule boost-install ( libraries * )
|
||||
alias install-libraries-shared : install-libraries-shared-cygwin : <target-os>cygwin ;
|
||||
$(p).mark-target-as-explicit install-libraries-shared ;
|
||||
|
||||
- install install-libraries-shared- : $(libraries) : <location>$(libdir) <install-type>SHARED_LIB <install-type>PDB <install-dependencies>on <install-no-version-symlinks>on ;
|
||||
+ install install-libraries-shared- : $(libraries) : <location>$(libdir) <install-type>SHARED_LIB <install-type>PDB <install-dependencies>on ;
|
||||
$(p).mark-target-as-explicit install-libraries-shared- ;
|
||||
|
||||
- install install-libraries-shared-cygwin : $(libraries) : <location>$(bindir) <install-type>SHARED_LIB <install-type>PDB <install-dependencies>on <install-no-version-symlinks>on ;
|
||||
+ install install-libraries-shared-cygwin : $(libraries) : <location>$(bindir) <install-type>SHARED_LIB <install-type>PDB <install-dependencies>on ;
|
||||
$(p).mark-target-as-explicit install-libraries-shared-cygwin ;
|
||||
|
||||
install install-unprefixed-static : $(unprefixed) : <install-type>STATIC_LIB <conditional>@boost-install%install-subdir ;
|
||||
$(p).mark-target-as-explicit install-unprefixed-static ;
|
||||
|
||||
- install install-unprefixed-shared : $(unprefixed) : <install-type>SHARED_LIB <install-no-version-symlinks>on <conditional>@boost-install%install-subdir ;
|
||||
+ install install-unprefixed-shared : $(unprefixed) : <install-type>SHARED_LIB <conditional>@boost-install%install-subdir ;
|
||||
$(p).mark-target-as-explicit install-unprefixed-shared ;
|
||||
|
||||
install-cmake-config $(libraries) ;
|
||||
@@ -1281,13 +1281,13 @@ rule boost-install ( libraries * )
|
||||
install stage-libraries-static : $(libraries) : <location>$(stage-libdir) <install-dependencies>on <install-type>STATIC_LIB ;
|
||||
$(p).mark-target-as-explicit stage-libraries-static ;
|
||||
|
||||
- install stage-libraries-shared : $(libraries) : <location>$(stage-libdir) <install-dependencies>on <install-type>SHARED_LIB <install-type>PDB <install-no-version-symlinks>on ;
|
||||
+ install stage-libraries-shared : $(libraries) : <location>$(stage-libdir) <install-dependencies>on <install-type>SHARED_LIB <install-type>PDB ;
|
||||
$(p).mark-target-as-explicit stage-libraries-shared ;
|
||||
|
||||
install stage-unprefixed-static : $(unprefixed) : <install-type>STATIC_LIB <conditional>@boost-install%stage-subdir ;
|
||||
$(p).mark-target-as-explicit stage-unprefixed-static ;
|
||||
|
||||
- install stage-unprefixed-shared : $(unprefixed) : <install-type>SHARED_LIB <install-type>PDB <install-no-version-symlinks>on <conditional>@boost-install%stage-subdir ;
|
||||
+ install stage-unprefixed-shared : $(unprefixed) : <install-type>SHARED_LIB <install-type>PDB <conditional>@boost-install%stage-subdir ;
|
||||
$(p).mark-target-as-explicit stage-unprefixed-shared ;
|
||||
|
||||
generate stage-dependencies : $(libraries) : <generating-rule>@boost-install%generate-dependencies <name>stage ;
|
File diff suppressed because it is too large
Load Diff
@ -1,16 +1,18 @@
|
||||
# Created by: Alexander Churanov <churanov.port.maintainer@gmail.com>
|
||||
|
||||
PORTNAME= boost-libs
|
||||
PORTREVISION= 1
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
PATCHDIR= ../boost-libs/files
|
||||
|
||||
COMMENT= Framework for interfacing Python and C++
|
||||
|
||||
LICENSE= BSL
|
||||
|
||||
BUILD_DEPENDS= bjam:devel/boost-jam \
|
||||
${PYNUMPY}
|
||||
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
|
||||
|
||||
USES= python:3.6-3.9 # upper bound inherited from math/py-numpy
|
||||
USES= python:3.7-3.9 # upper bound inherited from math/py-numpy
|
||||
USE_PYTHON= flavors
|
||||
|
||||
OPTIONS_DEFINE= DEBUG OPTIMIZED_CFLAGS
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1575937106
|
||||
SHA256 (boost_1_72_0.tar.bz2) = 59c9b274bc451cf91a9ba1dd2c7fdcaf5d60b1b3aa83f2c9fa143417cc660722
|
||||
SIZE (boost_1_72_0.tar.bz2) = 106907358
|
||||
TIMESTAMP = 1649916765
|
||||
SHA256 (boost_1_79_0.tar.bz2) = 475d589d51a7f8b3ba2ba4eda022b170e562ca3b760ee922c146b6c65856ef39
|
||||
SIZE (boost_1_79_0.tar.bz2) = 113456811
|
||||
|
@ -8,11 +8,11 @@ lib/cmake/boost_python-%%BOOST_SHARED_LIB_VER%%/libboost_python-variant-shared-p
|
||||
lib/cmake/boost_python-%%BOOST_SHARED_LIB_VER%%/libboost_python-variant-static-py%%PYTHON_VER%%.cmake
|
||||
lib/libboost_numpy%%PYTHON_SUFFIX%%.a
|
||||
lib/libboost_numpy%%PYTHON_SUFFIX%%.so
|
||||
lib/libboost_numpy%%PYTHON_SUFFIX%%.so.%%MAJOR_VER%%
|
||||
lib/libboost_numpy%%PYTHON_SUFFIX%%.so.%%MAJOR_VER%%.%%MINOR_VER%%
|
||||
lib/libboost_numpy%%PYTHON_SUFFIX%%.so.%%BOOST_MAJOR_VER%%
|
||||
lib/libboost_numpy%%PYTHON_SUFFIX%%.so.%%BOOST_MAJOR_VER%%.%%BOOST_MINOR_VER%%
|
||||
lib/libboost_numpy%%PYTHON_SUFFIX%%.so.%%BOOST_SHARED_LIB_VER%%
|
||||
lib/libboost_python%%PYTHON_SUFFIX%%.a
|
||||
lib/libboost_python%%PYTHON_SUFFIX%%.so
|
||||
lib/libboost_python%%PYTHON_SUFFIX%%.so.%%MAJOR_VER%%
|
||||
lib/libboost_python%%PYTHON_SUFFIX%%.so.%%MAJOR_VER%%.%%MINOR_VER%%
|
||||
lib/libboost_python%%PYTHON_SUFFIX%%.so.%%BOOST_MAJOR_VER%%
|
||||
lib/libboost_python%%PYTHON_SUFFIX%%.so.%%BOOST_MAJOR_VER%%.%%BOOST_MINOR_VER%%
|
||||
lib/libboost_python%%PYTHON_SUFFIX%%.so.%%BOOST_SHARED_LIB_VER%%
|
||||
|
Loading…
Reference in New Issue
Block a user