- Update to 2.9.9
- Add warning that make_jobs_safe may overwhelm some computers - Portlint PR: ports/152152 Submitted by: Ewgenij Gawrilow <ewgenij.gawrilow@o2online.de> Approved by: maho (mentor)
This commit is contained in:
parent
efb65e9731
commit
adf8d97482
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=276543
@ -6,61 +6,68 @@
|
||||
#
|
||||
|
||||
PORTNAME= polymake
|
||||
PORTVERSION= 2.3
|
||||
PORTREVISION= 3
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= ftp://ftp.math.tu-berlin.de/pub/combi/polymake/
|
||||
|
||||
PATCH_SITES= ${MASTER_SITES}
|
||||
PATCHFILES= ${PORTNAME}-${PORTVERSION}-install.diff
|
||||
PORTVERSION= 2.9.9
|
||||
CATEGORIES= math java
|
||||
MASTER_SITES= http://wwwopt.mathematik.tu-darmstadt.de/polymake/lib/exe/fetch.php/download/
|
||||
|
||||
MAINTAINER= gawrilow@math.tu-berlin.de
|
||||
COMMENT= A framework for experimental discrete geometry
|
||||
|
||||
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
|
||||
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
|
||||
${SITE_PERL}/XML/Writer.pm:${PORTSDIR}/textproc/p5-XML-Writer \
|
||||
${LOCALBASE}/share/xml/dtd/xhtml/xhtml-lat1.ent:${PORTSDIR}/textproc/xhtml
|
||||
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
|
||||
${SITE_PERL}/XML/Writer.pm:${PORTSDIR}/textproc/p5-XML-Writer \
|
||||
${LOCALBASE}/share/xml/dtd/xhtml/xhtml-lat1.ent:${PORTSDIR}/textproc/xhtml \
|
||||
${SITE_PERL}/${PERL_ARCH}/Term/ReadLine/Gnu.pm:${PORTSDIR}/devel/p5-ReadLine-Gnu \
|
||||
${SITE_PERL}/${PERL_ARCH}/XML/LibXSLT.pm:${PORTSDIR}/textproc/p5-XML-LibXSLT \
|
||||
${LOCALBASE}/bin/c++filt:${PORTSDIR}/devel/binutils
|
||||
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
|
||||
readline.[56]:${PORTSDIR}/devel/readline
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_BZIP2= yes
|
||||
USE_PERL5= 5.8.1+
|
||||
USE_GCC= 4.2+
|
||||
USE_JAVA= yes
|
||||
JAVA_BUILD= yes
|
||||
JAVA_RUN= yes
|
||||
JAVA_VERSION= 1.6
|
||||
|
||||
HAS_CONFIGURE= yes
|
||||
INSTALL_TARGET= install install-devel
|
||||
MAKE_JOBS_SAFE= yes
|
||||
MAKE_ENV+= ProcessDep=none
|
||||
NO_INSTALL_MANPAGES= yes
|
||||
|
||||
PLIST= ${WRKDIR}/pkg-plist
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ENV+= JAVA_HOME=${JAVA_HOME}
|
||||
CONFIGURE_ARGS+= --prefix='${PREFIX}' --datadir='${DATADIR}' \
|
||||
--libdir='${PREFIX}/libexec/polymake' \
|
||||
--docdir='${DOCSDIR}' --without-prereq \
|
||||
LDFLAGS='-L${PREFIX}/lib'
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PERL_LEVEL} >= 501000
|
||||
BROKEN= Does not build with perl >= 5.10
|
||||
.if !defined(DISABLE_MAKE_JOBS)
|
||||
pre-fetch:
|
||||
@MAKE_JOBS_NUMBER=${MAKE_JOBS_NUMBER}; \
|
||||
if [ $${MAKE_JOBS_NUMBER} -gt 1 ]; then \
|
||||
${ECHO_CMD} "Building this port uses a lot of CPU power, and a lot of memory to the point"; \
|
||||
${ECHO_CMD} "that swap space might be used extensively. Consider using less threads, as"; \
|
||||
${ECHO_CMD} "this might cause the build to be considerably faster. Currently the build is"; \
|
||||
${ECHO_CMD} "set to use $${MAKE_JOBS_NUMBER} threads. To change to <n> threads, use"; \
|
||||
${ECHO_CMD}; \
|
||||
${ECHO_CMD} "make MAKE_JOBS_NUMBER=<n>"; \
|
||||
fi
|
||||
.endif
|
||||
|
||||
pre-configure:
|
||||
@${REINPLACE_CMD} -e 's|return "$$CXX seems not to be any|\#|' ${WRKSRC}/support/configure.pl
|
||||
|
||||
do-configure:
|
||||
cd ${WRKSRC}; \
|
||||
${RM} -f build*/conf.make; \
|
||||
{ ${ECHO_CMD} CC='${CC}'; \
|
||||
${ECHO_CMD} CXX='${CXX}'; \
|
||||
${ECHO_CMD} Cflags='${CFLAGS} -I${PREFIX}/include'; \
|
||||
${ECHO_CMD} CXXflags='${CXXFLAGS} -I${PREFIX}/include'; \
|
||||
${ECHO_CMD} LDflags='-L${PREFIX}/lib'; \
|
||||
${ECHO_CMD} PREFIX='${PREFIX}'; \
|
||||
${ECHO_CMD} InstallTop='$${PREFIX}/share/polymake'; \
|
||||
${ECHO_CMD} InstallArch='$${PREFIX}/libexec/polymake'; \
|
||||
${ECHO_CMD} InstallDoc='$${PREFIX}${DOCSDIR:S,^${PREFIX},,}'; \
|
||||
${ECHO_CMD} InstallLinks='$${PREFIX}/bin'; \
|
||||
${ECHO_CMD} PerlExe='${PERL}'; \
|
||||
${ECHO_CMD} Arch=; \
|
||||
${ECHO_CMD} ProcessDep=none; \
|
||||
} | ${GMAKE} ${MAKE_ENV} LD=${LD} configure
|
||||
|
||||
pre-install:
|
||||
${RM} -f `find ${WRKSRC} -name '*.orig'`
|
||||
${SED} -e s,%%PERL_REAL_ARCH%%,`${PERL} -e 'use Config; print $$Config{archname}'`, <${.CURDIR}/pkg-plist > ${PLIST}
|
||||
|
||||
post-install:
|
||||
${CP} -p ${PREFIX}/libexec/polymake/Makefile ${PREFIX}/libexec/polymake/Makefile.devel
|
||||
${INSTALL_DATA} ${PREFIX}/libexec/polymake/conf.make ${PREFIX}/libexec/polymake/conf.make.in
|
||||
.if !defined(NOPORTDOCS)
|
||||
${SETENV} POLYMAKE_USER_DIR=${WRKDIR}/.polymake-tmp ${GMAKE} -C ${WRKSRC} docs
|
||||
.endif
|
||||
# Don't use PLIST_SUBS here, as perl might not be installed early enough.
|
||||
@${PERL} -i -pe 'BEGIN{use Config;} s/%%PERL_REAL_ARCH%%/$$Config{archname}/e' ${TMPPLIST}
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,4 +1,2 @@
|
||||
SHA256 (polymake-2.3.tar.bz2) = 3d601cf439c9a07f83bc4253ac2e92cbaefe3f1c2698f9156b6e1683c6d9a5bf
|
||||
SIZE (polymake-2.3.tar.bz2) = 2266143
|
||||
SHA256 (polymake-2.3-install.diff) = 5b548ab37a36d6cca5aa98b3562f31e7a51e08708388b94b81c6f7addfeefeae
|
||||
SIZE (polymake-2.3-install.diff) = 975
|
||||
SHA256 (polymake-2.9.9.tar.bz2) = f914dbb4283e3f11c94d2fa7e0da9383c506e15678fe7b05c52eeb939508215e
|
||||
SIZE (polymake-2.9.9.tar.bz2) = 12656699
|
||||
|
@ -1,13 +0,0 @@
|
||||
--- support/build.make 2007-01-17 16:25:44.000000000 +0000
|
||||
+++ support/build.make 2010-01-28 22:51:05.116780927 +0000
|
||||
@@ -134,10 +134,6 @@
|
||||
endif
|
||||
endif # !SourceDir
|
||||
|
||||
-ifeq "$(COMOversion)$(ICCversion)$(GCCversion)" ""
|
||||
- $(error unknown C++ compiler)
|
||||
-endif
|
||||
-
|
||||
ifdef COMOversion
|
||||
addinclude = -I$(patsubst $/,%,$(dir $(1))) --preinclude $(notdir $(1))
|
||||
make_dep_opt := -MD --no_preproc_only
|
@ -1,13 +1,10 @@
|
||||
Polymake is a versatile framework for experimental discrete geometry.
|
||||
The standard distribution contains tool collections for the algorithmic
|
||||
treatment of polytopes and polyhedra, polyhedral surfaces,
|
||||
and finite simplicial complexes.
|
||||
It offers an unified interface to a wide variety of algorithms
|
||||
and free software packages from the computational geometry field,
|
||||
such as convex hull computation or visualization tools.
|
||||
Polymake is a versatile tool for the algorithmic treatment of
|
||||
polytopes and polyhedra. It offers an unified interface to a wide
|
||||
variety of algorithms and free software packages from the computational
|
||||
geometry field, such as convex hull computation or visualization tools.
|
||||
|
||||
Polymake is highly adaptable to individual needs. In particular, it
|
||||
has a C++/perl interface which allows the user to bind his/her own
|
||||
algorithms into the common framework.
|
||||
The 2.9 series are test versions towards the "next generation" polymake.
|
||||
They introduce an interactive shell, the XML-base file format, more
|
||||
efficient C++/perl interface, and many other new features.
|
||||
|
||||
WWW: http://www.math.tu-berlin.de/polymake/
|
||||
WWW: http://www.polymake.de/
|
||||
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user